View Issue Details

IDProjectCategoryView StatusLast Update
0001123DCP-o-matic[All Projects] Bugspublic2017-09-01 20:03
ReporterCarstenAssigned Tocarl 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS X OS Version10.11
Product Version2.10.5 
Target Version2.12.0Fixed in Version 
Summary0001123: DPX log vs. lin interpretation looks faulty?
DescriptionIn DOM 2.10.5, it looks as if log DPX files were interpreted as linear. This was fixed after it came up in this thread:

http://dcpomatic.com/forum/viewtopic.php?f=2&t=835

However, now it appears that in 2.11.19, linear DPX files are interpreted as log DPX files.

http://dcpomatic.com/forum/viewtopic.php?f=2&t=897

- Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Activities

carl

2017-08-30 22:16

administrator   ~0001792

Thanks Carsten.

hacks/dumpdpx.py shows Rajeev's linear DPXs as being marked "printing density" and the previous log DPX files that I had are marked as "logarithmic". ImageMagick returns LogColorspace for both these header values (see coders/dpx.c). I'm not sure who's wrong here but it looks like we need to make it a manual switch in DoM.

carl

2017-08-30 22:23

administrator   ~0001793

At the moment if we see LogColorspace in an image we call colorSpace to set it back to RGBColorspace. This calls TransformColorSpace which modifies the image; on reflection it looks like we should always do that. But in Rajeev's case it's the wrong thing to do, which is odd as the image being returned from MagickProxyImage::image is always marked as RGB.

carl

2017-09-01 20:00

administrator   ~0001796

I'm hopeful that c0e4fd517192ac25c4aedc406a8a490663ec58b6 (in 2.11.20) helps with this.

carl

2017-09-01 20:03

administrator   ~0001797

I'm marking this as fixed in the hope that it is!

Issue History

Date Modified Username Field Change
2017-08-29 14:35 Carsten New Issue
2017-08-30 21:12 carl Target Version => 2.12.0
2017-08-30 22:16 carl Note Added: 0001792
2017-08-30 22:23 carl Note Added: 0001793
2017-09-01 20:00 carl Note Added: 0001796
2017-09-01 20:03 carl Assigned To => carl
2017-09-01 20:03 carl Status new => resolved
2017-09-01 20:03 carl Resolution open => fixed
2017-09-01 20:03 carl Note Added: 0001797