View Bug Details

IDProjectCategoryView StatusLast Update
0000749DCP-o-matic[All Projects] Bugspublic2016-07-04 14:13
ReporterrobnAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSFedoraOS Version22
Product Version2.5.0 
Target VersionFixed in Version 
Summary0000749: Checking for updates does not work the first time (when "Check for updates on startup" is disabled)
DescriptionWhen the preference "Check for updates on startup" is disabled,
and "Tools / Check for updates" is selected for the first time after
program start-up, nothing happens. Only after the second time you get the
"There are no new versions of DCP-o-matic available."-pop-up.

Did not check if the same happens when a new version *is* available.

(tested with v2.5.3)
Steps To Reproduce
- have up-to-date DCP-o-matic with "Check for updates on startup" disabled
- fresh start DCP-o-matic
- select "Tools / Check for updates" --> nothing happens
- select "Tools / Check for updates" --> "no new versions" pop-up is displayed
TagsNo tags attached.
Estimated work requiredAverage

Activities

carl

2015-11-14 18:28

administrator   ~0000980

Thanks for the report; fixed by f4e6a36244b0838d4f28d44e09d983686d1bd597 which will be in 2.5.4.

robn

2015-11-16 00:50

reporter   ~0000984

The problem was fixed indeed, thanks. But there's a small new snag:

The checkbox "Check for testing updates as well as stable ones"
can only be used if the checkbox "Check for updates on startup"
is enabled.

I assume that one should be able to check for testing updates manually
too (besides on startup)? So then the "Check for testing .." checkbox
should always be active (independent of the startup check)

carl

2015-11-16 00:57

administrator   ~0000985

"Check for testing updates as well as stable ones" only applies to the startup check. The manual check always tells you about both stable and testing updates. Does that make sense?

robn

2015-11-16 01:09

reporter   ~0000986

Ah OK, now I understand the logic! Good that one can verify (actually
always verify) testing updates with the manual check too.

It might confuse some (maybe one? :-) people a bit, but at least there's is
a complete check for the manual case available too!

carl

2015-11-16 01:22

administrator   ~0000987

I've tweaked the name of that option in my local copy so hopefully it is clearer now.

Bug History

Date Modified Username Field Change
2015-11-14 04:39 robn New Bug
2015-11-14 17:50 carl Assigned To => carl
2015-11-14 17:50 carl Status new => confirmed
2015-11-14 18:28 carl Note Added: 0000980
2015-11-14 18:28 carl Status confirmed => resolved
2015-11-14 18:28 carl Resolution open => fixed
2015-11-16 00:50 robn Note Added: 0000984
2015-11-16 00:50 robn Status resolved => feedback
2015-11-16 00:50 robn Resolution fixed => reopened
2015-11-16 00:57 carl Note Added: 0000985
2015-11-16 01:09 robn Note Added: 0000986
2015-11-16 01:09 robn Status feedback => assigned
2015-11-16 01:22 carl Note Added: 0000987
2015-11-16 01:22 carl Status assigned => resolved
2015-11-16 01:22 carl Resolution reopened => fixed