Exported video files out of sync - SERIOUS BUG?

Anything and everything to do with DCP-o-matic.
Post Reply
marcelmax
Posts: 26
Joined: Sun Mar 25, 2018 6:55 pm

Exported video files out of sync - SERIOUS BUG?

Post by marcelmax »

Hi guys,

spent hours on checking sync of 80 exported videos (all ProRes, but same problem with mp4). 12 of them were out of sync (some sec). 5 of those were created from a ProRes with 23,976 fps. The other 7 had nothing special, I could identify.
The procedure was: Created a DCP from source files like ProRes or DCP, then exported to ProRes to keep all changes like ST or sound volume in the new video file same as in DCP. As result 68 of 80 are ok. 12 have a out-of-sync sound.
Preview in DOM looks fine. Newly created DCPs are ok, too.

Take care! Hope, we find the problem.
I can send files, if it helps.

Update: Tried a lot, but the exported videos were out of sync all the time. Finally I had to give up creating ProRes or mp4 with DOM.
carl
Site Admin
Posts: 1468
Joined: Thu Nov 14, 2013 2:53 pm

Re: Exported video files out of sync - SERIOUS BUG?

Post by carl »

Hi,

That does sound nasty - I'm sorry you hit this bug!

If you have the time to help track it down, I have a few questions:
  • Do you know if exporting the same DCP more than once always gives an out-of-sync ProRes result? Or is it intermittent?
  • Do you have the "log" file from inside any of the projects which exported out of sync?
  • Can you describe the sync problem in a bit more detail? How far out is it? (10s of milliseconds? 100s? seconds?) And does it stay out by the same amount, or get slowly worse?
Thanks,
Carl
marcelmax
Posts: 26
Joined: Sun Mar 25, 2018 6:55 pm

Re: Exported video files out of sync - SERIOUS BUG?

Post by marcelmax »

Hi,

thank you.
sorry for delay.

- the out of sync issue appears every time I export. Funny thing: subtitles are sync with audio, which means they're shifted, too.
- I've sent a report with my address: marcel.aigner@20minmax.com
- the sound is about 2 sec later than picture. it looks like it's constant

I can send you a mail with a download link for both, the source file and the exported.

Best
Marcel
carl
Site Admin
Posts: 1468
Joined: Thu Nov 14, 2013 2:53 pm

Re: Exported video files out of sync - SERIOUS BUG?

Post by carl »

Hi Marcel,

Thank you for that. I think it's possible that your problem has been fixed/improved in the current test version of DCP-o-matic... would you be able to try that?

Kind regards,
Carl
marcelmax
Posts: 26
Joined: Sun Mar 25, 2018 6:55 pm

Re: Exported video files out of sync - SERIOUS BUG?

Post by marcelmax »

Thanks!
Tried the 2.15.167 but still same issue.
Sorry...
carl
Site Admin
Posts: 1468
Joined: Thu Nov 14, 2013 2:53 pm

Re: Exported video files out of sync - SERIOUS BUG?

Post by carl »

Thank you for trying it!
If you could send download links for the source file that would be great.
marcelmax
Posts: 26
Joined: Sun Mar 25, 2018 6:55 pm

Re: Exported video files out of sync - SERIOUS BUG?

Post by marcelmax »

sent a mail to Carl with a download link.
carl
Site Admin
Posts: 1468
Joined: Thu Nov 14, 2013 2:53 pm

Re: Exported video files out of sync - SERIOUS BUG?

Post by carl »

Could you please try 2.15.169? I can't reproduce it yet myself but there's a fix for a nasty oversight with exports in that version.
marcelmax
Posts: 26
Joined: Sun Mar 25, 2018 6:55 pm

Re: Exported video files out of sync - SERIOUS BUG?

Post by marcelmax »

Works with 2.15.169. Thank you!!
carl
Site Admin
Posts: 1468
Joined: Thu Nov 14, 2013 2:53 pm

Re: Exported video files out of sync - SERIOUS BUG?

Post by carl »

Great! 8-)
Post Reply