subtitles .ass bug?

Anything and everything to do with DCP-o-matic.
Post Reply
marcelmax
Posts: 10
Joined: Sun Mar 25, 2018 6:55 pm

subtitles .ass bug?

Post by marcelmax » Fri Feb 08, 2019 2:55 pm

Hi,

tried to import .ass file several times. Everytime DOM crashes.
MacOs, DOM 2.12.19
Any idea?

btw: Is there a way to set a background color for subtitles in DOM. That was the reason why I used .ass.

carl
Site Admin
Posts: 979
Joined: Thu Nov 14, 2013 2:53 pm

Re: subtitles .ass bug?

Post by carl » Fri Feb 08, 2019 2:57 pm

Please can you attach the .ass file, or send it to me carl@dcpomatic.com

Do you mean a panel of colour behind the text? That's not supported, but could be (for burn-in only).

marcelmax
Posts: 10
Joined: Sun Mar 25, 2018 6:55 pm

Re: subtitles .ass bug?

Post by marcelmax » Fri Feb 08, 2019 3:04 pm

sent.

carl
Site Admin
Posts: 979
Joined: Thu Nov 14, 2013 2:53 pm

Re: subtitles .ass bug?

Post by carl » Fri Feb 08, 2019 4:08 pm

Thanks. That's a bug; it should be fixed by 2.12.20 and 2.13.112, which I'll try to get out later today.

marcelmax
Posts: 10
Joined: Sun Mar 25, 2018 6:55 pm

Re: subtitles .ass bug?

Post by marcelmax » Fri Feb 08, 2019 4:37 pm

2.13.112 has the same issue

carl
Site Admin
Posts: 979
Joined: Thu Nov 14, 2013 2:53 pm

Re: subtitles .ass bug?

Post by carl » Fri Feb 08, 2019 4:39 pm

Sorry I meant 2.13.113.

marcelmax
Posts: 10
Joined: Sun Mar 25, 2018 6:55 pm

new issue

Post by marcelmax » Sun Feb 10, 2019 12:28 pm

Thanks!!
Now I can import.
But do anyone know why the grey background does not appear in DOM? Seems like the whole font layout is not imported.
Already sent you the .ass file before.

carl
Site Admin
Posts: 979
Joined: Thu Nov 14, 2013 2:53 pm

Re: subtitles .ass bug?

Post by carl » Sun Feb 10, 2019 1:35 pm

That part of the subtitle spec just isn't supported (yet) by DCP-o-matic. I'll add it soon.

Post Reply