Page 1 of 1

Trouble Setting Audio = '12 - 7.1/HI/VI'

Posted: Wed Jun 05, 2019 5:56 pm
by auricula
When using:
Audio = '12 - 7.1/HI/VI'

My DCP will never play back more than 6 tracks.
It's difficult to determine whether this is a DCP-o-matic issue (creation) or a DCP-o-matic Player issue.
I'd like to have access to a working 8-channel DCP to test my player/setup.
Does anyone have one they'd be willing to share, or know where to get, such a DCP ?
Thanks in advance.
Mark

Re: Trouble Setting Audio = '12 - 7.1/HI/VI'

Posted: Wed Jun 05, 2019 6:08 pm
by carl
What sound card are you using and how many channels does it have?

Are you using windows or Mac?

Re: Trouble Setting Audio = '12 - 7.1/HI/VI'

Posted: Wed Jun 05, 2019 10:52 pm
by Carsten
DCP-o-matic certainly does it right creating a 12ch DCP. The downmix or multichannel playback may not reproduce all channels though.

You can load the resulting audio mxf into audacity to see all the channels.

Note that for a 7.1/HI/VI-N DCP, the channel order is:

L/R/C/LFE/LS/RS/HI/VI-N/x/x/BSL/BSR

(x/x being two empty/silent channels). You would need a 12ch playback device or downmix to hear all channels.
Currently, there is no playout channel mapping available in DCP-o-matic or player. However, you can load the resulting 12ch DCP into DCP-o-matic and adjust the audio matrix to shift 7-12 into the range of downmix or playout channels, so you can check them.

The ISDCF SMPTE test DCP contains 7.1 and HI/VI-N tracks, 14 tracks alltogether.
The older unencrypted version is here:
http://isdcf.com/SMPTE-DCP-Content/SMPT ... _SMPTE.zip

You will notice that DCP-o-matic only downmixes channels 1-6. That is not a problem with the DCP.

- Carsten

Re: Trouble Setting Audio = '12 - 7.1/HI/VI'

Posted: Thu Jun 06, 2019 1:30 pm
by auricula
carl wrote:
Wed Jun 05, 2019 6:08 pm
What sound card are you using and how many channels does it have?
Are you using windows or Mac?
I'm using a Mac running Mojave with a 16-channel sound card.
7.1 playback works fine on my rig using other apps that support it.

Re: Trouble Setting Audio = '12 - 7.1/HI/VI'

Posted: Thu Jun 06, 2019 3:26 pm
by carl
What does DCP-o-matic say in the general tab of preferences next to "play sound via"?

Re: Trouble Setting Audio = '12 - 7.1/HI/VI'

Posted: Thu Jun 06, 2019 3:41 pm
by auricula
carl wrote:
Thu Jun 06, 2019 3:26 pm
What does DCP-o-matic say in the general tab of preferences next to "play sound via"?
My device is selected - followed by '16 channels on core audio'.