Programming error

Anything and everything to do with DCP-o-matic.
rahmani
Posts: 60
Joined: Sat Jun 17, 2017 1:24 pm

Programming error

Post by rahmani » Sat Aug 24, 2019 10:53 am

Hi
I am using DOM version 2.13.94 and have I've got this error while adding DCP,
programming error.jpg
programming error.jpg (27.42 KiB) Viewed 589 times
Any comments are welcome.

Carsten
Posts: 1397
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Programming error

Post by Carsten » Sat Aug 24, 2019 5:47 pm

I suggest you upgrade to 2.14.8 and try again - 2.13.158 was the last 2.13.x test version, so, a lot of issues have been solved since 2.13.94.
But this may also indicate a transfer/storage issue with the DCP you added. You may check that DCP explicitly for integrity with the verification feature in DCP-o-matic player 2.14.8.


- Carsten

rahmani
Posts: 60
Joined: Sat Jun 17, 2017 1:24 pm

Re: Programming error

Post by rahmani » Mon Aug 26, 2019 10:36 am

Hi
I've upgraded to 2.14.8 and got a fresh copy of the DCP but, still have got the same error with a small change in a value 199 instead of 198:
Programming error199.jpg
Programming error199.jpg (28.79 KiB) Viewed 557 times
Your Kind help are appreciated.

Carsten
Posts: 1397
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Programming error

Post by Carsten » Mon Aug 26, 2019 1:04 pm

Can you check the DCP you add in DCP-o-matic player 2.14.8 with 'Tools' - 'Verify'? Maybe it is not a programming error, but a bad DCP that makes DCP-o-matic crash.

-Carsten

rahmani
Posts: 60
Joined: Sat Jun 17, 2017 1:24 pm

Re: Programming error

Post by rahmani » Mon Aug 26, 2019 5:27 pm

The DOM player doesn't import the DCP to use Tools-->Verify and in the first stage the error message will appeared.

Carsten
Posts: 1397
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Programming error

Post by Carsten » Mon Aug 26, 2019 8:19 pm

I would think that DCP is broken (or, very 'unusual'). Where does it come from? Can you request it again from there? Do other DCPs work for you?

You may try to send just the metadata files (leaving out all the large MXF files) zipped to Carl. However, Carl may be busy currently relocating, so, it may take a while.

- Carsten

rahmani
Posts: 60
Joined: Sat Jun 17, 2017 1:24 pm

Re: Programming error

Post by rahmani » Tue Aug 27, 2019 2:00 pm

Yes, no problem for other DCP. I've tried a fresh copy from film distributor again and the result was the same as before, The XML files have been sent to the Carl.
Your help is highly appreciated.

rahmani
Posts: 60
Joined: Sat Jun 17, 2017 1:24 pm

Re: Programming error

Post by rahmani » Sun Sep 01, 2019 8:22 am

Hi everyone;
Again another new DCP fail to load into DOM!!
I tried to check two DCPs one of them fully verified in DOM(of course this film has been played once in DOM months ago) and the other(new film) not loaded into DOM because of "Programming error ..199" by two different methods. First I tried EasyDCP demo version for validating both, the result was the same:
validation report easyDCP.png
validation report easyDCP.png (84.94 KiB) Viewed 473 times
And second, I changed the hashes from Base64 to HEX in PKL file by a Text-converter software and then save it into a file "*.sha1" and verify the hashes by Total-Commander software for both DCPs, and again the result for both was the same and no error found in the wrong DCP-package for DOM!!
Hash check.jpg
Hash check.jpg (14.17 KiB) Viewed 473 times
I don't know what to do really is a nightmare!
I appreciate any kind of help to pass this nightmare!!

Solomon

rahmani
Posts: 60
Joined: Sat Jun 17, 2017 1:24 pm

Re: Programming error

Post by rahmani » Sun Sep 01, 2019 8:54 am

I have got another DCP which has been made by Qubmaster Pro 2.6.1.1. and loaded into the DOM Successfully but, another new film has been made by ClipsterDCI 5.10.0.5 not loaded into DOM!!

I think the only person is Carl to give us a helping hand! :(

rahmani
Posts: 60
Joined: Sat Jun 17, 2017 1:24 pm

Re: Programming error

Post by rahmani » Fri Sep 13, 2019 9:46 am

Hi Folks;

Still waiting for Carl reply regarding this issue.
No body has the same problem for any DCP? I need your advice and comments kindly share your experiences ;)

@Carl; Please have a look at XML files which have been sent via email and let me know what to do?


Solomon

Post Reply