Audio delay out on video

Anything and everything to do with DCP-o-matic.
Carsten
Posts: 1477
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Audio delay out on video

Post by Carsten » Thu Nov 07, 2019 8:10 pm

With data rate I mean J2K bandwidth for compression. But I see that is set to 125MBit/s - perfectly okay.


sigh... this 'Maniac' project looks completely normal. A standard Bluray rip to MKV. Nothing special. Did that many times before, never had issues...

Maybe I'll get the time to do a run with 2.14.13 as well. Maybe it happens here as well.

- Carsten

Alta
Posts: 5
Joined: Fri Nov 01, 2019 12:04 am

Re: Audio delay out on video

Post by Alta » Thu Nov 07, 2019 10:14 pm

Thank you Carsten.

Maybe a strange karma on the Maniac movie ;)
To follow.

I have another film (Tammy and the T-Rex!!!) to make for a screening next week, with French subtitles. I will check if I see a difference between audio/video at the end of the DCP. I will keep you informed after my test next week.

Nico

scozz76
Posts: 41
Joined: Sun May 15, 2016 10:13 am

Re: Audio delay out on video

Post by scozz76 » Sun Nov 10, 2019 7:42 am

After reading this I was concerned so I processed 1h 41m feature at the same bitrate on 2.14.13... No sync issues.
No sub's - Multiple reels.

scozz76
Posts: 41
Joined: Sun May 15, 2016 10:13 am

Re: Audio delay out on video

Post by scozz76 » Sun Nov 10, 2019 7:43 am

After reading this I was concerned so I processed 1h 41m feature at the same bitrate on 2.14.13... No sync issues.
No sub's - Multiple reels. Original content was mp4 with 2 track audio.

Carsten
Posts: 1477
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Audio delay out on video

Post by Carsten » Sun Nov 10, 2019 1:06 pm

Would be interesting to know wether issues like this persist with certain source files. That would lead to some specific audio streams/codecs causing problems.

- Carsteb
Last edited by Carsten on Mon Nov 11, 2019 11:57 am, edited 1 time in total.

carl
Site Admin
Posts: 1087
Joined: Thu Nov 14, 2013 2:53 pm

Re: Audio delay out on video

Post by carl » Mon Nov 11, 2019 10:42 am

Thanks to a video file sent in the post (!) by a helpful user I think I have an idea what's going on here. This video file has frames with duplicate presentation time stamps, and it would appear that tools like ffplay ignore these duplicate timestamp and play all the frames anyway. DCP-o-matic doesn't, so it drops them, causing sync problems. I'll push out a new test version once I have made some more local tests.

Carsten
Posts: 1477
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Audio delay out on video

Post by Carsten » Mon Nov 11, 2019 12:15 pm

Could you see which software was used for that RIP? Is this embedded in the original optical media, or has it been introduced by the ripping software?

- Carsten

carl
Site Admin
Posts: 1087
Joined: Thu Nov 14, 2013 2:53 pm

Re: Audio delay out on video

Post by carl » Mon Nov 11, 2019 11:33 pm

I'm not sure; I'll try to find out. I don't have the optical media, just the rip. 2.15.32 has the fix, if anyone would like to try it. Go easy though, it's a fairly deep change...

carl
Site Admin
Posts: 1087
Joined: Thu Nov 14, 2013 2:53 pm

Re: Audio delay out on video

Post by carl » Mon Nov 11, 2019 11:41 pm

DVDFab was the ripping program. I'm not blaming it at all at this point!

Carsten
Posts: 1477
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Audio delay out on video

Post by Carsten » Tue Nov 12, 2019 1:17 am

And the format of the file and the codec was?

- Carsten

Post Reply