Could not open film at Duplicate XML tag Text

Anything and everything to do with DCP-o-matic.
Post Reply
bnm14777
Posts: 21
Joined: Fri Jun 08, 2018 8:12 am

Could not open film at Duplicate XML tag Text

Post by bnm14777 »

Use DCP-o-matic to create a new project, add an encrypted DCP package with subtitles, use DKDM to decrypt, you cannot open it again after saving the project, and you cannot import batch transcoding server programs. Use the latest Stable release and Test version on MAC and WINDOWS The following errors occur under the system, I do not know how to solve them?
3.png
3.png (61.37 KiB) Viewed 756 times

IoannisSyrogiannis
Posts: 29
Joined: Mon Nov 13, 2017 8:40 pm

Re: Could not open film at Duplicate XML tag Text

Post by IoannisSyrogiannis »

Last time I had that problem it was that on the metadata.xml file of the project there were (for some peculiar reason) two Content entries of subtitles.
I edited with a text editor the file and removed the one of them (the one that seemed irrelevant) and that was it.
In case you have the same problem, I suggest backing up the metadata.xml and trying the same.

Edit: I would check there if there is any reference that goes to nowhere (due to files moved).

bnm14777
Posts: 21
Joined: Fri Jun 08, 2018 8:12 am

Re: Could not open film at Duplicate XML tag Text

Post by bnm14777 »

Thank you IoannisSyrogiannis The attachment is my metadata file, I didn't find it wrong, if you know, can you help me see it?
Attachments
metadata - 副本.xml
metadata.xml
(24.09 KiB) Downloaded 22 times

IoannisSyrogiannis
Posts: 29
Joined: Mon Nov 13, 2017 8:40 pm

Re: Could not open film at Duplicate XML tag Text

Post by IoannisSyrogiannis »

In order not to upload files and get things harder, I will just suggest a solution.
After backing up the file, I see that the subtitles are listed twice. (The error pop-up window was saying so.)
Try to remove one of them, save and then re-open the project.

Code: Select all

      <Text>
        <Use>0</Use>
        <Burn>0</Burn>
        <XOffset>0</XOffset>
        <YOffset>0</YOffset>
        <XScale>1</XScale>
        <YScale>1</YScale>
        <Language></Language>
        <LineSpacing>1</LineSpacing>
        <OutlineWidth>4</OutlineWidth>
        <Type>open-subtitle</Type>
        <OriginalType>open-subtitle</OriginalType>
      </Text>

Edit:
I see that you are trying to open the project on a Mac (/Volumes/...) while it is most probably created on Windows (E:\TEST_FTR-2_S_CS-EN_INT-TL_51-XX_4K_20191003_UPP_SMPTE_OV_1910TVS1694\).
I don't think the whole thing will work, unless you make a DKDM for that DCP-o-matic and correct on the metadata.xml file the path to every file.
The program will (either) ask you for a (D)KDM and(/or) it won't find the DCP where it is described to be.

bnm14777
Posts: 21
Joined: Fri Jun 08, 2018 8:12 am

Re: Could not open film at Duplicate XML tag Text

Post by bnm14777 »

Thank you for your guidance. After I delete one of the sections, I can open the project, but the following error window will be promptly displayed, which will cause the program to exit automatically.


The DCP package you created in MAC is because the same error occurred on both of my computers. The previous screenshot was taken in MAC. I just switched the computer. So I used the package created by the WINDOWS computer when uploading the XML file.
Attachments
1.png
1.png (17.1 KiB) Viewed 745 times

carl
Site Admin
Posts: 1191
Joined: Thu Nov 14, 2013 2:53 pm

Re: Could not open film at Duplicate XML tag Text

Post by carl »

Hi there,

I think your problems are being caused by

1. switching between "release" and "test" versions, and
2. some bugs in DCP-o-matic

The `Duplicate XML tag Text` error is most likely caused by trying to load a project saved by 2.15.x into 2.14.x.

The `SwsContext` error is a bug when loading old 2.14.x projects into 2.15.x; it is fixed locally and should be OK in 2.15.78 which I'll upload over the next 12 hours or so.

bnm14777
Posts: 21
Joined: Fri Jun 08, 2018 8:12 am

Re: Could not open film at Duplicate XML tag Text

Post by bnm14777 »

Thank you, carl, if you have any questions, I will always get your solution

carl
Site Admin
Posts: 1191
Joined: Thu Nov 14, 2013 2:53 pm

Re: Could not open film at Duplicate XML tag Text

Post by carl »

If you would like to try 2.15.78 it would be good to hear how you get on.

bnm14777
Posts: 21
Joined: Fri Jun 08, 2018 8:12 am

Re: Could not open film at Duplicate XML tag Text

Post by bnm14777 »

Thanks carl in the new version no longer has the previous problem

Post Reply