Page 1 of 1

audio sync w/DVD only

Posted: Wed Jul 29, 2020 12:44 pm
by techtrek2010
hello, i just got into using DCP o'matic to help out my local theater to be able to exhibit films for our summer kids shows. through my testing with various DVD & Blu-Ray rips I have from my personal collection I have not had any issues until I went to start making the theaters library which consist of all DVD's. I use Make MKV to rip the files and they play back in VLC no problem, but as soon as I pull them into DCP O'Matic it throws the audio way out of sync with the video by about 5-15 seconds. I tried running a file through handbrake and that made the initial playback in the tool correct but after creating the DCP it throws the audio out of sync again. I have not had this issue when running Blu-rays through. ive done one in English and one in Japanese with English subs and both played back perfect on our projection setup. any thoughts on what is occurring here?

Thanks!

Re: audio sync w/DVD only

Posted: Wed Jul 29, 2020 12:46 pm
by carl
Hi, if you look in one of your out-of-sync projects there should be files called ffprobe.log, log and metadata.xml. Please can you send me those? carl@dcpomatic.com

Re: audio sync w/DVD only

Posted: Thu Jul 30, 2020 12:34 am
by nshack68
I am having this same exact issue. My first project made from a blu-ray worked perfectly. Now on my second attempt with a DVD in two weeks and both times the sound is off by 8 seconds or more (playback is fine in VLC). Today I attempted with separate video and audio files and have the same issue when put together in DCP-o-matic. I have emailed you the two files mentioned above just now and hopefully you can give me some insight.

Re: audio sync w/DVD only

Posted: Sat Aug 01, 2020 10:17 pm
by carl
Hi all,

Thanks for your help with this. I think I've traced the bug to a fix I applied a couple of months ago (for a different problem) which turns out to be completely wrong! :oops:

I should be able to get a fixed version out for testing by some time on Monday (or Sunday if the wind is behind me). I'll add a note to the thread when a new version is available.

Re: audio sync w/DVD only

Posted: Mon Aug 03, 2020 5:32 pm
by carl
Here is a test version which should fix this problem (NTSC DVD rips being massively out of sync). Please let me know how you get on if you try it - thanks!

Re: audio sync w/DVD only

Posted: Mon Aug 10, 2020 1:34 pm
by carl
Did anybody try the test version?

Re: audio sync w/DVD only

Posted: Fri Sep 11, 2020 1:37 pm
by AReedy
I'm having this issue, too, when using MakeMKV. The DVD version of the movie is off 8-15 seconds. The Blu-Ray version audio is ahead like 2 seconds from the video. I've made lots of DCP's from my own MP4's. This is my first time using MKV. I'm using version 2.14.37 for Windows 10.