Suddenly weird errors when verifying DCP with Player

Anything and everything to do with DCP-o-matic.
ErikSchuit
Posts: 4
Joined: Mon Apr 04, 2022 9:22 am

Suddenly weird errors when verifying DCP with Player

Post by ErikSchuit »

When verifying DCP's that I checked before (and that gave no errors), I now get this:

Errors:
The XML in is malformed on line 0 (unable to open primary document entity 'C:\Program Files\DCP-o-matic 2\xsd\DCDMSubtitle-2014.xsd').
The XML in is malformed on line 0 (unable to open primary document entity 'C:\Program Files\DCP-o-matic 2\xsd\DCDMSubtitle-2014.xsd').
There is a <EntryPoint> tag inside a <MainMarkers>.
There is a <Duration> tag inside a <MainMarkers>.
The XML in is malformed on line 0 (unable to open primary document entity 'C:\Program Files\DCP-o-matic 2\xsd\DCDMSubtitle-2014.xsd').
The XML in is malformed on line 0 (unable to open primary document entity 'C:\Program Files\DCP-o-matic 2\xsd\DCDMSubtitle-2014.xsd').

Warning:
<IssueDate> has an invalid value 2023-03-07T12:29:00.000+01:00

I have removed DCP-o-matic and the C:\Users\xxxx\AppData\Local\dcpomatic2 folder, reinstalled 2.16.47 to no avail. DCP does play fine though. Subs are pretty low, I see, almost hitting the bottom (with DCP-o-matic Player.

Help!
ErikSchuit
Posts: 4
Joined: Mon Apr 04, 2022 9:22 am

Re: Suddenly weird errors when verifying DCP with Player

Post by ErikSchuit »

OK, update.

Created the DCP from scratch on another computer with version 2.16.26. Verified with DCP-o-matic Player 2.16.26 and all was fine.

I then verified that new DCP with DCP-o-matic Player 2.16.47 on my computer and got errors/warning.

I updated that other computer to 2.16.47, verified with DCP-o-matic Player 2.16.47 and presto, errors:

The XML in is malformed on line 0 (unable to open primary document entity 'C:\Program Files\DCP-o-matic 2\xsd\DCDMSubtitle-2014.xsd').
The XML in is malformed on line 0 (unable to open primary document entity 'C:\Program Files\DCP-o-matic 2\xsd\DCDMSubtitle-2014.xsd').
The XML in is malformed on line 0 (unable to open primary document entity 'C:\Program Files\DCP-o-matic 2\xsd\DCDMSubtitle-2014.xsd').
The XML in is malformed on line 0 (unable to open primary document entity 'C:\Program Files\DCP-o-matic 2\xsd\DCDMSubtitle-2014.xsd').

Warning:
<IssueDate> has an invalid value 2023-03-16T00:47:41.000+01:00

I noticed that in C:\Program Files\DCP-o-matic 2\xsd\ there is no file called DCDMSubtitle-2014.xsd, but there is a file called DCDMSubtitle-2010.xsd. I copied that file, renamed it to DCDMSubtitle-2014.xsd.

Verifying now says:

Errors:
There is a <EntryPoint> tag inside a <MainMarkers>.
There is a <Duration> tag inside a <MainMarkers>.

Warning:
<IssueDate> has an invalid value 2023-03-06T23:31:50.000+01:00

So, it seems something goes wrong with DCDMSubtitle-2014.xsd and/or DCDMSubtitle-2010.xsd?
Carsten
Posts: 2701
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Suddenly weird errors when verifying DCP with Player

Post by Carsten »

Yeah, the malformed XML thingy pops up occasionally. Maybe Carl can tell us what it actually complains about. From other threads, I thought it was a bug that should have been ironed out already, but don't know about that between test and release versions. As far as I understood so far, you can ignore it.

Those subtitle XSDs to my knowledge are a different thin and turn up with recent changes to the subtitle management, respectively, the way subtitles are meant to be rendered as to two different SMPTE specs from 2010 and 2014. You should not change these files manually, as specific versions of DCP-o-matic will need to deal with them in a specific way.

From your description, I guess Carl will sort it out. Unfortunately, I can't recommend a specific version that would work for you currently.


That entry point 'error' is not an error. It deals with two different metadata requirements. Maybe I was right writing this: https://dcpomatic.com/forum/viewtopic.p ... 169#p10169
carl
Site Admin
Posts: 2416
Joined: Thu Nov 14, 2013 2:53 pm

Re: Suddenly weird errors when verifying DCP with Player

Post by carl »

Hi,
Thanks for the report. There's a missing file in the Windows installer. I'll post a link to a new build to try out soon.
That entry point 'error' is not an error
I think it is. The CPL standard says that EntryPoint and Duration should not be present in markers tags. DCP-o-matic got this wrong until 2.16.8.
Carsten
Posts: 2701
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Suddenly weird errors when verifying DCP with Player

Post by Carsten »

Ooops, I mistook that as the FFEC/FFMC marker requirement for FTR vs. other content types. Still, 'error' or 'warning'?


What is this 'XML malformed' thing? Is it because the XML file does not comply with an XSD, or is it due to some 'low level' character issues, like LF/CR, indentation, etc.?
carl
Site Admin
Posts: 2416
Joined: Thu Nov 14, 2013 2:53 pm

Re: Suddenly weird errors when verifying DCP with Player

Post by carl »

Ooops, I mistook that as the FFEC/FFMC marker requirement for FTR vs. other content types. Still, 'error' or 'warning'?
Hard to say - it's quite difficult to decide with most of the errors/warnings to be honest!
What is this 'XML malformed' thing? Is it because the XML file does not comply with an XSD, or is it due to some 'low level' character issues, like LF/CR, indentation, etc.?
I think it's just a misleading error caused by the XSD not being there. It's missing from the installer on Windows.
carl
Site Admin
Posts: 2416
Joined: Thu Nov 14, 2013 2:53 pm

Re: Suddenly weird errors when verifying DCP with Player

Post by carl »

The XML malformed errors should be gone in this build if anybody wants to try it out.
Carsten
Posts: 2701
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Suddenly weird errors when verifying DCP with Player

Post by Carsten »

I think I have seen it before with much older builds. Probably when using different versions for creation and verification, if I remember correctly.

I do admit, it could be just a hint or warning in general, but,from the point of strict validation, it would indeed be an error. Even if it would never cause an actual issue on any existing server.


sigh...I had thought it becomes more easy with the SMPTE DCP.


- Carsten
carl
Site Admin
Posts: 2416
Joined: Thu Nov 14, 2013 2:53 pm

Re: Suddenly weird errors when verifying DCP with Player

Post by carl »

Right, when it's working properly it should mean that some part of the XML doesn't match the XSD.
stephenv2
Posts: 10
Joined: Tue Mar 09, 2021 8:40 pm

Re: Suddenly weird errors when verifying DCP with Player

Post by stephenv2 »

Yep, just got the same error here are current stable version.
Post Reply