DCP glitches putting audio out of synch

Anything and everything to do with DCP-o-matic.
Post Reply
Skeletim
Posts: 5
Joined: Tue Jun 18, 2024 3:48 pm

DCP glitches putting audio out of synch

Post by Skeletim »

I have been using DCP-O-Matic for a number of years creating tons of DCPs with no issues until recently. Almost every time I go to create a Feature DCP I have an issue where it glitches in the first 6-15 minutes of the film and puts the audio way out of synch. This doesn't happen for shorts, trailers or policy clips, just Features.

This started when I switched to a new computer after my old one died. Since then I have tried running numerous versions of DCP-o-Matic on two different computers but it keeps happening 9 out of 10 times. Each time the glitch happens at a random moment in the runtime but often in the first 15min.

Has anyone encountered this and if so do you have any suggestions on what I could try?
carl
Site Admin
Posts: 2429
Joined: Thu Nov 14, 2013 2:53 pm

Re: DCP glitches putting audio out of synch

Post by carl »

Are you seeing these glitches on a projector, or when playing back on a computer?
Skeletim
Posts: 5
Joined: Tue Jun 18, 2024 3:48 pm

Re: DCP glitches putting audio out of synch

Post by Skeletim »

Both. I downloaded the DCP player to test on my computer to save time driving to the theater with the hard drive and then repeating the process when it didn't work but it shows up the same on screen at the theater.

The picture sort of freezes and hiccups for a second and then the audio is drastically out of such after that.
carl
Site Admin
Posts: 2429
Joined: Thu Nov 14, 2013 2:53 pm

Re: DCP glitches putting audio out of synch

Post by carl »

You could send the log file from inside one of your failed projects to carl@dcpomatic.com - maybe there are some clues there.
Skeletim
Posts: 5
Joined: Tue Jun 18, 2024 3:48 pm

Re: DCP glitches putting audio out of synch

Post by Skeletim »

Just sent that over to you!
carl
Site Admin
Posts: 2429
Joined: Thu Nov 14, 2013 2:53 pm

Re: DCP glitches putting audio out of synch

Post by carl »

Thanks, something bad is happening when decoding the MKV file. This kind of stuff is bad news:

Code: Select all

Tue Jun 18 01:09:11 2024: FFmpeg: [matroska,webm @ 0x320866000] 0x00 at pos 1874659516 (0x6fbd08bc) invalid as first byte of an EBML number
Tue Jun 18 01:09:11 2024: FFmpeg: [matroska,webm @ 0x320866000] 0x00 at pos 1874661842 (0x6fbd11d2) invalid as first byte of an EBML number
Tue Jun 18 01:09:11 2024: Reset audio position: was 18206272, new data at 18256046, slack: 49774 frames
Tue Jun 18 01:09:11 2024: Reset audio position: was 18206272, new data at 18256046, slack: 49774 frames
Tue Jun 18 01:09:11 2024: Reset audio position: was 18206272, new data at 18256046, slack: 49774 frames
Tue Jun 18 01:09:11 2024: Reset audio position: was 18206272, new data at 18256046, slack: 49774 frames
Tue Jun 18 01:09:11 2024: FFmpeg: [ac3 @ 0x126774400] exponent -1 is out-of-range
Tue Jun 18 01:09:11 2024: FFmpeg: [ac3 @ 0x126774400] error decoding the audio block
It would be interesting to try with the test version as that has a newer version of the decoding library (FFmpeg). It's also not out of the question that there's some weird problem with the remote volume that the file is on ...
Skeletim
Posts: 5
Joined: Tue Jun 18, 2024 3:48 pm

Re: DCP glitches putting audio out of synch

Post by Skeletim »

Thank you! I will try out this test version and report back what happens.

It is definitely possible that the remote volume is causing issues but I have tried crating the DCPs to numerous different drives and directly onto my desktop & laptop to have this issue happen. So I feel like I've ruled that out as a factor but at this point I am totally open to any/all suggestions. I will start with this test version.
carl
Site Admin
Posts: 2429
Joined: Thu Nov 14, 2013 2:53 pm

Re: DCP glitches putting audio out of synch

Post by carl »

Right, if the test version is no better perhaps you could make sure that both source and DCP are onto local drives, and see how that goes. There have been various reports/rumours of problems with remote volumes that I've never yet managed to pin down unfortunately.
Carsten
Posts: 2711
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: DCP glitches putting audio out of synch

Post by Carsten »

I just created a number of long feature DCPs from MKV with the current version and have not experienced an issue like that. So at least it does not seem to be a fundamental bug in the current code.

- Carsten
Skeletim
Posts: 5
Joined: Tue Jun 18, 2024 3:48 pm

Re: DCP glitches putting audio out of synch

Post by Skeletim »

I created two separate feature DCPs last night using this new version and they both worked great. It looks like that likely fixed whatever was going on for me.
Thank you!!
Post Reply