MP4 to DCP Audio Sync Issues

Anything and everything to do with DCP-o-matic.
Post Reply
digiopamp
Posts: 4
Joined: Fri Jan 24, 2020 12:12 am

MP4 to DCP Audio Sync Issues

Post by digiopamp »

Hi,

We use DCP-O-Matic to create DCP trailers for our cinema (thank you for the great product!). We have been using the program for three years and haven't had a problem until this last month or so. We create 23.976 mp4's with AAC audio & constant frame rates out of Adobe Premiere Pro and then convert them to DCPs. However we have been experiencing audio sync issues for the last few DCPs we have made. The audio appears to be pushed about a third of a second after the video. The original mp4s do not have this problem. We are using version 2.14.23

Any help on this would be great if anyone else has solved this problem. We can provide file details or metadata if it helps.

carl
Site Admin
Posts: 1129
Joined: Thu Nov 14, 2013 2:53 pm

Re: MP4 to DCP Audio Sync Issues

Post by carl »

If you could send the metadata.xml and log files from one of your problematic project folders to carl@dcpomatic.com that would be great.

Did anything change in how you made your DCPs before it stopped working?

digiopamp
Posts: 4
Joined: Fri Jan 24, 2020 12:12 am

Re: MP4 to DCP Audio Sync Issues

Post by digiopamp »

Sorry for the late reply. We were testing the sync on our system to make sure it was not something with our new DCP Server. Within the last two months we have upgraded one of our DCP servers to a GDC SR-1000, and this is where the audio sync problems occur. We have another older GDC server (GDC SX-2001 AR) that does not have these issues when playing the DCP-O-Matic files. The new DCP server has been the only thing that has changed in our booth, and we are using the most up to date version of DCP-O-Matic. Sync issues do not occur on our feature DCPs, only those made from mp4s through the DCP-O-Matic program.

I have emailed the log and metadata files from one of our problem DCPs. Thank you for taking a look.

carl
Site Admin
Posts: 1129
Joined: Thu Nov 14, 2013 2:53 pm

Re: MP4 to DCP Audio Sync Issues

Post by carl »

Thanks for sending the files!

Are you saying that the exact same DCP plays OK on the GDC SX-2001 AR but has delay problems on the GDC SR-1000?

digiopamp
Posts: 4
Joined: Fri Jan 24, 2020 12:12 am

Re: MP4 to DCP Audio Sync Issues

Post by digiopamp »

Yes, after more testing this appears to be the case. However, our newer GDC SR-1000 only has sync problems with DCPs made from mp4s. It does not appear to have any problems with m2ts blu-ray files.

I have a request in to GDC to take a look at the problem, but I didn't know if DCP-O-Matic was somehow creating a DCP file that had differences between an mp4 source material or a m2ts.

Carsten
Posts: 1527
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: MP4 to DCP Audio Sync Issues

Post by Carsten »

Well, it shouldn't. First thing would be to check video vs. audio mxf to see wether there is an actual sync offset in the media files.

You may e.g. open the video mxf in VLC, cue to a visual cue, count the frames towards it from the beginning. Then open the audio mxf in e.g. Audacity/FFMPEG or Audition (or, again VLC), cue to the same position in the file, and see if the corresponding audio cue is there.

Which data rate and frame have you chosen for these DCPs?


- Carsten

carl
Site Admin
Posts: 1129
Joined: Thu Nov 14, 2013 2:53 pm

Re: MP4 to DCP Audio Sync Issues

Post by carl »

They are 24fps 140Mbit/s.

carl
Site Admin
Posts: 1129
Joined: Thu Nov 14, 2013 2:53 pm

Re: MP4 to DCP Audio Sync Issues

Post by carl »

I have a request in to GDC to take a look at the problem, but I didn't know if DCP-O-Matic was somehow creating a DCP file that had differences between an mp4 source material or a m2ts.
There may be different bugs exposed in how DCP-o-matic handles mp4 or m2ts (or anything else). The hard part to understand is that the same DCPs work on one projector but not on another. If that's the case it pretty much rules out any difference in how DCP-o-matic decodes the content, and instead suggests it's a problem with how the DCP is made.

Is it possible to make your mp4 file available to me somehow? carl@dcpomatic.com

Carsten
Posts: 1527
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: MP4 to DCP Audio Sync Issues

Post by Carsten »

The GDC SR-1000 is a very recent media block - there's at least some possibility that this is a bug or a bad sync setting on that server. Heck, it COULD even be that it has trouble with low J2k rates, who knows.

- Carsten

digiopamp
Posts: 4
Joined: Fri Jan 24, 2020 12:12 am

Re: MP4 to DCP Audio Sync Issues

Post by digiopamp »

Hi All,

Thank you for looking at the DCP file. Carl, I have uploaded the source mp4 for the DCP. I have also uploaded the DCP file to GDC themselves to take a look at the problem. I have not considered the bitrate, so I will also try different bitrates to see if there is a difference in how the server handles the file.

The annoying part about the problem is that most feature DCPs from Deluxe or other distributors play back fine, but if there is no inherent difference in the DCP depending on source then the problem might not lie with DCP-O-Matic. I can post whatever I hear from GDC for everyone's records.

Best,

Post Reply