DCP-o-matic Player verification error

Anything and everything to do with DCP-o-matic.
Post Reply
adam
Posts: 1
Joined: Wed Mar 11, 2020 3:31 pm

DCP-o-matic Player verification error

Post by adam »

Hello,

I am having a weird issue with a DCP I received for our upcoming film festival. We are using SimpleDCP to manage our print traffic and they reported an issue with one of our films: "Invalid Audio Channel Configuration. DCP is created with 6.1, a non-standard audio configuration. May result in playback failure. Balkowitsch_FTR-1_F-178_EN-XX_US-NR_20_2K_XX_20200306_XX_SMPTE_OV. Please repackage DCP with 5.1 channel configuration for safety." Their validation report is here, https://tinyurl.com/w5tw4cc, which shows several different errors but none, at least as far as I can tell, that have to do with the number of audio channels. The filmmaker claimed that the film is stereo and when I inspect the audio mxf it only shows two channels. I tried to open the DCP in the player to verify it and received this error: "Unknown asset type application/x-smpte-mxf;asdcpKind=Sound in PKL". However, I was able to load the DCP successfully and play through the entire movie with no issues. While playing there was only signal on the left and right channels.

This isn't urgent for me since the DCP played successfully. I'm mostly just curious if anyone has any insight into how the DCP could fail multiple checks and yet still work. Also, if we can figure out that DCP-o-matic is throwing false errors hopefully that can be helpful to others.

The DCP was created using Wraptor Pro which I have received numerous films from and never had any issues. Our server is a Dolby DSS200-3 and the projector is a Barco DP2K-20C.

Please let me know if I can provide any additional information.

Thank you,

P.S. I love DCP-o-matic and the support community it has, especially Carl and Carsten. I've been lurking for quite a while and you guys kind of amaze me :)

Carsten
Posts: 1580
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: DCP-o-matic Player verification error

Post by Carsten »

Which version of the player did you use?

I know that some create 5.1 DCPs even if only the first two channels are occupied with a stereo signal to avoid any confusion.

I have no idea why they complain about a 6.1 DCP. 6.1 IS technically possible and allowed (the Soundfield was called Dolby Digital EX, it has a mono backsurround). So, even IF they diagnosed a 6.1 audio track, it should not be the reason for a rejection. Practically, a 6.1 mix, however, should be packaged in a 7.1 audio file (Left and Right Back Surround carrying the same signal), as there are no strict digital 6.1 setups in the real world.
But, I doubt it is actually 6.1

But, as the player complains, maybe something is broken. Is there anything special about the way this DCP was created?

Can you make that validation report available here as a screenshot or attachment? Looks as if the link provided does not work without login credentials for SimpleDCP.

My confidence in wraptor is pretty low. Yes, it may be possible to create some basic DCPs, but, this issue may indeed be caused by Wraptors poor quality control. Maybe you should load this DCP into DCP-o-matic and rewrap it. I am sure the complaints will go away.


And yes, there are many formal complaints to be made about certain DCPs while they still will play without issues on some or all servers. Not all servers check for full compliance, and, over time, DCP definition changed a bit. Some servers are more tolerant than others. Some complain about things that others don't care about.



- Carsten
Last edited by Carsten on Wed Mar 11, 2020 10:42 pm, edited 1 time in total.

carl
Site Admin
Posts: 1161
Joined: Thu Nov 14, 2013 2:53 pm

Re: DCP-o-matic Player verification error

Post by carl »

I tried to open the DCP in the player to verify it and received this error: "Unknown asset type application/x-smpte-mxf;asdcpKind=Sound in PKL".
That is probably a bug in the player; I noticed some problems with verification of Interop DCPs lately.

Post Reply