Subtitle misplacement on VF

Anything and everything to do with DCP-o-matic.
Post Reply
PetterT
Posts: 8
Joined: Wed Jun 18, 2014 11:02 am

Subtitle misplacement on VF

Post by PetterT »

Hi,

First of all, I'm sorry if this has already been posted here; I looked and couldn't find it mentioned.

I'm testing many short films for a festival and keep coming across films with weirdly placed subtitles. At first, I thought it was an artistic choice of placement (there are a lot of special filmmakers out there), but when it happened to me, I started to worry.

Here is an example of the placement.
Example.PNG
Example.PNG (2.81 MiB) Viewed 3156 times
This is where I place it
Example 2.PNG
Example 2.PNG (1.76 MiB) Viewed 3156 times
Is this something you've seen before? What am I doing wrong here?
I'm referring to a DCP and making a VF with a .srt.

I've done this many times before without this happening.
I'm testing with EasyDCP player, as the DoM player doesn't work (it keeps crashing when I resize it from starting in full screen/black screen with F11)


Cheers for any answers,
Petter
carl
Site Admin
Posts: 2429
Joined: Thu Nov 14, 2013 2:53 pm

Re: Subtitle misplacement on VF

Post by carl »

Hi Petter,

You're making a VF with DoM and then checking it in EasyDCP?

Can you share a subtitle MXF or XML from one of the DCPs with this problem? (To carl@dcpomatic.com if that's easier).

With your full-screen crashes, are you using macOS or Windows?

Best,
Carl
PetterT
Posts: 8
Joined: Wed Jun 18, 2014 11:02 am

Re: Subtitle misplacement on VF

Post by PetterT »

carl wrote: Wed May 01, 2024 10:08 pm You're making a VF with DoM and then checking it in EasyDCP?
Yes, I like DoM much better for making DCPs than EasyDCP, but I like EasyDCP better for testing, especially since the DoM Player hasn't been working for some time. I'm using Windows.
The Encode Server in DoM is a God-send, or a Carl-send, as it were.

Attached is the zipped VF.

Best,
Petter
Attachments
RegalisTest_SHR-1-25_S_XX-EN_51-HI-VI_4K_20240502_PSS_SMPTE_VF.7z
(164.09 KiB) Downloaded 144 times
StephW999
Posts: 42
Joined: Mon May 17, 2021 1:15 pm

Re: Subtitle misplacement on VF

Post by StephW999 »

The xml file in the mxf has no anomalies.

<Subtitle FadeDownTime="00:00:00:00" FadeUpTime="00:00:00:00" TimeOut="00:00:57:04" TimeIn="00:00:54:04" SpotNumber="5">
<Text Vposition="6.54545" Valign="bottom">A speaking snail. You haven't seen that before.</Text>
</Subtitle>

Maybe the problem is with your computer, maybe your graphics card drivers.
carl
Site Admin
Posts: 2429
Joined: Thu Nov 14, 2013 2:53 pm

Re: Subtitle misplacement on VF

Post by carl »

I agree that I can't see anything wrong with the subtitles ... are you using a 4K screen? The bad screenshot looks a bit like the whole subtitle is scaled by 50%.

When your DCP-o-matic player crashes does it give any error message? Are you using the "simple" or "opengl" display mode?
PetterT
Posts: 8
Joined: Wed Jun 18, 2014 11:02 am

Re: Subtitle misplacement on VF

Post by PetterT »

Thank you both for looking into this.

I've tested the VF in a cinema, and it looks good. So, it's probably an issue with the EasyDCP Player.

Cheers,
Petter
PetterT
Posts: 8
Joined: Wed Jun 18, 2014 11:02 am

Re: Subtitle misplacement on VF

Post by PetterT »

I do not get any error messages, but it looks like this after I F11 out of the black fullscreen:
https://imgur.com/a/ggFCAXp

I can't press X or move the window, and it's still running in Task Manager.
carl wrote: Thu May 02, 2024 1:01 pm Are you using the "simple" or "opengl" display mode?
Where do I find this setting? I looked for it in the DoM Creator, but as far as I can tell, it's not there. I don't get access to the settings for the Player because it crashes.
Carsten
Posts: 2711
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Subtitle misplacement on VF

Post by Carsten »

It's under 'Advanced' settings.

You may also edit the config file manually if you feel confident.

- Carsten
Post Reply