View Bug Details

IDProjectCategoryView StatusLast Update
0001112DCP-o-matic[All Projects] Bugspublic2018-01-11 00:52
ReporterCarstenAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
PlatformMacOSOS XOS Version10.6
Product Version2.11.0 
Target Version2.12.0Fixed in Version 
Summary0001112: In 2.11.16, using crop buttons changes preview position
Description

Just noticed this in 2.11.16 running in 10.6.8 - when I change crop values, the preview slider position changes with the crop values.

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Activities

Cantar4

2017-08-15 06:41

reporter   ~0001764

Don't worry, testing with the current MacOS 10.12.5, no such bad behaviour. :-)

Carsten

2017-08-25 23:46

manager   ~0001788

Doesn't happen anymore in 2.11.19, not even under 10.6.8 ;-)

carl

2017-08-25 23:53

administrator   ~0001789

Good news!

Carsten

2017-09-05 14:52

manager   ~0001813

Hmm... it still happens - even in 2.11.22 and Sierra. The question is, what triggers it to appear...

I just created a new project to convert an older interlaced 4:3 source. And while trying to crop uneven frame borders, I see the preview slider jumping large portions whenever I activate one of the crop arrow buttons.

Now that I have the effect again, some details:

  • the preview slider only goes forward, never backwards, no matter whether I increase or reduce cropping, makes no difference for left/right/top/bottom
  • it always jumps to the same preview positions, , that means, whenever I click on either of the crop dials, I always see the same pictures appearing in the preview window. As if the crop controls jump to the same positions in a sequence - even when I start from a different position
  • when the preview slider has come to the end of the content, no further moves
  • it is independent of the 'jump to selected content' checkbox
  • I can not slide the preview slider back to frame 1 manually, nor can I nudge it back to 00:00:00:00 - the only way to reset it back to the start is by checking 'jump to selected content' and the reselect content. I can then crop without the preview slider jumping, but see no picture (initial frame black). The moment I advance to the first non black frame, I get the crop-trigger-jumps behaviour again. This seems to be just a nasty false trigger of the preview slider position. I also still get the old issue of the filter/interlace setting not being visible immediately unless I temporarily switch forth and back between e..g. a color preset (e.g. from rec601 to rec709 and back to rec601.

It's not a show stopper, but it's a nuissance when I want to crop based on what I see, and when I actually change a crop value, my reference picture flips away. It doesn't seem to influence the DCP creation at all.

  • Carsten

Carsten

2017-09-05 14:53

manager   ~0001814

It also happens the same way when I insert numbers instead of dialing up/down.

carl

2018-01-06 22:52

administrator   ~0001933

Should be fixed by 2897d0a5912144486294dadca9a72df593c0f0f9

Carsten

2018-01-08 01:19

manager   ~0001939

In one of the recent test versions, I also noted the preview slider jumping when I had the video filter dialog open and switched filters. I can not say wether the issue is completely gone, as before, I couldn't reproduce it intentionally, usually it occured to me when I didn't think of it.

  • Carsten

carl

2018-01-08 23:55

administrator   ~0001944

Should be fixed by the same commit; do re-open this bug if you see it again.

Carsten

2018-01-11 00:30

manager   ~0001954

Last edited: 2018-01-11 00:31

View 2 revisions

Was it a Mac specific issue? I work and test mostly on a Mac, can't remember if I ever experienced it in windows. Seems few other people complained about it. It only bothered me when I tried to crop visually, but my reference picture was always flipping away with an up or down click.
Other than that, it's not an actual show stopper. Just weird.

  • Carsten

carl

2018-01-11 00:52

administrator   ~0001955

The bug that was fixed here was triggered by doing a slider position drag and then doing some cropping. Same on all platforms I think.

Bug History

Date Modified Username Field Change
2017-08-12 22:43 Carsten New Bug
2017-08-15 06:41 Cantar4 Note Added: 0001764
2017-08-15 22:09 carl Target Version => 2.12.0
2017-08-25 23:46 Carsten Note Added: 0001788
2017-08-25 23:53 carl Assigned To => carl
2017-08-25 23:53 carl Status new => resolved
2017-08-25 23:53 carl Resolution open => fixed
2017-08-25 23:53 carl Note Added: 0001789
2017-09-05 14:52 Carsten Status resolved => feedback
2017-09-05 14:52 Carsten Resolution fixed => reopened
2017-09-05 14:52 Carsten Note Added: 0001813
2017-09-05 14:53 Carsten Note Added: 0001814
2017-09-05 14:53 Carsten Status feedback => assigned
2018-01-06 22:44 carl Status assigned => confirmed
2018-01-06 22:52 carl Status confirmed => resolved
2018-01-06 22:52 carl Note Added: 0001933
2018-01-08 01:19 Carsten Status resolved => feedback
2018-01-08 01:19 Carsten Note Added: 0001939
2018-01-08 23:55 carl Status feedback => resolved
2018-01-08 23:55 carl Note Added: 0001944
2018-01-11 00:30 Carsten Note Added: 0001954
2018-01-11 00:31 Carsten Note Edited: 0001954 View Revisions
2018-01-11 00:52 carl Note Added: 0001955