View Bug Details

IDProjectCategoryView StatusLast Update
0001137DCP-o-matic[All Projects] Bugspublic2018-02-05 00:22
ReporterCarstenAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS X OS Version10.11
Product Version2.11.0 
Target Version2.12.0Fixed in Version 
Summary0001137: Preselect KDM 'Write To' options/radio buttons with a suitable option by default
Description

When choosing 'Write To', there are three possible options to choose for the packing of multiple KDMs - however, none of these is preselected. Hence, if you simply choose 'Make KDMs', nothing happens, and for no apparent reason. Due to the nature of these options, people could think that once only needs to make a choice if one actually creates multiple KDMs in one go. However, without a radio button being active, even the creation of a single KDM does not happen.

No big deal, but it's simply unexpected behavior, and since there is no warning, you may think the KDM creation has finished silently, or nothing happens...

I guess 'Write all KDMs to the same folder' should initially be preselected. Then, DOM should remember the last chosen setting.
I guess having a pref default for this is overkill. However, sometimes I wish there was an option to always save KDMs into the project's directory. THAT would make sense as a pref, though?!

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Activities

Carsten

2017-10-22 15:46

manager  

carl

2017-12-29 19:51

administrator   ~0001862

Doesn't seem to happen on Linux so it looks like an OS X thing.

Carsten

2017-12-30 01:22

manager   ~0001864

True - in DOM WIN64, 'Write all KDMs to the same folder' is preselected. The issue only happens in OS X (2.11.30 in Snow Leopard and Sierra confirmed).

Maybe an issue with the OS X GUI toolkit?

carl

2018-01-04 21:28

administrator   ~0001901

9ccaee9ed18688b3862b8b7fb7e73b69e71568e3 should fix this.

carl

2018-01-04 23:06

administrator   ~0001913

Appears fixed. Please could you open a new bug for your save-to-project's-directory idea if you are still keen to see it? Thanks!

Carsten

2018-02-03 01:04

manager   ~0002061

Make DKDM in OS X needs the same solution.



carl

2018-02-05 00:22

administrator   ~0002068

DKDM should be fixed by cad7088414d36f6cdcc6f52eef192f78d92f3e07

Bug History

Date Modified Username Field Change
2017-10-22 15:46 Carsten New Bug
2017-10-22 15:46 Carsten File Added: Bildschirmfoto 2017-10-22 um 17.35.52.png
2017-12-06 00:49 carl Target Version => 2.12.0
2017-12-29 19:51 carl Note Added: 0001862
2017-12-30 01:22 Carsten Note Added: 0001864
2018-01-04 21:28 carl Note Added: 0001901
2018-01-04 23:06 carl Assigned To => carl
2018-01-04 23:06 carl Status new => resolved
2018-01-04 23:06 carl Resolution open => fixed
2018-01-04 23:06 carl Note Added: 0001913
2018-02-03 01:04 Carsten File Added: Bildschirmfoto 2018-02-03 um 01.59.32.png
2018-02-03 01:04 Carsten Note Added: 0002061
2018-02-03 01:10 carl Status resolved => assigned
2018-02-05 00:22 carl Status assigned => resolved
2018-02-05 00:22 carl Note Added: 0002068