View Bug Details

IDProjectCategoryView StatusLast Update
0001173DCP-o-matic[All Projects] Clean-uppublic2018-02-28 09:17
ReporterCarstenAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS X OS Version10.11
Product Version2.11.0 
Target Version2.12.0Fixed in Version 
Summary0001173: grey out options when versioning/VF demands?
Description

There are some options under e.g. DCP that can can still be changed if content is referenced and a VF will be generated. Wouldn't it be useful to grey these out? There is a hint popping up that concerns reel splitting for VF. I remember translating it - however, this hint is now also shown when I select '4k' under DCP, when the referenced DCP is 2k, and the hint about reel splitting doesn't make sense there. I should probably translate it back to a more generic hint saying something like that 'the parameter you chose is not compatible with the DCP you are referencing as OV - but they need to match'.

A suitable other solution would be to set all DCP parameters according to the referenced DCP, and grey out those who can not be changed under the VF/OV rule? The good thing about this is that the user sees the type of the OV and thus new VF DCP. Also, we get less complaints about the 'refer to existing DCP' not being able to be checked due to parameter mismatch.

In my translation for .42, I also changed 'refer to existing DCP' into 'Link to imported DCP as OV, and create version file (VF)'.
I think that makes sense, so people immediately understand the purpose of that checkbox. The current text does not mention OV or VF at all.
Unfortunately, this longish sentence breaks the formatting/alignment of 'db' and 'ms' in the audio tab ;-) (see screenshot), both in windows and OS X. Probably easy to fix.

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Activities

Carsten

2018-01-17 00:48

manager  

carl

2018-01-17 01:14

administrator   ~0002018

It's a good point. cbbcccac8a8c8a6374b5bdad5b1f1c909847170b should fix your layout problem. I'll look at disabling options once we have a VF/OV and see if it's fixable without too much upheaval.

Carsten

2018-01-28 17:33

manager   ~0002035

Last edited: 2018-01-28 17:36

View 2 revisions

Yup. Read DCP type and audio config from referenced DCP and lock DCP and only audio settings when audio is referenced. Read DCP type and video config (container, res, frame rate, etc) and lock DCP and only video settings when video is referenced from OV, always set reel segmentation to content. When 'refer to' is unchecked, release settings at their current values.

I also think it would be useful if the englisch and all other localizations would mention the terms OV and/or VF with the 'refer to existing DCP', as it would make it easier to understand.

  • Carsten

carl

2018-02-01 00:01

administrator   ~0002044

I've changed the wording of those checkboxes and disabled the relevant bits in the DCP panel when VF-mode is on. I haven't done the auto-changing of DCP settings when VF is enabled; this may be a bit intrusive for this late stage of the 2.12.0 game.

Carsten

2018-02-02 23:01

manager   ~0002052

Yes, seems to work. Still confusing that you can not immediately set DCP video/audio/subs to refer to OV unless you have changed the reel setting to 'split by video content'. Yup, the mouse over will tell you why.
Is it a big deal to just set the proper reel segmentation to allow immediate VF creation?

Formally, this should now probably become 'split by content', as when adding new video to referenced audio, this will probably use audio reel segmentation?
Maybe, when DCP options are locked, add a little hint under the DCP tab, like 'DCP settings are locked to referenced OV' later on?

  • Carsten

Carsten

2018-02-02 23:34

manager   ~0002055

Opps - found a deadlock in 2.11.47 - I saw it happening before when playing with the VF checkbox and switching between tabs, but a first couldn't reproduce it...
Now I have a project with a DCP trailer, followed by an MP4 file. And for some reason, both the 'Use this DCP's xxx as OV and make VF' AND the DCP settings are greyed out - so I can neither enable or disable VF creation. I still don't know how to reproduce it, but at least this state now seems to be baked in the project file, as it now is like this when I re-open this project.
See screenshots, and attached metadata.xml - maybe you can trace it in the project file.

  • Carsten


metadata.xml (12,514 bytes)

Carsten

2018-02-09 14:31

manager   ~0002103

Carl - did you notice this one? If leaves you stuck with DCP options being greyed out, but without a OV/VF checkbox to disable, so the only way is to trash the project.

  • Carsten

carl

2018-02-09 15:46

administrator   ~0002109

I was hoping that bc2b76ae17ad11bbcaf4291accc49f4fd5ad8157 might have fixed it...

Carsten

2018-02-09 23:48

manager   ~0002118

Oops, I'll check it...

  • Carsten

carl

2018-02-25 00:00

administrator   ~0002206

Hi Carsten, did you get the chance to check this?

Carsten

2018-02-28 02:45

manager   ~0002221

Opps, long time ago....I can still reproduce the problem with that metadata.xml file from above in 2.11.47 after loading the project, so that's good...

Now trying with 2.11.67...seems to be gone, all is normal. After saving the project file, it opens in 2.11.47 without the issue.

I'd say, close for now.

carl

2018-02-28 09:17

administrator   ~0002222

Great, thanks.

Bug History

Date Modified Username Field Change
2018-01-17 00:47 Carsten New Bug
2018-01-17 00:47 Carsten Status new => assigned
2018-01-17 00:47 Carsten Assigned To => carl
2018-01-17 00:48 Carsten Description Updated View Revisions
2018-01-17 00:48 Carsten File Added: Bildschirmfoto 2018-01-17 um 01.47.32.png
2018-01-17 00:53 Carsten Description Updated View Revisions
2018-01-17 01:14 carl Note Added: 0002018
2018-01-28 17:33 Carsten Note Added: 0002035
2018-01-28 17:36 Carsten Note Edited: 0002035 View Revisions
2018-02-01 00:01 carl Note Added: 0002044
2018-02-02 23:01 Carsten Note Added: 0002052
2018-02-02 23:34 Carsten File Added: Bildschirmfoto 2018-02-03 um 00.24.35.png
2018-02-02 23:34 Carsten File Added: Bildschirmfoto 2018-02-03 um 00.24.26.png
2018-02-02 23:34 Carsten File Added: Bildschirmfoto 2018-02-03 um 00.24.16.png
2018-02-02 23:34 Carsten File Added: metadata.xml
2018-02-02 23:34 Carsten Note Added: 0002055
2018-02-09 14:31 Carsten Note Added: 0002103
2018-02-09 15:46 carl Note Added: 0002109
2018-02-09 23:48 Carsten Note Added: 0002118
2018-02-12 20:58 carl Status assigned => feedback
2018-02-25 00:00 carl Note Added: 0002206
2018-02-28 02:45 Carsten Note Added: 0002221
2018-02-28 02:45 Carsten Status feedback => assigned
2018-02-28 09:17 carl Status assigned => resolved
2018-02-28 09:17 carl Resolution open => fixed
2018-02-28 09:17 carl Note Added: 0002222