View Bug Details

IDProjectCategoryView StatusLast Update
0001238DCP-o-matic[All Projects] Featurespublic2018-10-17 19:16
ReporterCarstenAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOS X OS Version10.11
Product Version2.11.0 
Target Version2.14.0Fixed in Version 
Summary0001238: add dcp file validation (verify hashes) and file completeness
Description

Maybe add this to the player? That would allow basic integrity checking to protect from copy/media errors.

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Relationships

related to 0000971 confirmed DCP integrity check by file hashes 

Activities

carl

2018-03-14 01:00

administrator   ~0002295

Background done in ccde188f3b560730d14933af5caa11b413c2e623

Carsten

2018-04-11 15:18

manager   ~0002359

Last edited: 2018-04-11 15:47

View 2 revisions

hash checking available as 'Verify DCP' in Player 2.13.9 under 'Tools'

So, solved. But that 'Verify DCP' needs to become a translatable string, as well as all dialogs that follow. Maybe also add some minimal explanation to what is happening?

  • Carsten

Carsten

2018-04-11 16:00

manager   ~0002360

Hmm, is it possible that 'Verify DCP' is just a dummy so far? As to 'Background done'?

Because, I manipulated size and hash values in a PKL of Bunny-DCP, but it is still validated OK?

  • Carsten

carl

2018-04-19 23:58

administrator   ~0002389

Ah yes it doesn't cross-check with the PKL.

carl

2018-04-20 12:31

administrator   ~0002393

Also it trips up if the CPL does not have hash tags.

carl

2018-08-16 22:34

administrator   ~0002623

@carl: pkl branch in libdcp has some work on reading PKLs.

carl

2018-08-17 08:43

administrator   ~0002625

Should check PKL hashes as well as CPL ones in 2.13.43, with libdcp commits around 01e08cb5fef34a33524e404ae8e2ad7d029d0a22

Bug History

Date Modified Username Field Change
2018-03-11 13:32 Carsten New Bug
2018-03-11 13:32 Carsten Status new => assigned
2018-03-11 13:32 Carsten Assigned To => carl
2018-03-14 01:00 carl Note Added: 0002295
2018-04-10 22:50 carl Relationship added related to 0000971
2018-04-11 15:18 Carsten Note Added: 0002359
2018-04-11 15:47 Carsten Note Edited: 0002359 View Revisions
2018-04-11 16:00 Carsten Note Added: 0002360
2018-04-19 23:58 carl Note Added: 0002389
2018-04-20 12:31 carl Note Added: 0002393
2018-08-16 22:34 carl Note Added: 0002623
2018-08-17 08:43 carl Status assigned => resolved
2018-08-17 08:43 carl Resolution open => fixed
2018-08-17 08:43 carl Note Added: 0002625
2018-10-17 19:16 carl Status resolved => closed