View Issue Details

IDProjectCategoryView StatusLast Update
0001355DCP-o-matic[All Projects] Bugspublic2020-05-20 23:35
Reportercarl Assigned Tocarl  
PriorityimmediateSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version2.16.0Fixed in Version 
Summary0001355: Can't make VF with video from one DCP and audio from another
Description

Since it won't let you overlay two video sources on the timeline.

Tagsworkflow
Branch
Estimated weeks required
Estimated work requiredMajor

Relationships

related to 0000887 resolvedcarl Allow removal of video and audio from a FFmpeg file to leave just subtitles 
has duplicate 0001554 resolvedcarl Feature: Ability to use audio/subtitles only from video file 

Activities

Carsten

2018-08-12 22:36

manager   ~0002601

Similar issue when trying to create VFs from e.g. multistream MKV files - you may create the OV from video + audio stream 1 - when you want to create a VF, video is reused, and audio for VF can not be used from the same MKV. It has to be extracted first to be used individually. Is there a nice way to import composite video/audio and decide to use only one or the other? It seems we can delete (unmap) audio from composite files, but not video.

  • Carsten

carl

2018-08-13 13:03

administrator   ~0002602

Yes, that function is missing. I guess a checkbox in the video tab is the best way, although that's one more bit of clutter that 99% of people won't want...

overlookmotel

2019-05-07 18:19

reporter   ~0003325

Just to add my thoughts...

I often find I need to combine the video from one file/DCP with audio from another video file, so this feature would be really helpful.

My two use cases:

CASE 1
I have made a DCP, but now filmmaker wants to change the audio mix. I am provided a ProRes file containing video (which I don't need) and the new audio.

At present, I have to export the audio from the ProRes as e.g. WAV, and then import the WAV into DCP-o-matic.

It'd be faster to be able to import the ProRes direct to DCP-o-matic and ask it ignore the video and use the audio only.

CASE 2
Existing DCP needs a shot substituted (quite common, particularly to correct a misspelled/omitted name in credits). The shot to be dropped in is provided as a video file with no audio.

At present, I need to export the existing audio from the DCP, then create a video file containing both the new shot + the audio that goes under it. That file can then be cut into the timeline in DCP-o-matic.

It'd be preferable to tell DCP-o-matic to use the audio from the DCP and then be able to drop the new video into the timeline on top of it.

There is a workaround for both these, and I see your point Carl about cluttering the interface. But just registering that there is at least one user who would use it!

Carsten

2019-05-07 21:12

manager   ~0003326

Last edited: 2019-05-08 01:13

View 4 revisions

Wondering wether a 'RightClick - Split content' would be unobtrusive enough?

While it would be somehow 'logical' to have a 'use video' and 'use audio' checkbox just as we have it for captions, I understand why Carl doesn't like that solution.

Let's also add that these applications can be performed typically by creating intermediate DCPs. e.g. it is possible to create a DCP containing just a single reel of audio from any pre-existing DCP (even containing multiple reels and entry point/duration offsets), then add this audio MXF to a new DCP.

Yes, one needs to explain this method to users.

  • Carsten

chr.hove

2019-05-13 12:18

reporter   ~0003344

Instead of making a checkbox, would it be a solution to make it possible to delete a video track in timeline view (right-click -> Remove) without removing the other tracks of that multi-stream content?
Seen from my point of view, it would do the trick without cluttering up the UI.
/Christian

carl

2019-05-31 23:28

administrator   ~0003364

Some work in b68fb4c103b5580509070c7733d3ae7deb46c3ce

overlookmotel

2019-10-07 15:38

reporter   ~0003454

Hi Carl. You mentioned "Some work in b68fb4c103b5580509070c7733d3ae7deb46c3ce". If this is now possible, how do you do it in the interface? Or is it only in test version?

carl

2019-10-07 18:50

administrator   ~0003455

It's in the test version; there's a checkbox "Use" in the video tab. I think it works but it hasn't been well tested.

carl

2020-05-17 21:20

administrator   ~0003823

This control is now in "advanced settings" accessible by right-clicking on the content in the content list.

carl

2020-05-17 21:55

administrator   ~0003824

@carl The "don't use the video" part seems to be pretty much there but the "can we do VF" checking code still can't cope with video or audio being switched off. Perhaps the overlap checks just need to be more intelligent. If that's fixed we need tests.

carl

2020-05-20 23:35

administrator   ~0003831

Should be all good in da5e64883d7665353fcf838f6956f2dfb6e8b176 and later (2.15.76).

Issue History

Date Modified Username Field Change
2018-08-12 20:56 carl New Issue
2018-08-12 22:36 Carsten Note Added: 0002601
2018-08-13 13:03 carl Note Added: 0002602
2018-08-16 21:08 carl Relationship added related to 0000887
2018-10-17 09:35 carl Priority normal => high
2018-10-17 09:35 carl Status new => acknowledged
2019-01-08 00:37 carl Target Version 2.14.0 => 2.16.0
2019-05-01 09:45 carl Estimated work required Unknown => Major
2019-05-07 18:19 overlookmotel Note Added: 0003325
2019-05-07 21:12 Carsten Note Added: 0003326
2019-05-07 22:53 carl Relationship added has duplicate 0001554
2019-05-07 22:59 Carsten Note Edited: 0003326 View Revisions
2019-05-08 01:09 Carsten Note Edited: 0003326 View Revisions
2019-05-08 01:13 Carsten Note Edited: 0003326 View Revisions
2019-05-13 12:18 chr.hove Note Added: 0003344
2019-05-31 23:28 carl Note Added: 0003364
2019-10-07 15:38 overlookmotel Note Added: 0003454
2019-10-07 18:50 carl Note Added: 0003455
2019-11-27 19:37 carl Tag Attached: workflow
2020-05-17 21:20 carl Note Added: 0003823
2020-05-17 21:54 carl Priority high => immediate
2020-05-17 21:55 carl Note Added: 0003824
2020-05-20 23:35 carl Assigned To => carl
2020-05-20 23:35 carl Status acknowledged => resolved
2020-05-20 23:35 carl Resolution open => fixed
2020-05-20 23:35 carl Note Added: 0003831