View Bug Details

IDProjectCategoryView StatusLast Update
0001389DCP-o-matic[All Projects] Bugspublic2018-11-07 00:35
ReporterrobnAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSFedoraOS Version27
Product Version 
Target VersionFixed in Version 
Summary0001389: Integrated Loudness analysis missing?
Description

Maybe/probably I'm missing something? .. but it appears that the setting to find
Integrated Loudness is gone. I don't succeed in getting it in the audio analysis.

It is mentioned in the manual though (but also missing from the picture
of the Preferences in which I'd expect its tick-box).

Steps To Reproduce

do a "Show audio" in a project

TagsNo tags attached.
Estimated work requiredUnknown

Activities

robn

2018-10-22 06:19

reporter   ~0002731

forgot to mention: tested with DOM 2.13.64 and some random earlier versions)

Carsten

2018-10-27 11:57

manager   ~0002735

Last edited: 2018-10-27 12:44

View 3 revisions

It's where it always was - under general preferences. You will only see the R128 values in audio analysis if you have enabled the calculation in prefs beforehand. The only way currently to force a recalculation though is to dump the analysis folder in the project directory. Same if you changed the number of DCP audio channels after the analysis. There is an open issue here on Mantis where I suggested to offer a button for a full recalculation. One could probably make it automatic, but audio digest can be very time consuming for full length features, so, you don't want that to happen every few minutes when playing with some audio parameter - especially since in recent versions, the GUI is more or less locked during audio analysis calculation.

  • Carsten

robn

2018-10-27 16:33

reporter   ~0002737

Excuse me if I'm really missing something ..,
but I think the setting you refer to is not there (anymore?)

The manual talks about a "Find integrated loudness, true peak and loudness range when analysing audio"
checkbox here:

https://dcpomatic.com/manual/html/ch10.html#idp26

I assume it is supposed to live between "Play sound via" and "Automatically analyse content audio".
But it is not there (I remember using it in the past BTW).

See the attached schreenshots: no checkbox and n0 LUFS info.
I created started with a fresh project, so no analysis folder existed.
(removing it and re-doing the analysis doesn't help anyway)

Tested with DOM 2.13.64



audio.png (37,763 bytes)
audio.png (37,763 bytes)
prefs.png (50,198 bytes)
prefs.png (50,198 bytes)

robn

2018-10-27 16:42

reporter   ~0002738

I noticed that in the DOM config file there is a "AnalyseEBUR128" setting that is set to "1".
It just does not seem to have effect or show up in the settings UI.
(also tested with a new DOM installation)

Carsten

2018-10-27 16:53

manager   ~0002739

Last edited: 2018-10-27 16:55

View 3 revisions

I have to check again, but I saw it in the most recent test and stable version I just downloaded (both Mac), that's why I wrote here. Currently that machine is doing a conversion for the next 12hrs, using 2.10.5, so I can't check again for a screen shot.
Could it be limited to your specific platform (Linux)?
Did you try setting that value to 0? Also, before you start DCP-o-matic again, make sure you delete the analysis folder for the project in question. If you then click on 'show audio', a new analysis should be performed, and the R128 values may turn up.

  • Carsten

robn

2018-10-27 17:23

reporter   ~0002740

Reading the source code I think this problem might have something to do with the macro
DCPOMATIC_HAVE_EBUR128_PATCHED_FFMPEG not being defined/available on Linux (or just Fedora?)
in recent versions. Things used to work fine in the past, so I assume it's something trivial.

Carsten

2018-10-27 17:25

manager   ~0002741

Carl needs to look into it, and '1' is the correct parameter to ENABLE it, so, yes, if it was just the GUI, it should still work for you. I understand Carl had to work quite a bit to get some of the recent Linux distributions to work. Did you try 2.12 stable?

  • Carsten

robn

2018-10-27 17:40

reporter   ~0002742

No, it does not work when set to "1" (it already was "1": I used the feature in the past).
Setting it to "0" doesn't change anything. The setting is just not used it seems.

I just tried 2.12.13 on Linux/Fedora27 and 2.13.64 on a Mac.
These versions work fine, so something went wrong for (at least)
Linux/Fedora27 recently with FFMPEG support in the development tree.

Carsten

2018-10-27 18:01

manager   ~0002743

Last edited: 2018-10-27 21:41

View 2 revisions

Carl recently changed something about FFMPEG vs. Imagemagick dealing with image files. Maybe this is a side effect that only hits some platforms.

https://dcpomatic.com/forum/viewtopic.php?f=2&t=1180

Can you try 2.13.60? That is the last version with Imagemagick image file handling before that change, which could indicate this change being the reason.

  • Carsten

robn

2018-10-28 03:18

reporter   ~0002744

No, it has nothing to do with the ffmpeg / imagemagick thing.

I tested some older version I kept:
2.13.16 is OK
2.13.18 (and later) is not OK.

I see ffmpeg upgrades mentioned in the DOM git log from that time (25 april 2018).
So it seems that something went wrong with necessary EBUR128 patches for (at least) Linux / Fedora 27.

robn

2018-10-28 11:46

reporter   ~0002745

And apparently this problem also exists on the system that was used to generate
the screenshot for the DOM manual: the option is missing there too:

https://dcpomatic.com/manual/html/ch10.html#idp26

carl

2018-10-28 23:12

administrator   ~0002746

Should be fixed by 9a1caa5ea1510977482c3590cd9cacd4d5b4cb24 in 2.13.65.

robn

2018-11-07 00:35

reporter   ~0002754

Yes indeed: I can confirm that it works again on DOM 2.13.66 !

Bug History

Date Modified Username Field Change
2018-10-22 06:17 robn New Bug
2018-10-22 06:19 robn Note Added: 0002731
2018-10-27 11:57 Carsten Note Added: 0002735
2018-10-27 12:43 Carsten Note Edited: 0002735 View Revisions
2018-10-27 12:44 Carsten Note Edited: 0002735 View Revisions
2018-10-27 16:33 robn File Added: audio.png
2018-10-27 16:33 robn File Added: prefs.png
2018-10-27 16:33 robn Note Added: 0002737
2018-10-27 16:42 robn Note Added: 0002738
2018-10-27 16:53 Carsten Note Added: 0002739
2018-10-27 16:55 Carsten Note Edited: 0002739 View Revisions
2018-10-27 16:55 Carsten Note Edited: 0002739 View Revisions
2018-10-27 17:23 robn Note Added: 0002740
2018-10-27 17:25 Carsten Note Added: 0002741
2018-10-27 17:40 robn Note Added: 0002742
2018-10-27 18:01 Carsten Note Added: 0002743
2018-10-27 21:41 Carsten Note Edited: 0002743 View Revisions
2018-10-28 03:18 robn Note Added: 0002744
2018-10-28 11:46 robn Note Added: 0002745
2018-10-28 23:12 carl Assigned To => carl
2018-10-28 23:12 carl Status new => resolved
2018-10-28 23:12 carl Resolution open => fixed
2018-10-28 23:12 carl Note Added: 0002746
2018-11-07 00:35 robn Note Added: 0002754