View Bug Details

IDProjectCategoryView StatusLast Update
0001449DCP-o-matic[All Projects] Generalpublic2019-02-04 08:22
ReportermarkuskAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platform64-bitOSLinuxOS VersionArch
Product Version2.12.x 
Target VersionFixed in Version 
Summary0001449: 2* expected class-name before »{« token
Description

compiling 2.12.17 has the following error during compile on current Arch Linux using

libasdcp-cth 0.1.5-1
libcxml 0.15.5-1
libdcp 1.5.7-1
liblocked-sstream 0.0.5-1
libsub 1.3.5-1

Additional Information

[ 15/379] Compiling src/lib/audio_ring_buffers.cc
[ 16/379] Compiling src/lib/audio_stream.cc
[ 17/379] Compiling src/lib/butler.cc
In file included from ../src/lib/signaller.h:24,
from ../src/lib/content.h:29,
from ../src/lib/atmos_mxf_content.h:21,
from ../src/lib/atmos_mxf_content.cc:21:
../src/lib/signal_manager.h:33:1: Fehler: expected class-name before »{« token
{
^

In file included from ../src/lib/signaller.h:24,
from ../src/lib/content.h:29,
from ../src/lib/content_part.h:24,
from ../src/lib/audio_content.h:28,
from ../src/lib/audio_content.cc:21:
../src/lib/signal_manager.h:33:1: Fehler: expected class-name before »{« token
{
^

Waf: Leaving directory `/media/internal-archiv4/makepkg-build-dir-per--etc--makepkg_conf/dcpomatic/src/dcpomatic-2.12.17/build'
Build failed
-> task in 'libdcpomatic2' failed (exit status 1):
{task 139887536259920: cxx atmos_mxf_content.cc -> atmos_mxf_content.cc.1.o}

TagsNo tags attached.
Estimated work requiredUnknown

Activities

carl

2019-01-24 22:13

administrator   ~0002931

Hi Markus, this is possibly fixed by commit 02e44f68612631a2e73709b90c5e259c0f333109
Are you able to test with that?

markusk

2019-01-25 15:39

reporter   ~0002939

during git version testing (18298d471010b3d8209efe81d6d46ff8efd857ed) the waf test fails... during Checking for wxWidgets using gtk2-unicode-3.0


Checking for wxWidgets using gtk2-unicode-3.0
['/usr/lib64/wx/config/gtk2-unicode-3.0', '--cppflags', '--cxxflags', '--libs', 'core,richtext,adv,html,xml']
out: -I/usr/lib/wx/include/gtk2-unicode-3.0 -I/usr/include/wx-3.0 -D_FILE_OFFSET_BITS=64 -DWXUSINGDLL -DWXGTK
-I/usr/lib/wx/include/gtk2-unicode-3.0 -I/usr/include/wx-3.0 -D_FILE_OFFSET_BITS=64 -DWXUSINGDLL -DWXGTK -pthread
-pthread -lwx_gtk2u_core-3.0 -lwx_gtk2u_richtext-3.0 -lwx_gtk2u_adv-3.0 -lwx_gtk2u_html-3.0 -lwx_baseu_xml-3.0 -lwx_baseu-3.0

yes
['/usr/lib64/wx/config/gtk2-unicode-3.0', '--version', 'wxwidgets']
out: 3.0.4

Unhandled flag '3.0.4'
['/sbin/pkg-config', '--cflags', '--libs', 'rtaudio']
out: -pthread -I/usr/include/rtaudio -D_FORTIFY_SOURCE=2 -DUNIX_JACK -DLINUX_ALSA -D__LINUX_PULSE__ -I/usr/include/alsa -D_REENTRANT -lrtaudio -ljack -lpthread -lasound -lpulse-simple -lpulse

==>

                        #include <RtAudio.h>

                        int main() { throw RtError("Hello"); }

<==
[1/2] Compiling build/.conf_check_224d5d3d4032c439f982bb66d4d5c73c/test.cpp

['/usr/lib/ccache/bin/g++', '-march=native', '-O2', '-pipe', '-fstack-protector-strong', '--std=c++11', '-DSTDC_CONSTANT_MACROS', '-DSTDC_LIMIT_MACROS', '-DSTDC_FORMAT_MACROS', '-msse', '-fno-strict-aliasing', '-Wall', '-Wcast-align', '-Wextra', '-Wwrite-strings', '-Wno-deprecated-declarations', '-Wno-ignored-qualifiers', '-D_FILE_OFFSET_BITS=64', '-Wno-unused-result', '-O2', '-DDCPOMATIC_POSIX', '-mfpmath=sse', '-DLINUX_LOCALE_PREFIX="/usr/share/locale"', '-DLINUX_SHARE_PREFIX="/usr/share/dcpomatic2"', '-DDCPOMATIC_LINUX', '-Wlogical-op', '-std=c++11', '-pthread', '-I/usr/include/rtaudio', '-I/usr/include/alsa', '-DHAVE_GTK=1', '-DHAVE_CURL=1', '-DHAVE_ICU=1', '-DHAVE_SAMPLERATE=1', '-DHAVE_GLIB=1', '-DHAVE_ZIP=1', '-DDCPOMATIC_HAVE_ZIP_SOURCE_T=1', '-DHAVE_FONTCONFIG=1', '-DHAVE_PANGOMM=1', '-DHAVE_CAIROMM=1', '-DDCPOMATIC_HAVE_FORMAT_STRIDE_FOR_WIDTH=1', '-DDCPOMATIC_HAVE_SHOW_IN_CAIRO_CONTEXT=1', '-DHAVE_CXML=1', '-DHAVE_DCP=1', '-DHAVE_SUB=1', '-DHAVE_XMLPP=1', '-DHAVE_NETTLE=1', '-DHAVE_PNG=1', '-DHAVE_AVFORMAT=1', '-DHAVE_AVFILTER=1', '-DHAVE_AVCODEC=1', '-DHAVE_AVUTIL=1', '-DHAVE_SWSCALE=1', '-DHAVE_POSTPROC=1', '-DHAVE_SWRESAMPLE=1', '-DLOCALEDIR="/usr/share/locale"', '-DDATADIR="/usr/share"', '-DHAVE_WXWIDGETS=1', '-DHAVE_RTAUDIO=1', '-D_FORTIFY_SOURCE=2', '-D__UNIX_JACK', '-DLINUX_ALSA', '-DLINUX_PULSE', '-D_REENTRANT', '../test.cpp', '-c', '-o/media/internal-archiv4/makepkg-build-dir-per--etc--makepkg_conf/dcpomatic-git/src/dcpomatic-git/build/.conf_check_224d5d3d4032c439f982bb66d4d5c73c/testbuild/test.cpp.1.o', '-D_FORTIFY_SOURCE=2']
err: ../test.cpp: In Funktion »int main()«:
../test.cpp:4:48: Fehler: »RtError« wurde in diesem Gültigkeitsbereich nicht definiert
int main() { throw RtError("Hello"); }
^~~
../test.cpp:4:48: Anmerkung: empfohlene Alternative: »perror«
int main() { throw RtError("Hello"); }
^~~
perror

from /media/internal-archiv4/makepkg-build-dir-per--etc--makepkg_conf/dcpomatic-git/src/dcpomatic-git/src/wx: Test does not build: Traceback (most recent call last):
File "/media/internal-archiv4/makepkg-build-dir-per--etc--makepkg_conf/dcpomatic-git/src/dcpomatic-git/.waf3-2.0.14-e67604cd8962dbdaf7c93e0d7470ef5b/waflib/Configure.py", line 325, in run_build
bld.compile()
File "/media/internal-archiv4/makepkg-build-dir-per--etc--makepkg_conf/dcpomatic-git/src/dcpomatic-git/.waf3-2.0.14-e67604cd8962dbdaf7c93e0d7470ef5b/waflib/Build.py", line 176, in compile
raise Errors.BuildError(self.producer.error)
waflib.Errors.BuildError: Build failed
-> task in 'testprog' failed with exit status 1 (run with -v to display more information)

from /media/internal-archiv4/makepkg-build-dir-per--etc--makepkg_conf/dcpomatic-git/src/dcpomatic-git/src/wx: The configuration failed
['/sbin/pkg-config', '--cflags', '--libs', 'sndfile']
out: -lsndfile

==>

                        #define BOOST_TEST_MODULE Config test

                        #include <boost/test/unit_test.hpp>

                        int main() {}

<==
[1/2] Compiling build/.conf_check_243a7fb8e3291ed5fcf1422161cfb3d0/test.cpp

['/usr/lib/ccache/bin/g++', '-march=native', '-O2', '-pipe', '-fstack-protector-strong', '--std=c++11', '-DSTDC_CONSTANT_MACROS', '-DSTDC_LIMIT_MACROS', '-D__STDC_FORMAT_MACROS', '-msse', '-fno-strict-aliasing', '-Wall', '-Wcast-align', '-Wextra', '-Wwrite-strings', '-Wno-deprecated-declarations', '-Wno-ignored-qualifiers', '-D_FILE_OFFSET_BITS=64', '-Wno-unused-result', '-O2', '-DDCPOMATIC_POSIX', '-mfpmath=sse', '-DLINUX_LOCALE_PREFIX="/usr/share/locale"', '-DLINUX_SHARE_PREFIX="/usr/share/dcpomatic2"', '-DDCPOMATIC_LINUX', '-Wlogical-op', '-std=c++11', '-DHAVE_GTK=1', '-DHAVE_CURL=1', '-DHAVE_ICU=1', '-DHAVE_SAMPLERATE=1', '-DHAVE_GLIB=1', '-DHAVE_ZIP=1', '-DDCPOMATIC_HAVE_ZIP_SOURCE_T=1', '-DHAVE_FONTCONFIG=1', '-DHAVE_PANGOMM=1', '-DHAVE_CAIROMM=1', '-DDCPOMATIC_HAVE_FORMAT_STRIDE_FOR_WIDTH=1', '-DDCPOMATIC_HAVE_SHOW_IN_CAIRO_CONTEXT=1', '-DHAVE_CXML=1', '-DHAVE_DCP=1', '-DHAVE_SUB=1', '-DHAVE_XMLPP=1', '-DHAVE_NETTLE=1', '-DHAVE_PNG=1', '-DHAVE_AVFORMAT=1', '-DHAVE_AVFILTER=1', '-DHAVE_AVCODEC=1', '-DHAVE_AVUTIL=1', '-DHAVE_SWSCALE=1', '-DHAVE_POSTPROC=1', '-DHAVE_SWRESAMPLE=1', '-DLOCALEDIR="/usr/share/locale"', '-DDATADIR="/usr/share"', '-DHAVE_WXWIDGETS=1', '-DHAVE_RTAUDIO=1', '-DHAVE_SNDFILE=1', '../test.cpp', '-c', '-o/media/internal-archiv4/makepkg-build-dir-per--etc--makepkg_conf/dcpomatic-git/src/dcpomatic-git/build/.conf_check_243a7fb8e3291ed5fcf1422161cfb3d0/testbuild/test.cpp.1.o', '-D_FORTIFY_SOURCE=2']
[2/2] Linking build/.conf_check_243a7fb8e3291ed5fcf1422161cfb3d0/testbuild/testprog

['/usr/lib/ccache/bin/g++', '-pthread', 'test.cpp.1.o', '-o/media/internal-archiv4/makepkg-build-dir-per--etc--makepkg_conf/dcpomatic-git/src/dcpomatic-git/build/.conf_check_243a7fb8e3291ed5fcf1422161cfb3d0/testbuild/testprog', '-Wl,-Bstatic', '-Wl,-Bdynamic', '-lboost_unit_test_framework', '-Wl,-O1,--sort-common,--as-needed,-z,relro']
['/sbin/pkg-config', '--cflags', '--libs', 'ImageMagick++']
err: Package ImageMagick++ was not found in the pkg-config search path.
Perhaps you should add the directory containing `ImageMagick++.pc'
to the PKG_CONFIG_PATH environment variable
Package 'ImageMagick++', required by 'virtual:world', not found

from /media/internal-archiv4/makepkg-build-dir-per--etc--makepkg_conf/dcpomatic-git/src/dcpomatic-git/test: The configuration failed



config.log (64,315 bytes)

carl

2019-01-25 21:44

administrator   ~0002942

Should be better in ea2e02e0b433f11c76e6a993c32bd963da87b547

markusk

2019-01-29 18:40

reporter   ~0002983

still getting errors like this in 0317705d1031d4f529a99b26034a8c9ab7f72ba1

[ 10/340] Compiling src/lib/content.cc
In file included from ../src/lib/signaller.h:24,
from ../src/lib/content.h:29,
from ../src/lib/content_part.h:25,
from ../src/lib/audio_content.h:28,
from ../src/lib/audio_content.cc:21:
../src/lib/signal_manager.h:33:1: Fehler: expected class-name before »{« token
{
^

In file included from ../src/lib/encode_server.h:28,
from ../src/lib/encode_server.cc:26:
../src/lib/server.h:32:1: Fehler: expected class-name before »{« token
{
^

In file included from ../src/lib/signaller.h:24,
from ../src/lib/content.h:29,
from ../src/lib/atmos_mxf_content.h:21,
from ../src/lib/atmos_mxf_content.cc:21:
../src/lib/signal_manager.h:33:1: Fehler: expected class-name before »{« token
{
^

In file included from ../src/lib/signaller.h:24,
from ../src/lib/content.h:29,
from ../src/lib/content.cc:25:
../src/lib/signal_manager.h:33:1: Fehler: expected class-name before »{« token
{
^
../src/lib/content.cc: In Elementfunktion »void Content::signal_change(ChangeType, int)«:
../src/lib/content.cc:208:18: Warnung: polymorpher Typ »class boost::bad_weak_ptr« wird per Wertzuweisung gefangen [-Wcatch-value=]
} catch (boost::bad_weak_ptr) {
^~~~

[ 7/340] Compiling src/lib/spl.cc
In file included from ../src/lib/signaller.h:24,
from ../src/lib/content.h:29,
from ../src/lib/content_part.h:25,
from ../src/lib/audio_content.h:28,
from ../src/lib/audio_content.cc:21:
../src/lib/signal_manager.h:33:1: Fehler: expected class-name before »{« token
{
^



config-2.log (60,925 bytes)

carl

2019-01-30 00:32

administrator   ~0002989

Those ones should be fixed in 072658c553eff4103bc962eec8b3b83aa05210ea

markusk

2019-01-30 16:47

reporter   ~0002992

some more using c2cbab19cc66ec3e2e2e7e5c8c208983396de70c ... might be best to change the title of this Bug to something like "Multiple compile bugs on Arch" ;)

[ 10/340] Compiling src/lib/content.cc
../src/lib/content.cc: In member function ‘void Content::signal_change(ChangeType, int)’:
../src/lib/content.cc:208:18: warning: catching polymorphic type ‘class boost::bad_weak_ptr’ by value [-Wcatch-value=]
} catch (boost::bad_weak_ptr) {
^~~~

[ 11/340] Compiling src/lib/audio_point.cc
[ 12/340] Compiling src/lib/screen.cc
[ 13/340] Compiling src/lib/screen_kdm.cc
[ 14/340] Compiling src/lib/encoder.cc
[ 15/340] Compiling src/lib/scp_uploader.cc
[ 16/340] Compiling src/lib/scoped_temporary.cc
[ 17/340] Compiling src/lib/empty.cc
[ 18/340] Compiling src/lib/rgba.cc
[ 19/340] Compiling src/lib/config.cc
[ 20/340] Compiling src/lib/emailer.cc
[ 21/340] Compiling src/lib/render_text.cc
[ 22/340] Compiling src/lib/reel_writer.cc
[ 23/340] Compiling src/lib/edid.cc
[ 24/340] Compiling src/lib/colour_conversion.cc
[ 25/340] Compiling src/lib/audio_merger.cc
[ 26/340] Compiling src/lib/audio_buffers.cc
[ 27/340] Compiling src/lib/raw_image_proxy.cc
[ 28/340] Compiling src/lib/ratio.cc
[ 29/340] Compiling src/lib/dolby_cp750.cc
[ 30/340] Compiling src/lib/position_image.cc
[ 31/340] Compiling src/lib/playlist.cc
[ 32/340] Compiling src/lib/dkdm_wrapper.cc
[ 33/340] Compiling src/lib/cinema_sound_processor.cc
[ 34/340] Compiling src/lib/player_video.cc
[ 35/340] Compiling src/lib/player_text.cc
[ 36/340] Compiling src/lib/digester.cc
[ 37/340] Compiling src/lib/player.cc
../src/lib/player.cc: In Elementfunktion »bool Player::pass()«:
../src/lib/player.cc:599:40: Warnung: »((void)& earliest_time +8)« könnte in dieser Funktion uninitialisiert verwendet werden [-Wmaybe-uninitialized]
if (!_black.done() && (!earliest_time || _black.position() < *earliest_time)) {
~~~~^~~~~~~~~~

[ 38/340] Compiling src/lib/overlaps.cc
[ 39/340] Compiling src/lib/decoder_part.cc
[ 40/340] Compiling src/lib/cinema_kdms.cc
[ 41/340] Compiling src/lib/audio_mapping.cc
[ 42/340] Compiling src/lib/monitor_checker.cc
[ 43/340] Compiling src/lib/resampler.cc
[ 44/340] Compiling src/lib/decoder_factory.cc
[ 45/340] Compiling src/lib/log_entry.cc
[ 46/340] Compiling src/lib/log.cc
[ 47/340] Compiling src/lib/decoder.cc
../src/lib/decoder.cc: In Elementfunktion »ContentTime Decoder::position() const«:
../src/lib/decoder.cc:50:41: Warnung: »((void)& pos +8)« könnte in dieser Funktion uninitialisiert verwendet werden [-Wmaybe-uninitialized]
if (audio && !audio->ignore() && (!pos || audio->position(f) < *pos)) {
~~^~~~~~~~~

[ 48/340] Compiling src/lib/cinema.cc
[ 49/340] Compiling src/lib/lock_file_checker.cc
[ 50/340] Compiling src/lib/json_server.cc
[ 51/340] Compiling src/lib/dcpomatic_time.cc
[ 52/340] Compiling src/lib/j2k_encoder.cc
In file included from /usr/include/libdcp-1.0/dcp/util.h:42,
from ../src/lib/types.h:26,
from ../src/lib/util.h:28,
from ../src/lib/j2k_encoder.h:28,
from ../src/lib/j2k_encoder.cc:25:
/usr/include/libdcp-1.0/dcp/data.h: In Elementfunktion »void J2KEncoder::encoder_thread(boost::optional<EncodeServerDescription>)«:
/usr/include/libdcp-1.0/dcp/data.h:43:7: Warnung: »((void)(& encoded)+8).dcp::Data::_size« könnte in dieser Funktion uninitialisiert verwendet werden [-Wmaybe-uninitialized]
class Data
^~~~
../src/lib/j2k_encoder.cc:307:19: Anmerkung: »((void)(& encoded)+8).dcp::Data::_size« wurde hier deklariert
optional<Data> encoded;
^~~

[ 53/340] Compiling src/lib/job_manager.cc
[ 54/340] Compiling src/lib/dcpomatic_socket.cc
[ 55/340] Compiling src/lib/check_content_change_job.cc
[ 56/340] Compiling src/lib/audio_filter_graph.cc
In file included from ../src/lib/dcpomatic_socket.cc:21:
../src/lib/dcpomatic_socket.h:31:1: error: expected class-name before ‘{’ token
{
^

Waf: Leaving directory `/media/internal-archiv4/makepkg-build-dir-per--etc--makepkg_conf/dcpomatic-git/src/dcpomatic-git/build'
Build failed
-> task in 'libdcpomatic2' failed with exit status 1 (run with -v to display more information)
==> ERROR: A failure occurred in build().
Aborting...



config-3.log (60,823 bytes)

carl

2019-01-30 16:51

administrator   ~0002993

That one should be gone in 2eeb503962f31665a19bee24e2e46840f7086f33

markusk

2019-01-30 17:58

reporter   ~0002994

i now compiles with a boat load of warnings but it compiles. See attached STDERR-STDOUT txt file for warnings if you like.

Will you be releasing a new stable version with the fixes in the near future? I'm asking because i'm searching for some arch version that i could base my stable packages on without using git.



dcpomatic-arch-build-STDERR-STDOUT.txt (290,626 bytes)

carl

2019-01-30 20:14

administrator   ~0002995

OK, thanks. There's only a few of those warnings I can do anything about, and I don't think they matter.

Are you wanting to build the 2.12.x branch or 2.13.x? AFAICS you're working on 2.13.x here?

markusk

2019-02-04 02:47

reporter   ~0003046

2.12.18 -> ist compiling on arch again! thank you for the quick fixes !

Bug History

Date Modified Username Field Change
2019-01-24 02:18 markusk New Bug
2019-01-24 22:13 carl Assigned To => carl
2019-01-24 22:13 carl Status new => feedback
2019-01-24 22:13 carl Note Added: 0002931
2019-01-25 15:39 markusk File Added: config.log
2019-01-25 15:39 markusk Note Added: 0002939
2019-01-25 15:39 markusk Status feedback => assigned
2019-01-25 21:44 carl Status assigned => feedback
2019-01-25 21:44 carl Note Added: 0002942
2019-01-29 18:40 markusk File Added: config-2.log
2019-01-29 18:40 markusk Note Added: 0002983
2019-01-29 18:40 markusk Status feedback => assigned
2019-01-30 00:32 carl Note Added: 0002989
2019-01-30 16:47 markusk File Added: config-3.log
2019-01-30 16:47 markusk Note Added: 0002992
2019-01-30 16:51 carl Status assigned => feedback
2019-01-30 16:51 carl Note Added: 0002993
2019-01-30 17:58 markusk File Added: dcpomatic-arch-build-STDERR-STDOUT.txt
2019-01-30 17:58 markusk Note Added: 0002994
2019-01-30 17:58 markusk Status feedback => assigned
2019-01-30 20:14 carl Note Added: 0002995
2019-02-04 02:47 markusk Note Added: 0003046
2019-02-04 08:22 carl Status assigned => resolved
2019-02-04 08:22 carl Resolution open => fixed