View Issue Details

IDProjectCategoryView StatusLast Update
0001500DCP-o-matic[All Projects] Featurespublic2019-03-31 23:36
ReporterCarsten Assigned Tocarl  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS XOS Version10.12
Product Version2.14.x 
Target Version2.16.0Fixed in Version 
Summary0001500: Add export/save option for KDM creator, so to save individual file based (D)KDMs from Creators list (config.xml)
Description

Some people may have the requirement to create a file based (D)KDM after they only sent a DKDM to the KDM creator list/config.xml.
E.g. to be used to decrypt your own DCP in DCP-o-matic main, or to assign it in player.

I think that could easily fit below the few existing buttons on the right side of the DKDM list (see screenshot).
Could that also be used to export multiple DKDMs to files, e.g. also to create a full backup (alls DKDMs to individual files)? Yes, one may backup the config.xml, but...

One question that comes up is - we have a choice of MT1, DCI any, etc. for general KDMs. Is there a specific formulation for DKDMs?
It probably doesn't matter much, since these DKDMs can only be used by the local DCP-o-matic installation, and as long as DCP-o-matic apps are all okay with the selected formulation, there is little risc.

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Activities

Carsten

2019-03-24 19:43

manager  

carl

2019-03-31 23:36

administrator   ~0003225

Export button added in 02ab3d31d6579089dfd05aa015ccca93952e95d3

Issue History

Date Modified Username Field Change
2019-03-24 19:43 Carsten New Issue
2019-03-24 19:43 Carsten File Added: Bildschirmfoto 2019-03-24 um 20.40.45.png
2019-03-24 19:46 Carsten Summary Add export/save option for KDM creator, so to save individual file based DKDMs from Creators list (config.xml) => Add export/save option for KDM creator, so to save individual file based (D)KDMs from Creators list (config.xml)
2019-03-24 19:46 Carsten Description Updated View Revisions
2019-03-24 19:48 Carsten Description Updated View Revisions
2019-03-24 19:48 Carsten Description Updated View Revisions
2019-03-24 19:49 Carsten Description Updated View Revisions
2019-03-31 23:36 carl Assigned To => carl
2019-03-31 23:36 carl Status new => resolved
2019-03-31 23:36 carl Resolution open => fixed
2019-03-31 23:36 carl Note Added: 0003225
2019-03-31 23:36 carl Target Version 2.14.x => 2.16.0