View Bug Details

IDProjectCategoryView StatusLast Update
0001524DCP-o-matic[All Projects] Bugspublic2019-04-06 22:13
ReporterCarstenAssigned Tocarl 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS XOS Version10.12
Product Version2.14.x 
Target Version2.14.0Fixed in Version 
Summary0001524: 2.13.x (141) does not deal correctly with synthesized text effects
Description

When importing/assigning e.g.italics, DCP-o-matic 2.13.141 does not preview italics, nor does the player show italics if the XML file of a DCP contains italic tags. This seems to be a display/preview/burn-in issue only, as italics from e.g. an SRT file are correctly converted into e.g. an Interop XML timed text file. DCP-o-matic 2.12.20 and Player 2.12.20 do not exhibit that behaviour.

  • Carsten

1
00:00:2,000 --> 00:00:5,000
This text is in italics.
This text is not in italics


<Subtitle SpotNumber="1" TimeIn="00:00:02:000" TimeOut="00:00:05:000" FadeUpTime="0" FadeDownTime="0">
<Font Italic="yes">
<Text VAlign="top" VPosition="86.9545">This text is in italics.</Text>
</Font>
<Font Italic="no">
<Text VAlign="top" VPosition="94.2273">This text is not in italics</Text>
</Font>
</Subtitle>

TagsNo tags attached.
Estimated work requiredUnknown

Activities

Carsten

2019-04-03 16:02

manager  

2_13_141.png (23,186 bytes)
2_13_141.png (23,186 bytes)
2_12_20.png (19,690 bytes)
2_12_20.png (19,690 bytes)

Carsten

2019-04-03 16:45

manager   ~0003230

More new here:

https://dcpomatic.com/forum/viewtopic.php?f=2&t=800&p=5332#p5332

carl

2019-04-03 20:48

administrator   ~0003231

Works for me on 10.13 (High Sierra) but not 10.10.5 (Yosemite)

carl

2019-04-03 20:50

administrator   ~0003232

Last edited: 2019-04-03 21:04

View 3 revisions

"Fontconfig error: Cannot load default config file" (on Yosemite), not on High Sierra.

carl

2019-04-03 21:33

administrator   ~0003233

No italics in burnt subs either for me on Yosemite.

Carsten

2019-04-03 21:47

manager   ~0003234

Weird. My tests are in Sierra...

To me, it appears as if the new synthesized font styles cause this, as it's okay in 2.12.20

Trying again... as previously: srt with italics previews correctly in 2.12.20, and without italics in 2.13.141 OS X Sierra.

Oops - can not see italics in burnt-in text with 2.13.141 either now... maybe did something wrong during initial testing...

  • Carsten

carl

2019-04-04 00:17

administrator   ~0003235

36971ecc260b46a4092a4ba3099c3e52e2d1b916 may help (v2.13.142)

carl

2019-04-05 23:14

administrator   ~0003237

Is 2.13.142 any better?

carl

2019-04-06 22:13

administrator   ~0003246

Believed fixed, according to https://dcpomatic.com/forum/viewtopic.php?f=2&p=5356#p5356

Bug History

Date Modified Username Field Change
2019-04-03 16:02 Carsten New Bug
2019-04-03 16:02 Carsten File Added: 2_13_141.png
2019-04-03 16:02 Carsten File Added: 2_12_20.png
2019-04-03 16:04 Carsten Description Updated View Revisions
2019-04-03 16:45 Carsten Note Added: 0003230
2019-04-03 20:48 carl Assigned To => carl
2019-04-03 20:48 carl Status new => confirmed
2019-04-03 20:48 carl Note Added: 0003231
2019-04-03 20:48 carl Target Version 2.14.x => 2.14.0
2019-04-03 20:50 carl Note Added: 0003232
2019-04-03 20:58 carl Note Edited: 0003232 View Revisions
2019-04-03 21:04 carl Note Edited: 0003232 View Revisions
2019-04-03 21:33 carl Note Added: 0003233
2019-04-03 21:47 Carsten Note Added: 0003234
2019-04-04 00:17 carl Note Added: 0003235
2019-04-05 23:14 carl Status confirmed => feedback
2019-04-05 23:14 carl Note Added: 0003237
2019-04-06 22:13 carl Status feedback => resolved
2019-04-06 22:13 carl Resolution open => fixed
2019-04-06 22:13 carl Note Added: 0003246