View Issue Details

IDProjectCategoryView StatusLast Update
0001592DCP-o-matic[All Projects] Bugspublic2019-11-27 19:31
Reporteralexthebassist Assigned Tocarl  
PriorityhighSeverityblockReproducibilityalways
Status assignedResolutionfixed 
PlatformLinuxOSKDE NeonOS Version5.16
Product Version 
Target Version2.16.0Fixed in Version 
Summary0001592: No playback with KDM
Description

We recently decided to give Ubuntu (KDE neon actually) a test ride in our cinema. I moved all the decryption credentials to a freshly setup system (it's age is less than half an hour at the moment I am writing this), but couldn't open any of encrypted DCPs. The player accepts the key, but does not start playback. The playback button is stuck in pressed mode when a KDM is loaded and checked, and nothing happens if I press it again no matter how many times I do that. Encrypted DCP playback works well on CentOS 7 and Fedora 29.

Steps To Reproduce
  1. Open an encrypted DCP
  2. Open a corresponding KDM
  3. Fail at playing the movie
Tagsplayer
Estimated weeks required
Estimated work requiredUndecided

Activities

alexthebassist

2019-09-24 14:42

reporter   ~0003431

None of recent test versions worked. What's worked both with and without KDM is the latest stable, but it's affected by the bug 0001472.

alexthebassist

2019-09-24 14:43

reporter   ~0003432

By “latest stable” I mean version 2.14.10.

carl

2019-09-24 14:50

administrator   ~0003433

I think there is a fix for this in the tree, but my build server is offline for about a week so I can't upload any new builds until then.

carl

2019-10-21 14:04

administrator   ~0003490

I think this is all sorted now.

alexthebassist

2019-10-21 14:34

reporter   ~0003491

Seems to finally work in latest development branch. Fix confirmed.

alexthebassist

2019-10-29 13:49

reporter   ~0003508

It's still unclear if the issue is resolved or not. I'll report on that in a week or so.

alexthebassist

2019-11-05 19:43

reporter   ~0003552

The bug is NOT resolved on any of recent unstable versions.

carl

2019-11-05 19:45

administrator   ~0003553

Are the symptoms still the same?

alexthebassist

2019-11-05 19:55

reporter   ~0003554

Yes, nothing changed so far. When I was reporting the new version worked, it was in fact an older one installed without my acknowledgement.

carl

2019-11-05 20:03

administrator   ~0003555

Still works for me. Is it feasible to set up a remote login session to your machine?

alexthebassist

2019-11-06 10:57

reporter   ~0003559

We can probably do it on Thursday morning via NoMachine. Is that okay?

carl

2019-11-06 10:59

administrator   ~0003560

Yes, I should be available from around 9am UTC+1. Feel free to get in touch on carl@dcpomatic.com

Issue History

Date Modified Username Field Change
2019-08-22 11:34 alexthebassist New Issue
2019-08-22 11:34 alexthebassist Tag Attached: dcp
2019-08-22 11:34 alexthebassist Tag Attached: player
2019-08-23 23:35 carl Target Version => 2.16.0
2019-09-24 14:42 alexthebassist Note Added: 0003431
2019-09-24 14:43 alexthebassist Note Added: 0003432
2019-09-24 14:50 carl Note Added: 0003433
2019-10-21 14:04 carl Assigned To => carl
2019-10-21 14:04 carl Status new => resolved
2019-10-21 14:04 carl Resolution open => fixed
2019-10-21 14:04 carl Note Added: 0003490
2019-10-21 14:34 alexthebassist Note Added: 0003491
2019-10-29 13:49 alexthebassist Note Added: 0003508
2019-11-05 19:43 alexthebassist Note Added: 0003552
2019-11-05 19:45 carl Status resolved => assigned
2019-11-05 19:45 carl Note Added: 0003553
2019-11-05 19:55 alexthebassist Note Added: 0003554
2019-11-05 20:03 carl Note Added: 0003555
2019-11-05 20:04 carl Status assigned => feedback
2019-11-06 10:57 alexthebassist Note Added: 0003559
2019-11-06 10:57 alexthebassist Status feedback => assigned
2019-11-06 10:59 carl Note Added: 0003560
2019-11-27 19:27 carl Tag Detached: player
2019-11-27 19:27 carl Tag Detached: dcp
2019-11-27 19:31 carl Tag Attached: player