View Issue Details

IDProjectCategoryView StatusLast Update
0001639DCP-o-matic[All Projects] Featurespublic2020-05-17 19:23
Reportercarl Assigned Tocarl  
PriorityurgentSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version2.16.0Fixed in Version 
Summary0001639: More comprehensive validation
Description

[]

Tagsmajor
Branch
Estimated weeks required2
Estimated work requiredUndecided

Activities

carl

2019-12-04 23:46

administrator   ~0003626

Last edited: 2020-05-08 22:39

View 2 revisions

Some ideas:

  • Certificate chain validity (including notBefore/notAfter)
  • ID, date format validities
  • DCI picture dimensions

carl

2019-12-09 22:06

administrator   ~0003631

Schema checking with xerces added in libdcp:xerces branch. Still should do picture dimensions, certificate chain validity, JPEG2000 frame size...

carl

2020-04-17 21:29

administrator   ~0003771

xerces branch merged to master.

carl

2020-05-06 22:20

administrator   ~0003802

Last edited: 2020-05-06 22:21

View 2 revisions

So the list is now:

  1. picture dimensions
  2. certificate chain validity (signer)
  3. JPEG2000 frame size (bytes)

Anything else?

carl

2020-05-06 23:09

administrator   ~0003803

Some work on frame size checking in libdcp:verify-j2k-sizes

carl

2020-05-07 19:30

administrator   ~0003804

JPEG2000 frame size now in libdcp master.

carl

2020-05-07 20:30

administrator   ~0003805

Last edited: 2020-05-07 20:52

View 2 revisions

Hacks for certificate chain checking in libdcp:check-chains but this requires going 10 rounds with xmlsec1 which I may not have the energy for. Although it looks like xmlsec1's verify (not unreasonably) wants the cert of the CA which issued the root. What do we actually want to check here? Just that the chain's root signs its intermediate, and so on?

carl

2020-05-07 21:03

administrator   ~0003806

Last edited: 2020-05-08 22:34

View 2 revisions

XML validity checks on subtitles added in libdcp:1b7394d83f64a8655787d82189c3170a2128c16b

carl

2020-05-17 19:23

administrator   ~0003820

I'll mark this resolved and we can add more specific requests in individual bugs.

Issue History

Date Modified Username Field Change
2019-10-24 21:56 carl New Issue
2019-10-24 21:57 carl Assigned To => carl
2019-10-24 21:57 carl Status new => confirmed
2019-11-27 16:22 carl Tag Attached: major
2019-11-27 22:00 carl Estimated weeks required => 2
2019-11-27 22:00 carl Estimated work required => Undecided
2019-12-04 23:32 carl Summary More comprehensive validation and perhaps a separate validation tool => More comprehensive validation
2019-12-04 23:46 carl Note Added: 0003626
2019-12-09 22:06 carl Note Added: 0003631
2020-04-17 21:29 carl Note Added: 0003771
2020-05-06 22:20 carl Note Added: 0003802
2020-05-06 22:21 carl Note Edited: 0003802 View Revisions
2020-05-06 23:09 carl Note Added: 0003803
2020-05-07 19:30 carl Note Added: 0003804
2020-05-07 20:30 carl Note Added: 0003805
2020-05-07 20:52 carl Note Edited: 0003805 View Revisions
2020-05-07 21:03 carl Note Added: 0003806
2020-05-08 22:34 carl Note Edited: 0003806 View Revisions
2020-05-08 22:39 carl Note Edited: 0003626 View Revisions
2020-05-17 19:23 carl Status confirmed => resolved
2020-05-17 19:23 carl Resolution open => fixed
2020-05-17 19:23 carl Note Added: 0003820