View Issue Details

IDProjectCategoryView StatusLast Update
0001786DCP-o-matic[All Projects] Bugspublic2020-07-29 09:11
Reportercarl Assigned Tocarl  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version2.14.xFixed in Version 
Summary0001786: Crash when exporting 7.1 project to MP4
Description

could not open FFmpeg audio codec; happens in 2.14.x and 2.15.x.

TagsNo tags attached.
Branch
Estimated weeks required
Estimated work required

Activities

carl

2020-07-27 21:10

administrator   ~0003873

Last edited: 2020-07-27 21:24

View 3 revisions

The list of layouts in aacenctab.h just doesn't support our strange attempt to write a 12-channel 7.1 file. Maybe we need to special-case this to throw away the silent channels. I don't know what's best for larger channel counts...

carl

2020-07-27 21:46

administrator   ~0003874

16 channels seems to be OK so let's just do 16 channels for any project with more than 8. Otherwise it's going to get (more) complicated.

carl

2020-07-29 09:11

administrator   ~0003875

525d5c76b24119125572805ef041b1b226233069 in master,2f796cd531de522a3b7ed03a9942f3c55f3a0b5b in v2.15.x

Issue History

Date Modified Username Field Change
2020-07-27 20:52 carl New Issue
2020-07-27 20:53 carl Assigned To => carl
2020-07-27 20:53 carl Status new => confirmed
2020-07-27 21:10 carl Note Added: 0003873
2020-07-27 21:23 carl Note Edited: 0003873 View Revisions
2020-07-27 21:24 carl Note Edited: 0003873 View Revisions
2020-07-27 21:46 carl Note Added: 0003874
2020-07-29 09:11 carl Status confirmed => resolved
2020-07-29 09:11 carl Resolution open => fixed
2020-07-29 09:11 carl Note Added: 0003875