View Bug Details

IDProjectCategoryView StatusLast Update
0001858DCP-o-maticBugspublic2020-12-23 00:54
Reportercarl Assigned Tocarl  
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Target Version2.16.0 
Summary0001858: Letting a project play to the end and then pressing play again causes strange things to happen
Description

[]

TagsNo tags attached.
Branch
Estimated weeks required
Estimated work requiredSmall

Activities

carl

2020-12-22 23:25

administrator   ~0004074

Pressing play after we've reached the end causes VideoView::get_next_frame()'s call to butler->get_video() to return null (with time 0) since there's no more video data.

This makes the FilmViewer think that we're at position 0, which we aren't.

Probably get_next_frame()'s return code should differentiate between no video and 'again'. You can't just return false in the no-video case as it will cause get_next_frame() to be called over and over.

carl

2020-12-23 00:54

administrator   ~0004075

Hopefully fixed by 6516fb170b0e7a83c582a858fb54d1f83f751cc0

Bug History

Date Modified Username Field Change
2020-10-14 20:11 carl New Bug
2020-10-14 20:12 carl Reproducibility have not tried => always
2020-10-14 20:12 carl Status new => confirmed
2020-10-14 20:12 carl Estimated work required => Undecided
2020-12-01 12:33 carl Estimated work required Undecided => Small
2020-12-22 23:25 carl Note Added: 0004074
2020-12-23 00:54 carl Assigned To => carl
2020-12-23 00:54 carl Status confirmed => resolved
2020-12-23 00:54 carl Resolution open => fixed
2020-12-23 00:54 carl Note Added: 0004075