View Bug Details

IDProjectCategoryView StatusLast Update
0002159DCP-o-maticBugspublic2022-01-11 21:17
Reporterrobn Assigned Tocarl  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Target Version2.16.0 
Summary0002159: DOM crashes on input file
Description

I noticed DOM 2.15.180 and 2.15.182 crash on a downloaded YouTube file.
The file plays fine in a other video player (for example "mpv").

Steps To Reproduce

==> an error pops up (see added screenshot)
After pressing OK, DOM terminates

Tagsci
Branch2159-bad-decoding
Estimated weeks required
Estimated work requiredUndecided

Relationships

has duplicate 0002158 resolvedcarl DOM crashes on input file 

Activities

robn

2022-01-01 00:43

reporter   ~0004743

The screenshot

robn

2022-01-01 00:50

reporter   ~0004744

Uploading an image seems to give an error from Mantis .. :

APPLICATION ERROR 0000504

No file was uploaded. Please go back and Choose a file before pressing Upload.
Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

Anyway, the pop-up error reads:

"avcodec_receive_frame failed [FFmpeg::decode_and_process_video_packet] (-1094995529)"

robn

2022-01-01 00:56

reporter   ~0004745

Sorry for the 3 reports: I tried again because my added screenshot (27572 bytes jpeg) was refused several times.
Didn't realise that the rest of the bug report was added!

carl

2022-01-09 16:50

administrator   ~0004752

@carl Downloading

carl

2022-01-11 08:43

administrator   ~0004754

@carl avcodec_receive_frame_failed [FFmpeg::decode_and_process_video_packet] (-1094995529)

carl

2022-01-11 08:43

administrator   ~0004755

@carl i.e. "INDA"

carl

2022-01-11 15:43

administrator   ~0004756

Should have a test for this.

carl

2022-01-11 21:14

administrator   ~0004757

Last edited: 2022-01-11 21:16

0070c968403a46b464bc259e6e2dcd89c541dcf2 and 758c1ba16ab87152621f6c7c62c2e011a2ae2712

carl

2022-01-11 21:17

administrator   ~0004758

@robn thanks for the report; this should be fixed in 2.15.183

Bug History

Date Modified Username Field Change
2022-01-01 00:42 robn New Bug
2022-01-01 00:43 robn Note Added: 0004743
2022-01-01 00:50 robn Note Added: 0004744
2022-01-01 00:56 robn Note Added: 0004745
2022-01-01 01:03 carl Relationship added has duplicate 0002158
2022-01-01 01:03 carl Status new => acknowledged
2022-01-01 01:03 carl Target Version => 2.16.0
2022-01-01 01:03 carl Estimated work required => Undecided
2022-01-09 16:50 carl Note Added: 0004752
2022-01-11 08:40 carl Assigned To => carl
2022-01-11 08:40 carl Status acknowledged => confirmed
2022-01-11 08:43 carl Note Added: 0004754
2022-01-11 08:43 carl Note Added: 0004755
2022-01-11 15:43 carl Branch => 2159-bad-decoding
2022-01-11 15:43 carl Tag Attached: ci
2022-01-11 15:43 carl Note Added: 0004756
2022-01-11 21:14 carl Status confirmed => resolved
2022-01-11 21:14 carl Resolution open => fixed
2022-01-11 21:14 carl Note Added: 0004757
2022-01-11 21:16 carl Note Edited: 0004757
2022-01-11 21:17 carl Note Added: 0004758