View Bug Details

IDProjectCategoryView StatusLast Update
0000725DCP-o-matic[All Projects] Featurespublic2018-10-17 19:16
ReportercarlAssigned Tocarl 
PriorityhighSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target Version2.14.0Fixed in Version 
Summary0000725: CCAP
Description

A demo DCP is here

http://isdcf.com/t/SMPTE-DCP-Tests/

and also Carsten forwarded one from Harold but its 9GB.

TagsNo tags attached.
Estimated work requiredMajor

Relationships

related to 0001346 closedcarl Out times of CCAPs don't match subs when the same source file is used 

Activities

Igor.Voyt

2015-10-26 11:51

reporter   ~0000921

What do we do with this? :)
I can see dark-green subtitles in DCP-o-matic ver.2.4.12 at top-right corner.

carl

2015-10-26 12:02

administrator   ~0000922

The main thing is to support creation of DCPs with CCAP and this DCP shows what needs to be done. It would be nice if everything worked on import too.

carl

2015-11-05 14:28

administrator   ~0000956

http://isdcf.com/papers/ISDCF-Doc9-Closed-Caption-Authoring-Best-Practices.pdf

IntMarine

2017-09-04 02:38

reporter   ~0001810

I believe that the link for the demo DCP in the Description section is wrong. It goes to a non-link.
Since the DCP changes from time to time, the best link is:
<http://isdcf.com/t/SMPTE-DCP-Tests/>

Furthermore, there is another ISDCF document that has a few subtle points to make in the use of Closed Captions
ISDCF Document 10 - Subtitles and Captions in Digital Cinema at:
<http://isdcf.com/ISDCF/technical-documents.html>

Carsten

2017-09-04 12:07

manager   ~0001811

We should probably dig up some sites with CCAP hardware for testing. I am pretty sure Harold Hallikainen would also look over some test files.

  • Carsten

carl

2017-09-04 23:44

administrator   ~0001812

@carl: basics are in libdcp git and ccap branch. First major difficulty is that DCP could have both subtitle & ccap, and the metadata format can't cope as all the tags for video/audio/subtitle are dumped into one parent.

carl

2017-09-11 21:38

administrator   ~0001819

@carl: perhaps this should be treated using subtitle streams; i.e. FFmpeg and DCP have multiple streams and we have a subtitle stream and a CCAP one.

carl

2018-07-19 23:07

administrator   ~0002534

Basics of CCAP creation are now in master; importing DCP with subtitle + CCAP needs some thought. How likely is it? Really we would want a tab for open and closed captions in this case. Not sure how feasible this is.

carl

2018-07-19 23:09

administrator   ~0002535

It would be nice if we could select a DCP and have two tabs appear (subtitle + closed caption) but this sounds nasty to implement.

Carsten

2018-07-20 12:49

manager   ~0002536

For now, I would skip the import thing. Couldn't we always import CCAP files from a DCP separately?
Or, just grey out CCAP tab if no CCAP content is loaded?

  • Carsten

carl

2018-07-20 12:58

administrator   ~0002537

Yes that would work. They could also be imported separately. I was just wondering whether it's common to have both subs and closed captions in a single DCP...

Carsten

2018-07-20 14:36

manager   ~0002538

Last edited: 2018-07-20 18:08

View 2 revisions

Yes, subtitles/OCAPs going with CCAPs are common.

  • Carsten

Carsten

2018-07-22 14:43

manager   ~0002539

Have you seen the latest ISDCF Meeting report (Mastering constraints). It says that if there are subs in any reel, every reel needs a sub reel (nothing new), and the same for CCAPs.

  • Carsten

carl

2018-07-22 18:22

administrator   ~0002541

I hadn't noticed that, and I hadn't realised that every reel needs a sub reel. Thanks!

Carsten

2018-07-23 00:48

manager   ~0002550

Last edited: 2018-07-23 00:56

View 2 revisions

Hmm...

Following 'Update to SMPTE standards to reflect the currently used profile':
http://isdcf.com/MeetingNotes/MeetingNotes20180308v3-POSTED.pdf

but:

https://cinepedia.com/accessibility/#section-1312

I remember that the 'without entry point and duration' phrase came up often in various locations, some also dealing with the 'official' ISDCF SMPTE DCP constraints, but I never understood what it meant. That Cinepedia article seems to clarify that.

  • Carsten

Carsten

2018-07-25 02:14

manager   ~0002556

Hmm, maybe it IS possible to get away with a single 'Captions' tab? If we can declare them to be subtitles or closed captions per content file, we could have e.g. two XML files in a project, one as subtitles, one as closed captions, with the appearance options being greyed out for closed captions? That would render the content tabs a bit more compact. It's true, not so many people will create closed captions, so why should they be so prominent in the GUI?

Other than that - nice work on the CCAPs both in main and player.

  • Carsten

carl

2018-07-25 07:59

administrator   ~0002557

I'm not sure if that works for DCP content which could have both... in the current version I've tried an arrangement where tabs appear and disappear as they are required. Maybe we can see if this is too annoying / weird.

Carsten

2018-07-25 11:59

manager   ~0002561

Last edited: 2018-07-25 12:08

View 5 revisions

Ah, right, OCAP+CCAP DCP as content that's what you were after with 'I was just wondering whether it's common to have both subs and closed captions in a single DCP...'

Yeah, no big deal, I just noticed it would work for a standard project with separate OCAP and CCAP content. The switching tabs may be a bit confusing for the long-time users at first, at the same time, why have all these tabs when they are no use for the currently selected content.

Oops - I just wanted to open a CCAP test project (Bunny with some CCAP) I created yesterday with 2.13.38 - but right after choosing the folder or 'recent files', DCP-o-matic vanishes silently. Means, I can not open a project that contains CCAPs. OS X. edit: also happens with subtitles.

Also, see attached screen shot 'Could not load film' - that is from a pre-existing project I tried to load. It does appear as if the CCAP addition changed something about subtitle content interpretation in project files?

  • Carsten


Carsten

2018-07-25 12:00

manager  

metadata.xml (9,949 bytes)

Carsten

2018-07-25 12:42

manager   ~0002562

Last edited: 2018-07-26 15:40

View 4 revisions

And wow, PNG subtitles? I saw 'Bitmapped subtitles' and hoped for PNG, but not enough to immediately try it. ;-)
Maybe change that entry on the changelist to into something more clear, like 'PNG subtitles, or 'Timed-Text PNG subtitles'.
'Timed-Text PNG' seems to be a common description, although I notice that even the ISDCF big-buffs feal uneasy about that formulation. Maybe we should just name it 'Timed PNG subtitles'?

And then offer a choice in the GUI to either burn-in or use as timed PNG? That would make it clearer I guess?

  • Carsten

Carsten

2018-07-26 14:45

manager   ~0002565

I contacted Harold Hallikainen wether he wanted to test DCP-o-matic CCAP DCPs on USL/QSC equipment. He was excited, but (sigh...) first thing he was interested in was DCPs with different language CCAPs, as yet they can be seen rarely in the wild, and of course he wants to test them against his own code ;-)
Seems that CCAP equipment allows or should allow to have multiple CCAP from which to choose at playtime.

I told him I wouldn't know wether that is currently supported, but for now, sent him a basic test DCP with single, two and three liners.

BTW - I see that in Interop, liberation-sans is still added to the CCAP folder. It probably won't hurt for now?

Playback of 1,2,3 lines and line length VU meter work nicely. But maybe it would be better to always open the CCAP window with a fixed length, so that the full lines are always visible without prior resizing?

Good work. Now hopefully someone uses it ;-)

  • Carsten

Carsten

2018-07-26 15:12

manager   ~0002566

BTW - in my tests for Harold, I created CCAP and reused the same input file for simultaneous subtitle/OCAP. This works in DCP-o-matic and the player (simultaneous playback of subs and CCAP), but it looks as if the CCAP display module is always early with the out time. They match in in-time, but CCAP disappears about one second earlier. In- and Out-Time is identical in both source as well as created XML. No big deal, but...

Will send these to Harold now and hope he can give us feedback soon.

  • Carsten

Carsten

2018-07-26 15:12

manager   ~0002567

Last edited: 2018-07-26 15:13

View 2 revisions

Oh - and Carl - have a beer, this round's on me!

  • Carsten

carl

2018-07-27 00:05

administrator   ~0002575

I've updated the changelog and added new bugs for multi-language, fonts, CCAP window aspect and out-time incorrect. Burp!

Bug History

Date Modified Username Field Change
2015-10-26 11:03 carl New Bug
2015-10-26 11:51 Igor.Voyt Note Added: 0000921
2015-10-26 12:02 carl Note Added: 0000922
2015-10-30 13:25 carl Priority normal => low
2015-10-30 13:25 carl Status new => confirmed
2015-11-05 14:28 carl Note Added: 0000956
2017-09-03 21:46 carl Target Version => 2.12.0
2017-09-04 02:38 IntMarine Note Added: 0001810
2017-09-04 12:07 Carsten Note Added: 0001811
2017-09-04 12:54 carl Description Updated View Revisions
2017-09-04 23:44 carl Note Added: 0001812
2017-09-11 21:38 carl Note Added: 0001819
2018-01-16 23:34 carl Target Version 2.12.0 => 2.14.0
2018-07-09 20:56 carl Priority low => high
2018-07-09 20:56 carl Estimated work required Average => Major
2018-07-19 23:07 carl Assigned To => carl
2018-07-19 23:07 carl Status confirmed => resolved
2018-07-19 23:07 carl Resolution open => fixed
2018-07-19 23:07 carl Note Added: 0002534
2018-07-19 23:09 carl Note Added: 0002535
2018-07-20 12:49 Carsten Note Added: 0002536
2018-07-20 12:58 carl Note Added: 0002537
2018-07-20 14:36 Carsten Note Added: 0002538
2018-07-20 18:08 Carsten Note Edited: 0002538 View Revisions
2018-07-22 14:43 Carsten Note Added: 0002539
2018-07-22 18:22 carl Note Added: 0002541
2018-07-23 00:48 Carsten Note Added: 0002550
2018-07-23 00:56 Carsten Note Edited: 0002550 View Revisions
2018-07-25 02:14 Carsten Note Added: 0002556
2018-07-25 07:59 carl Note Added: 0002557
2018-07-25 11:59 Carsten File Added: Bildschirmfoto 2018-07-25 um 13.57.11.png
2018-07-25 11:59 Carsten Note Added: 0002561
2018-07-25 11:59 Carsten Note Edited: 0002561 View Revisions
2018-07-25 12:00 Carsten File Added: metadata.xml
2018-07-25 12:05 Carsten Note Edited: 0002561 View Revisions
2018-07-25 12:06 Carsten Note Edited: 0002561 View Revisions
2018-07-25 12:08 Carsten Note Edited: 0002561 View Revisions
2018-07-25 12:42 Carsten Note Added: 0002562
2018-07-25 12:43 Carsten Note Edited: 0002562 View Revisions
2018-07-25 13:21 Carsten Note Edited: 0002562 View Revisions
2018-07-26 14:45 Carsten Note Added: 0002565
2018-07-26 15:12 Carsten Note Added: 0002566
2018-07-26 15:12 Carsten Note Added: 0002567
2018-07-26 15:13 Carsten Note Edited: 0002567 View Revisions
2018-07-26 15:40 Carsten Note Edited: 0002562 View Revisions
2018-07-26 16:15 carl Relationship added related to 0001346
2018-07-27 00:05 carl Note Added: 0002575
2018-10-17 19:16 carl Status resolved => closed