View Bug Details

IDProjectCategoryView StatusLast Update
0001000DCP-o-matic[All Projects] Bugspublic2018-01-08 23:18
ReporterCarstenAssigned Tocarl 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionreopened 
PlatformMacOSOS XOS Version10.6
Product Version2.9.0 
Target Version2.12.0Fixed in Version 
Summary0001000: Wrong decryption KDM applied results in crash
DescriptionI was just playing around with decrypting DCPs, supplying a wrong KDM to DOM 2.9.40 OS X intentionally. It resulted in an error message, and DOM crashed afterwards. Should probably deal with this issue more gracefully.


TagsNo tags attached.
Estimated work requiredAverage

Relationships

related to 0001161 new Give nicer error on supplying an incorrect KDM 

Activities

Carsten

2016-11-15 02:25

manager  

Carsten

2016-11-18 11:09

manager  

Carsten

2016-11-18 11:10

manager  

Carsten

2016-11-18 11:11

manager   ~0001554

In 2.10.1: Applying a wrong KDM first results in a decoding error shown below the progress bar. Then, when I click that encrypted content again, the app crashes. See screenshots.

carl

2018-01-04 22:51

administrator   ~0001911

I believe this is fixed now: please add a note if not.

Carsten

2018-01-06 00:48

manager   ~0001923

The crash still occurs in 2.11.36 OS X - the behavior is as in the screenshots above - as long as an initial 'Needs KDM' is indicated in content list, a right click on the content/dcp is possible. After a wrong KDM has been assigned, the status bar in the lower right shows 'Error - could not decrypt KDM (...)'. So far, so good.
When I right click the content again to assign another, hopefully working KDM, DOM crashes.

- Carsten

Carsten

2018-01-06 00:50

manager  

carl

2018-01-06 23:10

administrator   ~0001934

Should be fixed by db19d69c0c33fe64cf60ec85bf59c4c15ec37383

Carsten

2018-01-08 02:12

manager   ~0001940

Hmm, this seems to be a tough one - in 2.11.38, I can now right-click->Assign KDM as often as I want without crashing - that solves the issue should someone use a wrong KDM initially, then want's to correct his choice.
However, if I left-click on the encrypted DCP afterwards (still with 'Needs KDM' flagged), I still get the same crash as before.

Not such a big deal. Personally, I wish there would be a nice dialog saying 'Sorry, this KDM doesn't match the content you tried to assign it to', but, for now, it allows to select another, possibly working KDM.

- Carsten

carl

2018-01-08 23:16

administrator   ~0001941

That other crash should be fixed by 160a401d16e3962b10f3105e00992936a8188424 in 2.11.39.

carl

2018-01-08 23:18

administrator   ~0001942

Closing this again; the nicer-error idea is in 0001161.

Bug History

Date Modified Username Field Change
2016-11-15 02:25 Carsten New Bug
2016-11-15 02:25 Carsten File Added: Bildschirmfoto 2016-11-15 um 03.19.31.jpg
2016-11-18 11:09 Carsten File Added: Bildschirmfoto 2016-11-18 um 12.05.41.jpg
2016-11-18 11:10 Carsten File Added: Bildschirmfoto 2016-11-18 um 12.05.59.jpg
2016-11-18 11:11 Carsten Note Added: 0001554
2016-11-18 11:24 carl Target Version => 2.11.0
2016-11-19 20:20 carl Target Version 2.11.0 => 2.10.2
2016-12-13 09:33 carl Target Version 2.10.2 => 2.11.0
2017-04-21 09:26 carl Status new => confirmed
2017-04-21 09:26 carl Target Version 2.11.0 => 2.12.0
2018-01-04 22:51 carl Assigned To => carl
2018-01-04 22:51 carl Status confirmed => resolved
2018-01-04 22:51 carl Resolution open => fixed
2018-01-04 22:51 carl Note Added: 0001911
2018-01-06 00:48 Carsten Status resolved => feedback
2018-01-06 00:48 Carsten Resolution fixed => reopened
2018-01-06 00:48 Carsten Note Added: 0001923
2018-01-06 00:50 Carsten File Added: Bildschirmfoto 2018-01-06 um 01.40.48.png
2018-01-06 23:01 carl Status feedback => confirmed
2018-01-06 23:10 carl Status confirmed => resolved
2018-01-06 23:10 carl Note Added: 0001934
2018-01-08 02:12 Carsten Status resolved => feedback
2018-01-08 02:12 Carsten Note Added: 0001940
2018-01-08 23:16 carl Note Added: 0001941
2018-01-08 23:18 carl Relationship added related to 0001161
2018-01-08 23:18 carl Status feedback => resolved
2018-01-08 23:18 carl Note Added: 0001942