View Bug Details

IDProjectCategoryView StatusLast Update
0000752DCP-o-matic[All Projects] Bugspublic2016-08-18 15:52
ReportercarlAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000752: Colour fringing / anti-aliasing / something on outlined subs in preview
Description[]
TagsNo tags attached.
Estimated work requiredAverage

Relationships

related to 0000936 resolvedcarl Miscoloured subtitles when burning into existing DCP content 

Activities

carl

2015-11-17 11:32

administrator  

fringing.png (298,999 bytes)

carl

2015-11-17 17:58

administrator   ~0000992

Looks like possibly windows-only.

Igor.Voyt

2015-11-17 18:00

reporter   ~0000993

Probably it is so. I tried on Ubuntu and didn't see anything like that

carl

2015-11-17 22:12

administrator   ~0000999

Can't reproduce it on Windows either. Maybe a font thing...?

cloud06

2016-04-11 13:28

reporter   ~0001191

Last edited: 2016-04-11 13:29

View 2 revisions

I have this same problem on Mac OS X... Tried Arial and Tahoma. Same thing happens.

EDIT: it is also visible in DCP with burned in subtitles...

Carsten

2016-04-11 14:21

reporter   ~0001192

Looks okay in 2.7.11 under OS X 10.6.8

I guess some combinations of font size and outlining could create such issues. Also, when burning in subtitles, the J2C could create similar looking artifacts, because the hard-edged, high contrast chars undergo the J2C compression.

Carl - does DOM apply some antialiasing when burning in subtitles? Could be advisable. Make it a feature request ... ;-)

cloud06

2016-04-11 15:38

reporter   ~0001194

I'm using 10.11.3 and latest version. Scale is 100%x100%... Also, edges look jagged. Maybe anti-aliasing would help. Also, it would be great to have option to change outline size, maybe use shadow instead... But that's feature request, not bug report :)

robn

2016-04-12 01:57

reporter   ~0001197

I see it with Linux Fedora 22 (but only in DOM, not in the DCP!)

cloud06

2016-04-20 15:39

reporter   ~0001209

When I make burned-in subtitles, they have exactly the same look as in DOM... Strange thing is - I made DCP before realising this using exactly the same settings. Maybe I just had older version of DOM and they didn't have any issues with burned in subtitles.

cloud06

2016-05-10 19:58

reporter   ~0001233

Any news on this issue? I'm experiencing it in newest version - 2.8.0... Really important issue for me :(

I'm making burn ins and having this issue.

Carsten

2016-05-11 10:21

reporter   ~0001234

Can you supply a demo project (incl. font) and screen grab from the MXF? VLC will do screen grabs from J2C MXFs.

- Carsten

cloud06

2016-05-11 11:23

reporter   ~0001235

Last edited: 2016-05-11 11:23

View 2 revisions

It happnes when I import DCP and want to burn in SRT subtitles. I just tried with importing video file to DOM and importing subtitles, setting outline... Looks good.

Screenshot from EasyDCP:
https://www.dropbox.com/s/zz9w5smnc4uspxz/subtitles.jpg?dl=0

It is like this regardless of font used...

Carsten

2016-05-11 11:27

reporter   ~0001236

Maybe bring this to the forum or mailing list?

But it's an important fact it happens only when burning into an existing DCP/MXF. Does it happen without outlining, too?

- Carsten

Carsten

2016-05-11 11:33

reporter   ~0001237

Hmm, I see a lot of compression artifacts around the titles. What data rate do you use?

Carl - I guess Anti-Aliasing is advisable. It's not a problem with timed-text, as a 1:1 pixel representation is overlayed on a J2c image. But when burning in, it can cause trouble.

You can probably reduce the effect a bit by using 'soft' colours for the titles, e.g. no full white/black.

In your example, the purple fringing is also visible in parts of the image around the title. I am nearly sure what you experience here is different from what the original reporter sees in the preview.

Your's is definitely J2C/compression artifact related.

- Carsten

cloud06

2016-05-11 11:37

reporter   ~0001238

That's bad JPEG from dropbox... Try this link:
https://www.dropbox.com/s/zz9w5smnc4uspxz/subtitles.jpg?dl=1

It is like this regardless of bitrate and when using same colors and same titles. It happens in project with imported DCP and not in project with imported QT (for example ProRes)... It has to be something to do with importing DCP.

Carsten

2016-05-11 11:47

reporter   ~0001239

Makes no difference. Again, what datarate do you use?

Do you have a DCP-o-matic forum account? Better to bring this issue up there, this is not a discussion forum.

Interesting issue anyway, wondering what Carl is going to say about it.

Maybe there is a bug in the colorspace adoption between the J2C XYZ and the font sRGB. DOM needs to do decompress, inverse XYZ the image, overlay with title sRGB, then XYZ the composed result and recompress. He could also XYZ the title, leave the decompressed image in XYZ, compose and recompress to J2C. Could be something around this. Still a miracle why the fringing is only cyan and why it only occurs on certain parts of the title. But I guess Carl has something to work on now.

- Carsten

cloud06

2016-05-11 11:58

reporter   ~0001240

I usually use 220 mbps... But as I said - I eliminated that as a reason because I used different settings and it doesn't affect result.

It is like this in DOM preview and exactly the same in final DCP.

cloud06

2016-05-11 12:17

reporter   ~0001241

My last post for now, as definitive confirmation that it has something to do with importing DCP:

I deleted DCP from project and imported QT file of the same film and same length (in same project with the same settings). No problems with titles... It just disappears and title outline looks great.

carl

2016-05-11 15:52

administrator   ~0001242

Thanks chaps, I can see the problem with overlaying outlined subs on a DCP source here now.

carl

2016-05-12 00:11

administrator   ~0001244

Hopefully fixed by 12eb3f36b30087c136a9855706450cbb01ffd7c2 and 631f905234537d2b0a24e9b3ff40f08a17c0fd8b. @cloud06: could you please try 2.8.2 from dcpomatic.com/test-download and let us know if it's any better?

cloud06

2016-05-12 08:05

reporter   ~0001245

Thanks Carl, looks great now.

carl

2016-05-12 13:18

administrator   ~0001246

Good news, thanks for letting us know.

Bug History

Date Modified Username Field Change
2015-11-17 11:31 carl New Bug
2015-11-17 11:32 carl File Added: fringing.png
2015-11-17 17:58 carl Note Added: 0000992
2015-11-17 18:00 Igor.Voyt Note Added: 0000993
2015-11-17 22:12 carl Note Added: 0000999
2016-04-11 13:28 cloud06 Note Added: 0001191
2016-04-11 13:29 cloud06 Note Edited: 0001191 View Revisions
2016-04-11 14:21 Carsten Note Added: 0001192
2016-04-11 15:38 cloud06 Note Added: 0001194
2016-04-12 01:57 robn Note Added: 0001197
2016-04-20 15:39 cloud06 Note Added: 0001209
2016-05-10 19:58 cloud06 Note Added: 0001233
2016-05-11 10:21 Carsten Note Added: 0001234
2016-05-11 11:23 cloud06 Note Added: 0001235
2016-05-11 11:23 cloud06 Note Edited: 0001235 View Revisions
2016-05-11 11:27 Carsten Note Added: 0001236
2016-05-11 11:33 Carsten Note Added: 0001237
2016-05-11 11:37 cloud06 Note Added: 0001238
2016-05-11 11:47 Carsten Note Added: 0001239
2016-05-11 11:58 cloud06 Note Added: 0001240
2016-05-11 12:17 cloud06 Note Added: 0001241
2016-05-11 15:52 carl Note Added: 0001242
2016-05-11 15:52 carl Assigned To => carl
2016-05-11 15:52 carl Status new => confirmed
2016-05-12 00:11 carl Note Added: 0001244
2016-05-12 00:11 carl Status confirmed => feedback
2016-05-12 08:05 cloud06 Note Added: 0001245
2016-05-12 13:18 carl Note Added: 0001246
2016-05-12 13:18 carl Status feedback => assigned
2016-05-12 13:18 carl Status assigned => resolved
2016-05-12 13:18 carl Resolution open => fixed
2016-08-18 15:52 carl Relationship added related to 0000930
2016-08-18 15:52 carl Relationship deleted related to 0000930
2016-08-18 15:52 carl Relationship added related to 0000936