View Bug Details

IDProjectCategoryView StatusLast Update
0000975DCP-o-matic[All Projects] Featurespublic2017-02-12 20:21
ReportercarlAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version2.11.0Fixed in Version 
Summary0000975: VF KDMs should probably include the keys for the OV
DescriptionIf you've imported an encrypted OV and make a KDM for the VF we should include keys for the OV, though possibly not without checking with the user since that might be considered a leak.
TagsNo tags attached.
Estimated work requiredAverage

Activities

scorpio81

2016-10-17 16:13

reporter   ~0001475

A KDM for VF should contain encryption keys for all assets in the VF CPL which include some or all assets of OV CPL. This KDM should only allow playback of this particular VF CPL and not OV CPL.
For example, if VF adds subtitles then a KDM for VF should contain keys for all assets from OV (subtitles might not be encrypted). And if VF replaces audio, then a KDM for VF should contain a key for video from OV and a key for audio from VF, not from OV.

carl

2017-02-12 20:21

administrator   ~0001610

Fixed by df29125d2f63b5c2e36b373462eac9684d8046e4

Bug History

Date Modified Username Field Change
2016-10-17 09:54 carl New Bug
2016-10-17 16:13 scorpio81 Note Added: 0001475
2017-02-12 20:21 carl Assigned To => carl
2017-02-12 20:21 carl Status new => resolved
2017-02-12 20:21 carl Resolution open => fixed
2017-02-12 20:21 carl Note Added: 0001610