Where are the system fonts? gone?

Anything and everything to do with DCP-o-matic.
Post Reply
bronze13
Posts: 3
Joined: Fri Feb 05, 2016 10:00 am

Where are the system fonts? gone?

Post by bronze13 » Tue Sep 03, 2019 7:24 pm

To design subs there used to be various sytem fonts (i.e. ARIALN.TTF). Now they have vanished from the checkbox. What shall I do?
Best
Ulrich

Carsten
Posts: 1397
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Where are the system fonts? gone?

Post by Carsten » Tue Sep 03, 2019 7:57 pm

Vanished from where? Can you post a screenshot?

- Carsten

bronze13
Posts: 3
Joined: Fri Feb 05, 2016 10:00 am

Re: Where are the system fonts? gone?

Post by bronze13 » Tue Sep 03, 2019 8:31 pm

see attached
Attachments
system fonts vanished.jpg
system fonts vanished.jpg (95.81 KiB) Viewed 348 times

Carsten
Posts: 1397
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Where are the system fonts? gone?

Post by Carsten » Tue Sep 03, 2019 9:53 pm

Ah, I was suspecting that. Well, as a matter of fact, previous versions offered options to set normal, italics and bold font files - but italics and bold actually made no sense, as there was no way to address these separate fonts in a DCP. Now, there is only a single 'plain' font to be chosen, and both DCP-o-matic and the external projector will 'compute' italics and bold from it. Click on 'theFontId' (it's a placeholder for the default font) and then 'Bearbeiten' - choose your preferred font (e.g. from your system font directory).

https://dcpomatic.com/mantis/view.php?id=1451

Normally, DCP-o-matic uses a standard default font (Liberation-Sans - even if not visible in the font list). The only thing left in the font menu is to change that default font to a different one. Looks like less options than before, but, essentially, it's the same, as some choices were useless. Is there a specific reason why you want to change the default font? Or do you believe you need to make a selection there? You don't have to if you're okay with the default font! Liberation-Sans is quite useful - it is free, small, yet covers many different languages/glyphs.





Gruß nach Konstanz - Carsten

mytbyte
Posts: 20
Joined: Fri Apr 08, 2016 8:03 pm

Re: Where are the system fonts? gone?

Post by mytbyte » Tue Sep 17, 2019 9:46 pm

I can choose the font I want and get it to display as intended while building the package in DCP-o-MATIC, but it simply doesn't get rendered as itself in DCP-o-MATIC player or easyDCP player (instead default font, Arial probably, is used - what's more, it's rendered as black/bold in easyDCP. In short, not only the font renders differently in the two players but it's not the font I chose and built into the package.

Is this normal/expected? I did a subtitle VF once before and I believe the font I then chose rendered as it should in the cinema. Why not in software players? It was in the time when all system fonts would be listed.

Another issue: When I want to choose the font, I must copy it from the Windows\Fonts folder to another folder because the Fonts folder won't show up in the requester. Any ideas/solution about that?

Joao.Gri
Posts: 7
Joined: Tue Mar 06, 2018 7:25 pm

Re: Where are the system fonts? gone?

Post by Joao.Gri » Wed Oct 02, 2019 4:15 pm

I've been using neoDCP for playback check for a while now, it seems feels like a quite competent software and recently I added a font to the Fonts option inside DOM, a Bold font, and when I opened the export DCP on neoDCP I was met with the following error message: "The specified font resource does not contain regular style". This message led me to believe that there is indeed a way to reference different font types, am I wrong? That player identified the font file and managed to understand it was bold, not a regular, and followed on to replace the missing font for the default one.

I am quite interested in the ability to control which font will be used on a screening and being able embed an entire font family with the subtitles is yet another level of security e reassurance (see the Georgian - viewtopic.php?f=2&t=1375&hilit=font - thread).

Was there any new development in this area? Is there a way to embed regular, bold and italic?

Thanks.

Carsten
Posts: 1397
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: Where are the system fonts? gone?

Post by Carsten » Wed Oct 02, 2019 8:24 pm

Cinema projectors do not deal with separate fonts when displaying bold or italic. They synthesize the effect from 'just' the supplied (typically, regular) font (single font file per reel). So, it does not make sense to specifiy different fonts when mastering a DCP. Yes, in theory, different fonts could be used for burn-in applications.

I understand you are seeing some issues when previewing/using software players. But they are not solved for actual DCP playout by being able to specifiy different fonts.

One issue is probably that software players use operating system functions to display chars. This will usually render fonts in a different way than DCI projectors do.

- Carsten

Post Reply