View Bug Details

IDProjectCategoryView StatusLast Update
0001451DCP-o-matic[All Projects] Clean-uppublic2019-01-27 00:53
ReporterCarstenAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS XOS Version10.12
Product Version2.12.x 
Target Version2.14.0Fixed in Version 
Summary0001451: Remove font selection for italics and bold
Description

This is only a cleanup, I guess. We talked about it a while ago when someone on the forum was confused about using italics in subtitles:

As timed text in DCI does not use dedicated fonts for italics and bold, but renders italics and bold projector or server side through display functions, the dialog to select italics and bold fonts is useless (and confusing). I guess we can clean it up for 2.14 without much thinking, right? Or, do we need these options for XML sources including font modifiers that are to be burned in? In that case, we should probably make this clearer? Maybe font selection should only be possible when burn-in is selected?
What happens when e.g. an XML file with italics or bold font modifiers is loaded and burn-in is selected? What takes care for the italics display/rendering - the chosen italics font, or, a system function? Is it important to have distinctive fonts for normal/italics/bold when doing burn-in? I guess those that revealed themselves as being picky would say: YES!

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Activities

carl

2019-01-26 23:29

administrator   ~0002971

As it stands DoM needs to know what TTF files to use to render bold/italic. It starts off with Liberation Sans (i.e. Arial) but if you specify a new TTF for "normal" text you also need to tell DoM the TTFs for italic/bold.

Maybe there's a way to guess these, but it seems unlikely. I don't think we can use the operating system's font store as we must have TTF and no other format.

Alternatively there may be some way to do fake bold/italic so we wouldn't need to ask the user for the TTF files.

Even hiding bold/italic for non-burn-in is tricky, as we still need to know what fonts to use to render the preview.

Maybe trying to do synthesized bold/italic inside DoM is the best idea.

Carsten

2019-01-27 00:23

manager   ~0002972

Last edited: 2019-01-27 00:53

View 2 revisions

I guess I need to create or dig up some XML files with font effects to see what happens.

But in general, I guess it would be best if DCP-o-matic would simulate what the projector/server subtitle rendering is doing.

I'm wondering wether there is a test XML file using all common text modifiers/tags?

I know ISDCF has some older test files, I need to look into them...

  • Carsten

carl

2019-01-27 00:27

administrator   ~0002973

Synthesis turns out to be easier than I expected (although let's see if it works on OSX/Windows). Italic/bold font selection removed and synthesis added in f77ec143719c86ddbf098bff6d19fe2a159b8c3e and 731eb4282fc1dd8e2ac054879db16647757a766a (2.13.110).

Bug History

Date Modified Username Field Change
2019-01-26 15:11 Carsten New Bug
2019-01-26 15:11 Carsten Status new => assigned
2019-01-26 15:11 Carsten Assigned To => carl
2019-01-26 15:12 Carsten Description Updated View Revisions
2019-01-26 15:13 Carsten Description Updated View Revisions
2019-01-26 15:13 Carsten Description Updated View Revisions
2019-01-26 15:46 Carsten Description Updated View Revisions
2019-01-26 15:46 Carsten Description Updated View Revisions
2019-01-26 23:29 carl Note Added: 0002971
2019-01-27 00:23 Carsten Note Added: 0002972
2019-01-27 00:27 carl Status assigned => resolved
2019-01-27 00:27 carl Resolution open => fixed
2019-01-27 00:27 carl Note Added: 0002973
2019-01-27 00:53 Carsten Note Edited: 0002972 View Revisions