3D Broken Again

Anything and everything to do with DCP-o-matic.
Post Reply
scozz76
Posts: 52
Joined: Sun May 15, 2016 10:13 am

3D Broken Again

Post by scozz76 »

If I use separate L/R files the DCP appears to switch in and out of 3D.
The latest test version has a flickering brightness issue and didn't encode 3D at all.

*UPDATE*
SBS files appear to work ok (stable version).

Version 2.14.26

carl
Site Admin
Posts: 1179
Joined: Thu Nov 14, 2013 2:53 pm

Re: 3D Broken Again

Post by carl »

What format of files are you using for L/R when it doesn't work? Can I get the log file from one of those encodes? What was the last working version of DCP-o-matic that you used?

scozz76
Posts: 52
Joined: Sun May 15, 2016 10:13 am

Re: 3D Broken Again

Post by scozz76 »

I was using M2TS files. The SBS was also m2ts and was successful. 23.976fps

The last known working version I used for 3D was 2.13.117

Thanks
Attachments
Source Info.zip
(1.73 KiB) Downloaded 45 times
ffprobe.log
(1.26 KiB) Downloaded 49 times
log.txt
(142.66 KiB) Downloaded 33 times

carl
Site Admin
Posts: 1179
Joined: Thu Nov 14, 2013 2:53 pm

Re: 3D Broken Again

Post by carl »

Hi, OK, thanks for those files. Something is clearly going wrong with DCP-o-matic's attempts to keep L and R in sync with each other. Assuming it's not feasible to send me the original m2ts files we'll need some more detailed debug logs. I've added some bits to version 2.15.46 of DCP-o-matic which will be uploaded within the next few hours. Please could you install that, enable "Debug: 3D" in advanced prefs, re-run your transcode (and let it run for a minute or two) then upload the log file again?

saftsuse
Posts: 13
Joined: Mon Apr 02, 2018 7:38 pm

Re: 3D Broken Again

Post by saftsuse »

I was so happy to see that 3D was working at last, so I updated to the latest Version and made two dcp from SBS material.

But unfortunately same problem I had long time ago. The DCP will not play on my DoReMi player.
Its only a flickering green Picture and it does not play, the time just stays on 0:00:00:00.
(The PJ is in 3d mode, double checked. )

Has anyone ever been succsessful making a 3D DCP from SBS material?
The file was an MKV With SBS material.

Regards,
Erik

Carsten
Posts: 1594
Joined: Tue Apr 15, 2014 9:11 pm
Location: Germany

Re: 3D Broken Again

Post by Carsten »

Does anyone know a source for various 3D formats as test content?

- Carsten

scozz76
Posts: 52
Joined: Sun May 15, 2016 10:13 am

Re: 3D Broken Again

Post by scozz76 »

Try this site. They may have content you're after - probably mostly SBS
https://www.demo-world.eu/3d-demo-trailers-hd/

I believe they're shutting down the site in May so grab whatever you need.

When I get some extra time I'll create separate Left/Right files of something - Probably a distributor tag.

Re the debugging. I haven't had chance to run the tests. Sorry.

scozz76
Posts: 52
Joined: Sun May 15, 2016 10:13 am

Re: 3D Broken Again

Post by scozz76 »

saftsuse wrote:
Sun Mar 08, 2020 8:59 pm
I was so happy to see that 3D was working at last, so I updated to the latest Version and made two dcp from SBS material.

But unfortunately same problem I had long time ago. The DCP will not play on my DoReMi player.
Its only a flickering green Picture and it does not play, the time just stays on 0:00:00:00.
(The PJ is in 3d mode, double checked. )

Has anyone ever been succsessful making a 3D DCP from SBS material?
The file was an MKV With SBS material.

Regards,
Erik
Yes I did have a 3D DCP made from an SBS file on ver. 2.14.36 tested at a local cinema and it was fine.
Only difference was mine was a M2TS file
Here's a link to my test file https://mega.nz/#!fWI11QpT!NZhtS2qzQ2IW ... 3XuEgNd8tg
Last edited by scozz76 on Sun Mar 15, 2020 5:31 am, edited 2 times in total.

scozz76
Posts: 52
Joined: Sun May 15, 2016 10:13 am

Re: 3D Broken Again

Post by scozz76 »

carl wrote:
Sun Mar 01, 2020 10:00 pm
Hi, OK, thanks for those files. Something is clearly going wrong with DCP-o-matic's attempts to keep L and R in sync with each other. Assuming it's not feasible to send me the original m2ts files we'll need some more detailed debug logs. I've added some bits to version 2.15.46 of DCP-o-matic which will be uploaded within the next few hours. Please could you install that, enable "Debug: 3D" in advanced prefs, re-run your transcode (and let it run for a minute or two) then upload the log file again?
I've done the test for you (Version 2.15.47) I used a 5min L/R file and it works.

I've also sent you a PM with links to my source files, let me know if you haven't received it - or - once you've successfully downloaded the files.

Thanks
Scott
Attachments
log2.zip
(191.26 KiB) Downloaded 36 times

Post Reply