View Bug Details

IDProjectCategoryView StatusLast Update
0001111DCP-o-matic[All Projects] Bugspublic2018-01-21 06:43
ReporterrobnAssigned Tocarl 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionreopened 
Platformx86_64OSFedoraOS Version25
Product Version2.11.0 
Target Version2.12.0Fixed in Version 
Summary0001111: Dolby TrueHD sound track in content leads to problems (even when not used!)
Description

I created this bug to have a more relevant title/summary.
The description is in bug 1109 :

        http://dcpomatic.com/mantis/view.php?id=1109
TagsNo tags attached.
Estimated work requiredUnknown

Relationships

related to 0001109 resolvedcarl Percentage counter not updated in DOM Batch Converter 
related to 0001041 resolvedcarl Audio analysis very slow with True HD track 

Activities

carl

2017-09-03 00:36

administrator   ~0001806

First problem is that TrueHD frames arrive in the decoder with only a few timestamped and most having AV_NOPTS_VALUE. ffplay.c solves this by calculating the correct pts for those unmarked frames.

carl

2017-09-03 00:37

administrator   ~0001807

Last edited: 2017-09-03 00:39

View 2 revisions

After that it may be the small frame size (40 samples) exposing inefficiencies; playback of Wayne's World sort of works but it's slow.

carl

2017-09-03 19:26

administrator   ~0001809

Nothing obvious in callgrind; coalescing 40 sample blocks into bigger blocks before resampling doesn't help.

carl

2018-01-18 01:30

administrator   ~0002024

I think things are usable now, at least, with TrueHD. Leave a comment if you don't agree!

robn

2018-01-18 17:41

reporter   ~0002029

I re-tested with the same TrueHD source (movie Blu-ray)
and now with DOM 2.11.43 the problem is indeed gone!

carl

2018-01-18 20:17

administrator   ~0002030

Great!

Bug History

Date Modified Username Field Change
2017-08-11 02:47 robn New Bug
2017-08-12 12:27 carl Relationship added related to 0001109
2017-08-12 12:28 carl Target Version => 2.12.0
2017-08-21 00:01 carl Relationship added related to 0001041
2017-09-03 00:36 carl Note Added: 0001806
2017-09-03 00:37 carl Note Added: 0001807
2017-09-03 00:39 carl Note Edited: 0001807 View Revisions
2017-09-03 19:26 carl Note Added: 0001809
2017-12-29 23:40 carl Assigned To => carl
2017-12-29 23:40 carl Status new => confirmed
2018-01-18 01:30 carl Status confirmed => resolved
2018-01-18 01:30 carl Resolution open => fixed
2018-01-18 01:30 carl Note Added: 0002024
2018-01-18 17:41 robn Status resolved => feedback
2018-01-18 17:41 robn Resolution fixed => reopened
2018-01-18 17:41 robn Note Added: 0002029
2018-01-18 20:17 carl Status feedback => resolved
2018-01-18 20:17 carl Note Added: 0002030