View Bug Details

IDProjectCategoryView StatusLast Update
0001188DCP-o-matic[All Projects] Bugspublic2018-02-05 19:47
ReporterCarstenAssigned Tocarl 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS X OS Version10.11
Product Version2.11.0 
Target Version2.12.0Fixed in Version 
Summary0001188: Trying to create a KDM or DKDM for unencrypted content results in program crash
Description

Tried it with both Windows and Mac version 2.11.47. Mac version simply vanishes, windows version gives a Visual C++ runtime Library error '...terminate in an unusual way'. Happens both in the DKDM and KDM dialog. One should probably catch this issue, either by giving a hint like 'The active content is not encrypted', or by disallowing the creation of (D)KDM.

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Activities

carl

2018-02-03 01:10

administrator   ~0002062

Can't reproduce on Linux; will try OSX/Windows.

Carsten

2018-02-03 01:32

manager   ~0002063

Hehe... let's try the Quicktime screen capture feature I just discovered... ready for some screencasts/tutorials...
For some reason, I thought I was only a screenshot function and never dared to try...

Carsten

2018-02-03 02:19

manager  

crashtest_s.mp4 (472,397 bytes)

carl

2018-02-05 00:30

administrator   ~0002069

Confirmed on OS X.

carl

2018-02-05 00:41

administrator   ~0002070

d9b4e65b92e28f9126fac7660d7aba97fc1ca4ad should fix this.

Carsten

2018-02-05 02:43

manager   ~0002071

Disabling DKDM is probably useful, however, when Make KDM is disabled as well, it is not possible to make changes to the cinema database (except when resorting to KDM Creator), or to simply explore the complex KDM creation dialog.
Maybe it's sufficient to disable the generation of KDMs, but still allow to open the Make KDM dialog?
That said, it is sufficient to check the 'Encryped' checkbox without creating an actual DCP in order to access these menu entries.

  • Carsten

carl

2018-02-05 19:47

administrator   ~0002072

Ah yes, good point...

Bug History

Date Modified Username Field Change
2018-02-03 00:39 Carsten New Bug
2018-02-03 00:39 Carsten Status new => assigned
2018-02-03 00:39 Carsten Assigned To => carl
2018-02-03 01:10 carl Note Added: 0002062
2018-02-03 01:32 Carsten Note Added: 0002063
2018-02-03 02:19 Carsten File Added: crashtest_s.mp4
2018-02-05 00:30 carl Status assigned => confirmed
2018-02-05 00:30 carl Note Added: 0002069
2018-02-05 00:41 carl Status confirmed => resolved
2018-02-05 00:41 carl Resolution open => fixed
2018-02-05 00:41 carl Note Added: 0002070
2018-02-05 02:43 Carsten Note Added: 0002071
2018-02-05 19:47 carl Note Added: 0002072