View Bug Details

IDProjectCategoryView StatusLast Update
0001261DCP-o-matic[All Projects] Clean-uppublic2019-02-02 16:41
ReporterCarstenAssigned Tocarl 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS X OS Version10.11
Product Version2.12.x 
Target Version2.14.0Fixed in Version 
Summary0001261: file selector dialogs in localized OS X are english, even when system language is set different
Description

My OS X system is set to german GUI. When using DCP-o-matic with the german localization, file selector boxes following 'open film', 'export destination file', 'Export Certificate', etc. are displayed in english, not in german as it is the case for other apps or finder - however, their window title is localized from the DCP-o-matic translation files. Just buttons like 'Open', 'Cancel', as well as the finder sidebar folder names, etc. are english as if the OS X was set to english. See screenshot. It's the same behavior for other localized languages.

Maybe this can be fixed through the OS X GUI library.

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Activities

Carsten

2018-03-29 22:08

manager  

Carsten

2019-01-26 16:14

manager   ~0002955

I guess this is easy and safe to fix through the OS X GUI library?

carl

2019-01-26 20:48

administrator   ~0002964

Do you have de_DE set in DCP-o-matic's config or does it pick that up automatically?

Carsten

2019-01-26 21:20

manager   ~0002968

Last edited: 2019-01-26 21:23

View 4 revisions

I always have it set fixed to german. I know that automatic language selection used/uses to cause mixed language GUI elements in DCP-o-matic in OS X, but, as I work on the german translation, I actively switch between english and german in prefs.

This issue is not severe, but it exists for a long time. I just checked on my old plastic mac book, and it already happens in 1.83/10.6.8. Obviously, it doesn't bother many people.

  • Carsten

carl

2019-01-26 21:40

administrator   ~0002969

May be fixed by b2b0b98acc55f556ab995b27289028519b8f4a30 (2.13.110)

carl

2019-01-31 14:41

administrator   ~0003001

@Carsten if you could test 2.13.110 or later that would be cool; seems to work for me.

Carsten

2019-02-02 16:40

manager   ~0003042

Last edited: 2019-02-02 16:41

View 2 revisions

Yup - the issue is there in 2.13.109, but solved in 2.13.111.

The few translated sidebar system folder names are still displayed in english (e.g. 'movies'), while the finder shows their german translations ('Filme'). But, really...

Solved.

  • Carsten

Bug History

Date Modified Username Field Change
2018-03-29 22:08 Carsten New Bug
2018-03-29 22:08 Carsten Status new => assigned
2018-03-29 22:08 Carsten Assigned To => carl
2018-03-29 22:08 Carsten File Added: Bildschirmfoto 2018-03-30 um 00.02.42.png
2018-03-29 22:10 Carsten Description Updated View Revisions
2019-01-26 16:14 Carsten Product Version 2.14.0 => 2.12.x
2019-01-26 16:14 Carsten Target Version 2.12.x => 2.14.0
2019-01-26 16:14 Carsten Note Added: 0002955
2019-01-26 20:48 carl Note Added: 0002964
2019-01-26 21:20 Carsten Note Added: 0002968
2019-01-26 21:20 Carsten Note Edited: 0002968 View Revisions
2019-01-26 21:22 Carsten Note Edited: 0002968 View Revisions
2019-01-26 21:23 Carsten Note Edited: 0002968 View Revisions
2019-01-26 21:40 carl Status assigned => feedback
2019-01-26 21:40 carl Note Added: 0002969
2019-01-31 14:41 carl Note Added: 0003001
2019-02-02 00:24 carl Status feedback => resolved
2019-02-02 00:24 carl Resolution open => fixed
2019-02-02 16:40 Carsten Note Added: 0003042
2019-02-02 16:41 Carsten Note Edited: 0003042 View Revisions