View Bug Details

IDProjectCategoryView StatusLast Update
0001274DCP-o-matic[All Projects] Bugspublic2018-04-15 23:04
ReporterCarstenAssigned Tocarl 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS X OS Version10.11
Product Version2.12.x 
Target Version2.13.xFixed in Version 
Summary0001274: Preview in dcp-o-matic is wrong with cropping applied, makes visual cropping impossible
Description

https://dcpomatic.com/forum/viewtopic.php?f=2&p=4028&sid=32ff4bf7b9bddf639f2b78ea3a2a8a7f#p4028

I'll check some 2.11.x versions for when that may have been introduced...

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Activities

Carsten

2018-04-13 17:47

manager   ~0002368

Last edited: 2018-04-13 19:03

View 3 revisions

Appears to happen between 2.10.5 and 2.11.17, so, the latter already has it. When I load the same project back in 2.10.5, everything looks okay.

Carl, here is a test image to reproduce this - oops, it doesn't happen with a still, only with an actual DCP... Carl, could this be a 2k/4k interpretation thing?

More testing - it happens for DCPs and MXF files. When I create a DCP from DCP or MXF with crop values that appear to be okay visually in preview window, the resulting DCP has black bars top and bottom.

  • Carsten


scope_flat.jpg (469,879 bytes)

carl

2018-04-13 21:57

administrator   ~0002369

Seemingly it happens only if the preview size is smaller than half the full DCP image size; probably due to the low-resolution DCP decoding that happens if the preview is small.

carl

2018-04-13 22:25

administrator   ~0002370

Believed fixed by 0ff4fa6058b305476e7bc60c590acb6135c49b1c in master, d119e52831556a0b11f4ac4bd20c31151faac171 in v2.12.x.

Carsten

2018-04-13 23:45

manager   ~0002371

Oh, lucky us working on tiny notebook displays...

  • Carsten

Carsten

2018-04-15 23:03

manager   ~0002372

confirm solved in 2.12.4

carl

2018-04-15 23:04

administrator   ~0002373

Thanks Carsten.

Bug History

Date Modified Username Field Change
2018-04-13 17:23 Carsten New Bug
2018-04-13 17:23 Carsten Status new => assigned
2018-04-13 17:23 Carsten Assigned To => carl
2018-04-13 17:47 Carsten File Added: scope_flat.jpg
2018-04-13 17:47 Carsten Note Added: 0002368
2018-04-13 17:52 Carsten Note Edited: 0002368 View Revisions
2018-04-13 19:03 Carsten Note Edited: 0002368 View Revisions
2018-04-13 21:57 carl Note Added: 0002369
2018-04-13 22:25 carl Status assigned => resolved
2018-04-13 22:25 carl Resolution open => fixed
2018-04-13 22:25 carl Note Added: 0002370
2018-04-13 23:45 Carsten Note Added: 0002371
2018-04-15 23:03 Carsten Note Added: 0002372
2018-04-15 23:04 carl Note Added: 0002373