View Bug Details

IDProjectCategoryView StatusLast Update
0001281DCP-o-matic[All Projects] Bugspublic2018-06-11 14:00
ReporterCarstenAssigned Tocarl 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS X OS Version10.11
Product Version2.12.x 
Target Version2.12.xFixed in Version 
Summary0001281: No full audio downmix for multichannel audio
Description

Ooops - I was just checking multichannel DCP and audio file playback in DCP-o-matic 2.12.x and 2.13.x - the default playback device on my Mac is stereo.

Only input tracks assigned to DCP channels 1-3 (L/R/C) are audible during playback. When I assign input 4,5,6 (LFE, Ls, Rs) to either channel 1,2 or 3, they become audible. They are silent when assigned to DCP channels 4,5,6 (LFE, Ls, Rs).

Same happens for both DCPs, audio MXFs, and e.g. quicktime files.

Strange thing - when I try 2.11.17, only channels mapped to 1/2(L/R) become audible. In 2.12.x/2.13.x, channels become audible when mapped to either 1,2 or 3... Looks as if the downmix function is 'truncated' after channel 3/center.

I guess that is not intentional? ;-)

I may have been so fascinated about the option to play back to actual multichannel interfaces, that I didn't bother testing the downmix option - at least as long as the important center/dialog channel was always there... Probably the reason no one else complained so far. Have to test in windows.

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Activities

carl

2018-06-09 23:35

administrator   ~0002473

It was intentional, but probably wrong. Ls/Rs and Lfe are included in 79a9da3ed267f2fa95aa9615dd662a1cea2e9d81 (2.13.29)

Carsten

2018-06-10 10:49

manager   ~0002474

How do you sum/normalize with multiple channels? Based on active matrix assignments? Because I guess we often have the scenario with 5.1 target channels, but only L/R and Center being populated. Downmix-Attentuating based on target channel numbers then would result in a very low level. But I guess we do not always have a dependable sample peak per channel to base downmix-attentuation on?

  • Carsten

carl

2018-06-11 09:49

administrator   ~0002477

No I'm just doing

Lt = L (down 3dB) + Ls (down 3dB) + C (down 6dB) + Lfe (down 10dB)
Rt = R (down 3dB) + Rs (down 3dB) + C (down 6dB) + Lfe (down 10dB)

It's not very sophisticated... and I'm not sure how much it matters. We certainly don't have enough sample peak information to do it exactly.

Carsten

2018-06-11 14:00

manager   ~0002478

The nerd in me wants a separate audio matrix for playback only, separate from the DCP-oriented matrix. But I understand how much that will confuse users. It could matter at some point when people want to monitor playback from the player or DCP-o-matic main, because mixdown will alter FS reference. No big issue for now, but I had a discussion about this with a film maker on a german forum who wanted to setup his own monitoring/review room and have proper reference levels. I guess the only important thing for now in that respect is that, when playing out to multichannel capable audio devices, that DCP FS=channel FS. Most people operating on that skill level will understand that reference levels and downmix don't go together well.

  • Carsten

Bug History

Date Modified Username Field Change
2018-04-22 01:02 Carsten New Bug
2018-04-22 01:02 Carsten Status new => assigned
2018-04-22 01:02 Carsten Assigned To => carl
2018-04-22 01:04 Carsten Description Updated View Revisions
2018-06-09 23:35 carl Status assigned => resolved
2018-06-09 23:35 carl Resolution open => fixed
2018-06-09 23:35 carl Note Added: 0002473
2018-06-10 10:49 Carsten Note Added: 0002474
2018-06-11 09:49 carl Note Added: 0002477
2018-06-11 14:00 Carsten Note Added: 0002478