View Bug Details

IDProjectCategoryView StatusLast Update
0001391DCP-o-matic[All Projects] Bugspublic2019-01-07 22:41
Reportertomashnyk@gmail.comAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platform64 bitOSLinuxOS VersionUbuntu
Product Version2.12.0 
Target Version2.14.0Fixed in Version 
Summary0001391: When "make VF" is selected, export results in black file with subtitles only
Description

Not sure if this is a feature or a bug, but after making a VF, I wanted to also export my DCP. I left the checkbox to "use this as OV and make a VF" ticked (for both video and audio) and the export resulted in a black image with subtitles only. The export only took about an hour and the filesize was about 40 MB and I can imagine this actually being useful (I once made a file precisely like that) but I don't think it is what one expects when exporting.

Maybe a promt such as "The resulting file will not contain video and audio data. You left the options to make a VF checked. Do you wnat ot proceed?"(variable, depending what is checked) would help.

TagsNo tags attached.
Estimated work requiredUnknown

Activities

carl

2019-01-07 15:21

administrator   ~0002868

Hi, I'm struggling to reproduce this: when I try exporting a project containing a referenced OV I get the OV's image in the output (with 2.12.12). Can you still reproduce it yourself?
Thanks!

tomashnyk@gmail.com

2019-01-07 16:37

reporter   ~0002869

Hm, it seems to be DCP-specific. I think I am reproducing it now, but I am not sure - it will takes two hours before the export finishes. Though it runs at 15,5 FPS and this computer only manages like 3.5 FPS when the export is with image. But I also found out with this DCP that if I use trim function (I originally wanted to export just a few seconds) the export always hangs a few frames before it finishes (on the command line, it said "Encoder did not produce proper pts, making some up." - but that should not be a problem, I guess).

So I guess this is DCP-specific and the DCP has 101 GB, so I am not sure if it would be feasible to send it to you at all? I have no problem uploading it somewhere (it shoudl take about 30 hours with my 10 mbit upload link), but I do not have access to a server that would store such a large file. This DCP was normally shown in cinemas, it was not produced with DCPomatic but with "<!-- Generated by orca_wrapping version 3.4.1-2 -->" according to its PKL.xml. It is not encrypted. Of course, I would expect you not to share it anywhere but I think I can trust you with that:-).

tomashnyk@gmail.com

2019-01-07 20:38

reporter   ~0002870

Hm, I did not manage to reproduce this after trying for an hour or so. Either it was something that got fixed along the way or it was some weird glitch. But I definitely managed to create a video just with subtitles, I am not making it up.

carl

2019-01-07 22:41

administrator   ~0002871

Thanks for looking into it. I believe you that you're not making it up :) It's just a shame we can't reproduce it. I'll close it for now: do feel free to leave a note if you see a similar problem again!

Bug History

Date Modified Username Field Change
2018-10-23 11:35 tomashnyk@gmail.com New Bug
2018-11-09 12:31 carl Status new => acknowledged
2018-11-09 12:31 carl Target Version => 2.14.0
2019-01-07 15:21 carl Assigned To => carl
2019-01-07 15:21 carl Status acknowledged => feedback
2019-01-07 15:21 carl Note Added: 0002868
2019-01-07 16:37 tomashnyk@gmail.com Note Added: 0002869
2019-01-07 16:37 tomashnyk@gmail.com Status feedback => assigned
2019-01-07 20:38 tomashnyk@gmail.com Note Added: 0002870
2019-01-07 22:41 carl Note Added: 0002871
2019-01-07 22:41 carl Status assigned => resolved
2019-01-07 22:41 carl Resolution open => unable to reproduce