View Issue Details

IDProjectCategoryView StatusLast Update
0001436DCP-o-matic[All Projects] Bugspublic2019-01-02 19:46
Reporterrobn Assigned Tocarl  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSFedoraOS Version27
Product Version 
Target Version2.14.0Fixed in Version 
Summary0001436: OK content makes DOM crash (probably audio related)
Description

DOM 2.13.89 crashes on some blu-ray ripped content (which appears to be fine when played with a media player).
It crashes with an error pop-up window (see attached screenshot).

Trying older versions I found out that this problem is not new: it starts to appear between 2.13.40 and 2.13.42:

2.13.20 ok
2.13.31 ok
2.13.36 ok
2.13.40 ok
2.13.42 crash
2.13.47 crash
2.13.83 crash
2.13.89 crash

Steps To Reproduce

Fortunately I was able to create a small sample of the complete .mkv blu-ray rip that makes DOM crash too.
It can be found here (21 MB, first 10 seconds):

 http://berrymount.nl/dom_crash.mkv

Just try to add this content to a DOM-project and watch it crash!
(with the error in the attached screenshot)

TagsNo tags attached.
Estimated weeks required
Estimated work requiredUnknown

Relationships

related to 0001437 resolvedcarl Option to force 48kHz DCP audio 

Activities

robn

2018-12-22 22:38

reporter  

crash_error.png (13,187 bytes)
crash_error.png (13,187 bytes)

carl

2018-12-22 23:34

administrator   ~0002817

Thanks; should be fixed by b73576594b252e033539bec964d72403d3775585 in 2.13.91.

carl

2018-12-22 23:41

administrator   ~0002818

The file has a TrueHD audio stream at a sampling rate of 192kHz; this makes DCP-o-matic decide to make a 96kHz-audio DCP. You may be in uncharted territory here: I'm not sure if anybody distributes 96kHz DCPs and whether or not DCP-o-matic should even create them...

robn

2018-12-22 23:48

reporter   ~0002819

Ah OK, I see.

Would there be any way to force DCP-o-matic into resampling to 48kHz-audio?
(of course I can do this outside DCP-o-matic, so my short term problem seems to be solved, thanks!)

carl

2018-12-22 23:49

administrator   ~0002820

There isn't at the moment, but I think there should be...

robn

2018-12-23 00:09

reporter   ~0002821

Looking in the manual of the widely used Dolby CP650 I think that it can't work with anything above 48 kHz.
(when fed with digital PCM-channels from the DCI server like I have in my cinema).
So something to prevent that 96 kHz DCPs will be created by DCP-o-matic seems important!

carl

2018-12-23 00:12

administrator   ~0002822

OK, I've added 0001437.

Carsten

2018-12-23 15:05

manager   ~0002823

Most servers will downsample to 48kHz, but that is an installer option. The general consensus currently is to not create 96 kHz DCPs. Some cinema processors can handle 96kHz, some do downsampling to 48kHz, some fail. I guess a useful option would be to allow 96kHz only in advanced prefs, and add a hint/warning if 96kHz is created.

  • Carsten

carl

2018-12-23 21:21

administrator   ~0002825

Thanks Carsten. I've made it always 48kHz now. If 96kHz DCPs start happening (for some bizarre reason!) we can put in an option.

robn

2019-01-02 19:46

reporter   ~0002834

I re-tested with DOM 2.13.94 and everything works perfect now.
Good to be able to process these high sampling rate audio-tracks from within DCP-o-matic!

Issue History

Date Modified Username Field Change
2018-12-22 22:38 robn New Issue
2018-12-22 22:38 robn File Added: crash_error.png
2018-12-22 22:56 carl Status new => confirmed
2018-12-22 22:56 carl Target Version => 2.14.0
2018-12-22 23:34 carl Assigned To => carl
2018-12-22 23:34 carl Status confirmed => resolved
2018-12-22 23:34 carl Resolution open => fixed
2018-12-22 23:34 carl Note Added: 0002817
2018-12-22 23:41 carl Note Added: 0002818
2018-12-22 23:48 robn Note Added: 0002819
2018-12-22 23:49 carl Note Added: 0002820
2018-12-23 00:09 robn Note Added: 0002821
2018-12-23 00:12 carl Relationship added related to 0001437
2018-12-23 00:12 carl Note Added: 0002822
2018-12-23 15:05 Carsten Note Added: 0002823
2018-12-23 21:21 carl Note Added: 0002825
2019-01-02 19:46 robn Note Added: 0002834