View Bug Details

IDProjectCategoryView StatusLast Update
0000015DVD-o-matic[All Projects] Generalpublic2013-01-21 09:51
ReporterslycordinatorAssigned Tocarl 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platform64-bitOSGentoo LinuxOS Version
Product Version0.67 
Target VersionFixed in Version 
Summary0000015: Cannot configure libdcp-0.34 or dvd-o-matic-0.67 from sources
Description

After unpacking the source for libdcp-0.34 and changing to the unpacked directory, when I run "./waf configure" I receive the following message:

Waf: The wscript in '/home/chris/dvd-o-matic/libdcp-0.34' is unreadable
Traceback (most recent call last):
File "/home/chris/dvd-o-matic/libdcp-0.34/.waf3-1.6.11-7c79ffd760eee0252d71f25c9bcc0977/waflib/Scripting.py", line 87, in waf_entry_point
set_main_module(Context.run_dir+os.sep+Context.WSCRIPT_FILE)
File "/home/chris/dvd-o-matic/libdcp-0.34/.waf3-1.6.11-7c79ffd760eee0252d71f25c9bcc0977/waflib/Scripting.py", line 110, in set_main_module
Context.g_module=Context.load_module(file_path)
File "/home/chris/dvd-o-matic/libdcp-0.34/.waf3-1.6.11-7c79ffd760eee0252d71f25c9bcc0977/waflib/extras/compat15.py", line 88, in load_module
ret=rev(path)
File "/home/chris/dvd-o-matic/libdcp-0.34/.waf3-1.6.11-7c79ffd760eee0252d71f25c9bcc0977/waflib/Context.py", line 266, in load_module
exec(compile(code,path,'exec'),module.dict)
File "/home/chris/dvd-o-matic/libdcp-0.34/wscript", line 3, in <module>
import lut
File "/home/chris/dvd-o-matic/libdcp-0.34/lut.py", line 61
v = math.pow (i / (BIT_LENGTH - 1.0), DCI_GAMMA);
^
TabError: inconsistent use of tabs and spaces in indentation

And when I download the dvd-o-matic 0.67 sources and do the same I receive the following:
Waf: The wscript in '/home/chris/dvd-o-matic/dvdomatic-0.67' is unreadable
Traceback (most recent call last):
File "/home/chris/dvd-o-matic/dvdomatic-0.67/.waf3-1.6.11-7c79ffd760eee0252d71f25c9bcc0977/waflib/Scripting.py", line 87, in waf_entry_point
set_main_module(Context.run_dir+os.sep+Context.WSCRIPT_FILE)
File "/home/chris/dvd-o-matic/dvdomatic-0.67/.waf3-1.6.11-7c79ffd760eee0252d71f25c9bcc0977/waflib/Scripting.py", line 110, in set_main_module
Context.g_module=Context.load_module(file_path)
File "/home/chris/dvd-o-matic/dvdomatic-0.67/.waf3-1.6.11-7c79ffd760eee0252d71f25c9bcc0977/waflib/extras/compat15.py", line 88, in load_module
ret=rev(path)
File "/home/chris/dvd-o-matic/dvdomatic-0.67/.waf3-1.6.11-7c79ffd760eee0252d71f25c9bcc0977/waflib/Context.py", line 266, in load_module
exec(compile(code,path,'exec'),module.dict)
File "/home/chris/dvd-o-matic/dvdomatic-0.67/wscript", line 27
print wxrc
^
SyntaxError: invalid syntax

Steps To Reproduce

1) wget http://carlh.net/software/libdcp/libdcp-0.34.tar.bz2
2) tar xjf libdcp-0.34.tar.bz2
3) cd libdcp-0.34
4) ./waf configure

1) wget http://carlh.net/software/dvdomatic/dvdomatic-0.67.tar.bz2
2) tar xjf dvdomatic-0.67.tar.bz2
3) cd dvdomatic-0.67
4) ./waf configure

TagsNo tags attached.
cc

Activities

carl

2012-12-22 12:38

administrator   ~0000006

This is because those wscripts aren't happy being run by python 3 (yet). A workaround would be to run waf with a copy of python 2 (if you have one around); with something like

python2 ./waf configure

or whatever.

carl

2012-12-22 13:21

administrator   ~0000007

Fixed in libdcp-0.35; updated dvdomatic to follow.

carl

2012-12-22 13:31

administrator   ~0000008

Should be fixed in libdcp-0.35 and dvdomatic-0.68beta10. Do let me know if you are still having problems. Thanks!

Bug History

Date Modified Username Field Change
2012-12-22 01:04 slycordinator New Bug
2012-12-22 12:38 carl Note Added: 0000006
2012-12-22 12:38 carl Status new => acknowledged
2012-12-22 13:21 carl Note Added: 0000007
2012-12-22 13:31 carl Note Added: 0000008
2012-12-22 13:31 carl Status acknowledged => resolved
2012-12-22 13:31 carl Resolution open => fixed
2012-12-22 13:31 carl Assigned To => carl
2013-01-21 09:51 carl Status resolved => closed