View Issue Details

IDProjectCategoryView StatusLast Update
0001593DCP-o-matic[All Projects] Featurespublic2020-04-14 20:17
Reporteralexthebassist Assigned Tocarl  
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version2.16.0Fixed in Version 
Summary0001593: Skip corrupted (undecodable) frames instead of crashing the player
Description

When there's a corrupted frame in a DCP, DCP-o-matic Player does hang with a warning window and then crashes the moment you press “OK” button. Instead, it would be better to skip the bad frame, leaving a warning in logs and/or in a special string in info section, like that one for frames skipped due to insufficient performance. This will be enough to indicate such problems, but in a somewhat fair way to theatrical playback situations.

Tagsplayer
Branch
Estimated weeks required
Estimated work requiredUndecided

Activities

carl

2020-04-14 20:17

administrator   ~0003755

Done in 4ab86ef0295bcd6bb9297996a06006f371d22bae (v2.15.52)

Issue History

Date Modified Username Field Change
2019-08-22 17:57 alexthebassist New Issue
2019-08-22 17:57 alexthebassist Tag Attached: dcp
2019-08-22 17:57 alexthebassist Tag Attached: player
2019-08-23 23:17 carl Target Version => 2.16.0
2019-11-27 16:23 carl Tag Detached: dcp
2020-04-14 20:17 carl Assigned To => carl
2020-04-14 20:17 carl Status new => resolved
2020-04-14 20:17 carl Resolution open => fixed
2020-04-14 20:17 carl Note Added: 0003755