View Bug Details

IDProjectCategoryView StatusLast Update
0001623DCP-o-maticBugspublic2019-12-19 00:35
Reporteroverlookmotel Assigned Tocarl  
PrioritynormalSeverityminorReproducibilityalways
Status acknowledgedResolutionfixed 
PlatformMacOSOS XOS Version10.14
Product Version2.14.8 
Summary0001623: Crash at end of encoding
Description

I am making a DCP from:

  • ProRes HQ 1920x1080, 23.98fps, 8 audio channels
  • Audio WAV file 48k pcm_s24le, 6 audio channels

All the audio channels on the ProRes are disabled, and I'm using the audio from the WAV file instead.

At the very end of encode, DCP-o-matic crashes. This is using the command line dcpomatic2_cli.

Last lines written to stdout are:

Checking content for changes: OK (ran for 0:00:00)           
Transcoding MyFilm_SHR_F-133_EN-XX_51_2K_20191007_IOP_OV; Computing digests: 84%; 1m 25s remaining; finishing at 13:52       
Checking content for changes: OK (ran for 0:00:00)           
Transcoding MyFilm_SHR_F-133_EN-XX_51_2K_20191007_IOP_OV; Computing digests: 96%; 21s remaining; finishing at 13:51          
Checking content for changes: OK (ran for 0:00:00)           
Transcoding MyFilm_SHR_F-133_EN-XX_51_2K_20191007_IOP_OV: Error: Programming error at ../src/lib/reel_writer.cc:461 20816 vs 20963

Any idea what this error is caused by?

I've tried it twice and got the same error both times at the same point.

Tagsnext
Branch
Estimated weeks required
Estimated work requiredUndecided

Relationships

related to 0001691 resolvedcarl Crash at end of encode when DCP frame rate different from content frame rate and some content has no audio 

Activities

overlookmotel

2019-10-10 20:45

reporter   ~0003467

Oh I forgot to say, I also added a 1-frame long DCI MXF file containing a black frame to the very end.

carl

2019-10-10 21:47

administrator   ~0003468

Can I have metadata.xml and log files, please?

carl

2019-11-20 11:30

administrator   ~0003596

ping @overlookmotel

carl

2019-12-01 23:28

administrator   ~0003621

@carl emailed on 30/11

overlookmotel

2019-12-10 12:50

reporter   ~0003637

I think I have better reproduction of this. I'll post details in next few days.

carl

2019-12-16 23:04

administrator   ~0003653

Believed to be a dupe of 0001691.

overlookmotel

2019-12-17 01:20

reporter   ~0003655

Actually I'm not sure this is a dupe of 1691 after all.

You said by email that 1691 was caused by "a bug with resampled audio on DCP sources". But this case didn't involve a DCP source.

carl

2019-12-17 20:40

administrator   ~0003657

A good point and well made; it's not even the same error... I'll re-open.

overlookmotel

2019-12-19 00:35

reporter   ~0003664

But I do think this is a dupe of 0001694. So I think can be safely closed now. I'll post a comment if it rears its head again.

Bug History

Date Modified Username Field Change
2019-10-10 20:40 overlookmotel New Bug
2019-10-10 20:45 overlookmotel Note Added: 0003467
2019-10-10 21:47 carl Tag Attached: next
2019-10-10 21:47 carl Assigned To => carl
2019-10-10 21:47 carl Status new => feedback
2019-10-10 21:47 carl Note Added: 0003468
2019-11-20 11:30 carl Note Added: 0003596
2019-12-01 23:28 carl Note Added: 0003621
2019-12-10 12:50 overlookmotel Note Added: 0003637
2019-12-10 12:50 overlookmotel Status feedback => assigned
2019-12-16 22:14 carl Relationship added related to 0001691
2019-12-16 23:04 carl Status assigned => resolved
2019-12-16 23:04 carl Resolution open => fixed
2019-12-16 23:04 carl Note Added: 0003653
2019-12-17 01:20 overlookmotel Note Added: 0003655
2019-12-17 20:40 carl Status resolved => acknowledged
2019-12-17 20:40 carl Estimated work required => Undecided
2019-12-17 20:40 carl Note Added: 0003657
2019-12-19 00:35 overlookmotel Note Added: 0003664