View Issue Details

IDProjectCategoryView StatusLast Update
0001641DCP-o-matic[All Projects] Bugspublic2019-10-30 21:44
Reporteroverlookmotel Assigned Tocarl  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS XOS Version10.14
Product Version2.14.8 
Target VersionFixed in Version 
Summary0001641: Cannot open DCP with soft subtitles
Description

I tried to re-wrap a DCP with DCP-o-matic in order to burn in the subtitles.

The DCP:

  • is Interop
  • has 2 CPLs
  • 2nd CPL contains soft subtitles

When switching to the 2nd CPL, the preview goes black and no subtitles options appear.

If you save the project, close DCP-o-matic and try to reopen the project, it gives an error:

Could not open film at /path/to/DOM/project/file
Programming error at ...src/lib/dcp_decoder.cc:208

I think actually the DCP is faulty. The CPL XML lists Duration and Intrinsic Duration of the subtitles as longer than they actually are.

So it's not really DCP-o-matic fault it won't open it. However, it could be nice if DCP-o-matic handled this more gracefully - it'd be great to be able to use DOM to rewrap and fix problems with DCPs like this.

Carl, I'll email you a link to the original DCP and DOM project shortly.

TagsNo tags attached.
Estimated work required

Activities

carl

2019-10-30 20:56

administrator   ~0003509

I see the blank video thing. Can't reproduce the crash yet.

carl

2019-10-30 21:19

administrator   ~0003510

Ah, I see the crash too. It's not reliably reported (butler dies with an exception that nobody reports).

carl

2019-10-30 21:32

administrator   ~0003511

@carl a DCPContentProperty::CPL change is emitted, causing pieces to be rebuilt. At that point a DCPDecoder is made which still sees the old TextContent; it has no texts so the DCPDecoder constructor makes no TextDecoders. However, the DCPContent cpl() has changed, so if pass() is called we come to pass_texts() which thinks that because there's a main_subtitle there must be a TextDecoder

carl

2019-10-30 21:33

administrator   ~0003512

An OK fix for 2.14.x would probably be to just do nothing in pass_texts if there is no decoder. It all gets sorted out by (multiple) later signal emissions which cause piece rebuild, eventually with everything in order.

carl

2019-10-30 21:41

administrator   ~0003513

Should be fixed in master by da39ed1516f2463f8a9bf4795a94f23d420c9ca3 which will be in 2.14.13.

carl

2019-10-30 21:44

administrator   ~0003514

0486d4d94900c7f2a2cab7885b3f162d1ad8290c in v.2.15.x

Thanks for the report!

Issue History

Date Modified Username Field Change
2019-10-29 20:00 overlookmotel New Issue
2019-10-30 20:56 carl Assigned To => carl
2019-10-30 20:56 carl Status new => confirmed
2019-10-30 20:56 carl Note Added: 0003509
2019-10-30 21:19 carl Note Added: 0003510
2019-10-30 21:32 carl Note Added: 0003511
2019-10-30 21:33 carl Note Added: 0003512
2019-10-30 21:41 carl Note Added: 0003513
2019-10-30 21:44 carl Status confirmed => resolved
2019-10-30 21:44 carl Resolution open => fixed
2019-10-30 21:44 carl Note Added: 0003514