View Issue Details

IDProjectCategoryView StatusLast Update
0001654DCP-o-matic[All Projects] Bugspublic2019-11-16 21:42
Reportercarl Assigned Tocarl  
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version2.14.14Fixed in Version 
Summary0001654: Crash on cropping DCP content
Description

New project, add a Scope DCP, crop by 279, boom... crash in sws_scale; seems to happen in master and v2.15.x. May need a test!

TagsNo tags attached.
Estimated work requiredUndecided

Activities

Carsten

2019-11-04 00:42

manager   ~0003535

Can you be more specific about circumstances? I just loaded a scope trailer, cropped all sides arbitrarily, created DCP - no problem (2.14.11). I discovered though, that you can play the preview with the space bar while the encode is running ;-)

I also noticed that cropping the scope trailer DOES trigger a recompression in this version.

  • Carsten

robn

2019-11-04 01:29

reporter   ~0003538

Maybe related: there is also always a crash after some time when you export an .mp4 file from a cropped DCP.
(for example make a 16x9 mediafile from a 1.78 film in a pillar-boxed Flat/1.85 container)

carl

2019-11-04 09:05

administrator   ~0003539

@robn is there a Mantis bug for that?

carl

2019-11-04 09:06

administrator   ~0003540

@Carsten did you crop by exactly 279 on left only?

Carsten

2019-11-04 10:40

manager   ~0003541

Last edited: 2019-11-04 10:58

View 3 revisions

'@Carsten did you crop by exactly 279 on left only?'

No ;-)

robn - there may be some specific values causing this. In 2.14.11, I just cropped a scope trailer and exported as MP4 without an issue.

Can you upload a metadata file with the values causing it?

  • Carsten

Carsten

2019-11-04 10:49

manager   ~0003542

Last edited: 2019-11-04 11:09

View 4 revisions

@ Carl - OS X 2.14.11 - add Scope DCP, set left crop to 279. Tried both by using the up/down arrows as well as input the number. No problem. Currently encoding...
Also tried no-stretch with it, and switched from flat to scope container. All encode without issues, although, aside from that, as in https://dcpomatic.com/mantis/view.php?id=1653 , with no stretch, cropping is not actually applied in the conversion of a DCP source.

Hmm, interesting - with the no-stretch option and only left crop 279, encoding runs through - but when I watch the DCP in player, some content is repeated on the right side of the resulting image...looks as if it is exactly the stripe that has been cropped off the left.

  • Carsten

carl

2019-11-04 11:07

administrator   ~0003543

It looks like an out-of-bounds read, so may not always crash. Should be fixed by b32d031762bc49d8d076d36c4a8c60fa175a94dc in master and 25d968fdcf1abada4bd7bbcb8c72eeebda73b134 in v2.15.x.

Carsten

2019-11-04 11:09

manager  

Bildschirmfoto 2019-11-04 um 12.09.05.png (1,150,860 bytes)

carl

2019-11-04 15:39

administrator   ~0003545

@carsten yeah, that too, fix coming up.

carl

2019-11-04 15:40

administrator   ~0003546

master also probably needs 7b0372776ac4da6a8e4ff29f41a4f08b9b4de506, following on from the initial fix for 0001654.

robn

2019-11-04 16:41

reporter   ~0003547

@carl: no I did not create a Mantis bug for it.

I've tried to create 1920x1080 .mp4 files from pillar-boxed 1998x1080 DCPs many times in the past.
The conversion ALWAYS crashed after a couple of minutes (I gave up on using it).

Funny thing is that now I fail to reproduce the bug with DOM 2.14.13 ..
I successfully converted a full feature movie. Maybe the problem has to do with sub-titling?
(the test movie was not subtitled). Running a new test with a subtitled movie now.
I will report the results!

robn

2019-11-04 17:07

reporter   ~0003548

OK, "fortunately" I just had a crash with creating a cropped .mp4 file from a subtitled pillar-boxed DCP with DOM 2.14.13.
This was with a commercial DCP which I can't share. I will try to create a test-DCP which also illustrates the problem.

What I do is this:

  • create new project
  • add 1998x1080 DCP
  • crop 39 pixels left and right (to get 1920x1080)
  • set output DCP container to 1920x1080
  • export .mp4 file (with burnt-in subs)
  • ==> crash after couple of minutes

robn

2019-11-04 21:26

reporter   ~0003550

I can reproduce the "crop & export" crash and have created a separate
bug report for it. Test-DCP is available. See:

https://dcpomatic.com/mantis/view.php?id=1656

carl

2019-11-04 21:53

administrator   ~0003551

Thanks @robn!

carl

2019-11-16 21:42

administrator   ~0003586

7b0372776ac4da6a8e4ff29f41a4f08b9b4de506 from v2.15.x backported to 7ec44b5c9f0cb6de128010a2c958ca4c353db3c9 in master.

Issue History

Date Modified Username Field Change
2019-11-04 00:03 carl New Issue
2019-11-04 00:03 carl Assigned To => carl
2019-11-04 00:03 carl Status new => confirmed
2019-11-04 00:03 carl Tag Attached: next
2019-11-04 00:42 Carsten Note Added: 0003535
2019-11-04 01:29 robn Note Added: 0003538
2019-11-04 09:05 carl Note Added: 0003539
2019-11-04 09:06 carl Note Added: 0003540
2019-11-04 10:40 Carsten Note Added: 0003541
2019-11-04 10:43 Carsten Note Edited: 0003541 View Revisions
2019-11-04 10:49 Carsten Note Added: 0003542
2019-11-04 10:50 Carsten Note Edited: 0003542 View Revisions
2019-11-04 10:51 Carsten Note Edited: 0003542 View Revisions
2019-11-04 10:58 Carsten Note Edited: 0003541 View Revisions
2019-11-04 11:07 carl Status confirmed => resolved
2019-11-04 11:07 carl Resolution open => fixed
2019-11-04 11:07 carl Note Added: 0003543
2019-11-04 11:07 carl Tag Detached: next
2019-11-04 11:09 Carsten Note Edited: 0003542 View Revisions
2019-11-04 11:09 Carsten File Added: Bildschirmfoto 2019-11-04 um 12.09.05.png
2019-11-04 15:39 carl Note Added: 0003545
2019-11-04 15:40 carl Status resolved => confirmed
2019-11-04 15:40 carl Target Version 2.14.x => 2.14.14
2019-11-04 15:40 carl Estimated work required => Undecided
2019-11-04 15:40 carl Note Added: 0003546
2019-11-04 16:41 robn Note Added: 0003547
2019-11-04 17:07 robn Note Added: 0003548
2019-11-04 21:26 robn Note Added: 0003550
2019-11-04 21:53 carl Note Added: 0003551
2019-11-16 21:42 carl Note Added: 0003586
2019-11-16 21:42 carl Status confirmed => resolved