View Bug Details

IDProjectCategoryView StatusLast Update
0001657DCP-o-maticBugspublic2022-03-16 13:27
ReporterCarsten Assigned Tocarl  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version2.16.x 
Summary0001657: KDM dialog tweaks
Description

When I quit the advanced KDM options (Watermarking) with 'Okay', the KDM creation window disappears - it goes behind the DCP-o-matic main window. That’s probably a bit surprising for beginners. Okay, beginners should not make KDMs or choose advanced options anyway ;-) This may only happen in OS X.

I created 6 different Sony SMPTE Test DCPs within the same film/project, carefully switching apps, renaming CPLs and changing encrypted checkbox.

I then went to creating the KDMs with the same project open in 2.15.17. I was able to select the three encrypted CPLs from the list/UUIDs, and their different CPLs were correctly displayed beneath - however, the %f flag in the KDM naming dialog is chosen from the current set CPL under DCP tab - not from the CPL that I selected above for the KDM creation.

In this case, the CPL name under DCP was still set for the last CPL I created - DOM21517 - but the CPL I selected for the first KDM to be generated was DOM21410.  The KDM file was hence named KDMDOM21517encLinden-Theater_FrechenSaal1.xml - but was created for the DOM21410 CPL. As this is only file naming, I changed it manually to KDMDOM21410encLinden-Theater_FrechenSaal1. Another consequence was that, since the selected %f under these conditions (multiple encrypted CPLs within one project) stays the same, the KDM writing will always use the same file name, thus overwriting previously generated KDMs.

So, long story short, I guess %f should not be taken from the currently set CPL name under the DCP tab, but from the chosen CPL in the KDM creation dialog. No big deal if you know what happens, but should probably be corrected - there certainly are good reasons that KDM file name and CPL name and annotation text in the KDM comply - even if users are probably not advised to have multiple different encrypted CPLs in their project.

TagsNo tags attached.
Branch1657-fix-kdm-filename
Estimated weeks required
Estimated work requiredSmall

Activities

carl

2022-03-05 10:35

administrator   ~0004910

Last edited: 2022-03-05 10:35

I see what you mean. At the moment the %f is replaced with the name of the project; I guess we should change this to be the <ContentTitleText> from the CPL... any thoughts?

Carsten

2022-03-06 01:10

manager   ~0004912

Yup, that would probably be best.

carl

2022-03-11 22:36

administrator   ~0004923

Last edited: 2022-03-15 08:31

@carl: re-running tests.

carl

2022-03-16 13:27

administrator   ~0004949

d5d9e143a5778928c5f386a7bd9cb140d4f1191a

Bug History

Date Modified Username Field Change
2019-11-04 22:36 carl New Bug
2019-11-04 22:36 carl Reporter carl => Carsten
2019-11-04 22:36 carl Estimated work required => Undecided
2019-11-04 22:37 carl Status new => acknowledged
2019-11-04 22:37 carl Estimated work required Undecided => Small
2022-02-16 23:33 carl Target Version 2.14.x => 2.16.x
2022-03-05 10:35 carl Assigned To => carl
2022-03-05 10:35 carl Status acknowledged => feedback
2022-03-05 10:35 carl Note Added: 0004910
2022-03-05 10:35 carl Note Edited: 0004910
2022-03-06 01:10 Carsten Note Added: 0004912
2022-03-06 01:10 Carsten Status feedback => assigned
2022-03-10 22:02 carl Status assigned => in progress
2022-03-10 22:02 carl Branch => 1657-fix-kdm-filename
2022-03-11 22:36 carl Note Added: 0004923
2022-03-13 21:17 carl Note Edited: 0004923
2022-03-15 08:31 carl Note Edited: 0004923
2022-03-16 13:27 carl Note Added: 0004949
2022-03-16 13:27 carl Status in progress => resolved
2022-03-16 13:27 carl Resolution open => fixed