View Issue Details

IDProjectCategoryView StatusLast Update
0001708DCP-o-matic[All Projects] Bugspublic2020-01-07 14:21
Reporteroverlookmotel Assigned Tocarl  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS XOS Version10.14
Product Version2.14.15 
Target VersionFixed in Version 
Summary0001708: Error at end of encoding when trimming end of video file with non-integer frame rate
Description

I've come across a file where setting end trim causes an error at very end of encode.

Details of the case:

  • Content frame rate: 30000/1001 (0000039:0000029.97)
  • DCP frame rate: 30
  • End trim: 3 secs, 17 frames
  • Start trim: 4 secs, 26 frames
  • Position: 1 frame (i.e. one frame of black before content begins)

When I set end trim to 0, the encode completes without error.

I wonder if this is due to incorrect calculation of the TrimEnd value.

I calculate it should be 107 frames x 96000 / 30000 x 1001 = 342742.4. But TrimEnd value in metadata.xml is 342454.

This is in DCP-o-matic 2.14.19. I was getting quite a lot of these cases on previous versions of DCP-o-matic, but they seem rare now - this is the first I've encountered since upgrading to 2.14.19 a couple of weeks ago, and have made at least 20 DCPs from non-integer frame rate sources since.

Steps To Reproduce

Carl, I'll send you a repro case.

TagsNo tags attached.
Branch
Estimated weeks required
Estimated work required

Activities

carl

2020-01-07 13:41

administrator   ~0003708

Thanks. Should be fixed by 77c30a110a321b3b69259381a7f30c5c25f4da7c in v2.15.x and 0e86a5da67451dfc6120406e5282fc786de6e248 in master.

overlookmotel

2020-01-07 14:21

reporter   ~0003709

Thanks Carl!

Issue History

Date Modified Username Field Change
2020-01-06 21:21 overlookmotel New Issue
2020-01-07 13:41 carl Assigned To => carl
2020-01-07 13:41 carl Status new => resolved
2020-01-07 13:41 carl Resolution open => fixed
2020-01-07 13:41 carl Note Added: 0003708
2020-01-07 14:21 overlookmotel Note Added: 0003709