View Bug Details

IDProjectCategoryView StatusLast Update
0001736DCP-o-maticFeaturespublic2020-04-30 23:55
ReporterCarsten Assigned Tocarl  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformMacOSOS XOS Version10.12
Product Version2.16.0 
Target Version2.16.0 
Summary0001736: When using the Goto Time/Frame number in preview/player, propopulate fields with the current seek position
Description

When clicking on TC or frame number in DCP-o-matic preview or player, don't offer the time code or frame number input fields empty, but populate them with the current playhead position.

TagsNo tags attached.
Branch
Estimated weeks required
Estimated work required

Activities

carl

2020-04-29 21:15

administrator   ~0003788

Done in and around 40d38c8d011f0863f396f21cd750cdcef803a792

I've tried using "hints" (feint displays of the numbers you will get if you don't enter anything) to see if that's nicer than putting the numbers in "properly". Let me know what you think.

Carsten

2020-04-30 01:45

manager   ~0003791

I think populating them is better. Very often you do not want to change/input all fields, but only one or two, e.g. seconds, or frames. Having the other fields populated with the current playhead position allows this much faster.

Would also be nice to have <TAB> move between hh:mm:ss:ff fields.

  • Carsten

carl

2020-04-30 23:55

administrator   ~0003792

Maybe you can give it a try? I don't want to tell you how the current version behaves, so that we can see if it's intuitive :)

Tabbing between fields works for me... does it not work on macOS?

Bug History

Date Modified Username Field Change
2020-04-29 11:33 Carsten New Bug
2020-04-29 11:33 Carsten Status new => assigned
2020-04-29 11:33 Carsten Assigned To => carl
2020-04-29 21:15 carl Status assigned => resolved
2020-04-29 21:15 carl Resolution open => fixed
2020-04-29 21:15 carl Note Added: 0003788
2020-04-30 01:45 Carsten Note Added: 0003791
2020-04-30 23:55 carl Note Added: 0003792